EXCEL: Berechnung ENTWEDER ODER?

6 Antworten

Ich bin mir nicht sicher ob dir diese Formel zusagt, da du auf meine Fragen nicht geantwortet hast

=WENN(ZÄHLENWENN(B2:B3;"HS")>0;ZÄHLENWENN(B2:B3;"HS")*20;WENN(B2+B3>0;((B2+B3)+1)*24;WENN(B2+B3>0;((B2+B3)+1)*24;"")))

Die Formel wäre dann

=ZÄHLENWENN(B2:B3;"HS")*20+SUMME(B2:B3)*24

Wenn in beiden Zellen "HS" steht, wird das Ergebnis 40 sein, wenn zwei Zahlen drinstehen, wird die Summe der Zahlen mit 24 multipliziert. Wenn einmal HS und eine Zahl steht, wird 20 + Zahl*24 gerechnet.

Eine gute Anlaufstelle für Formellernen ist z.B. http://www.online-excel.de/ (dort bei Funktionen). Fortgeschrittenere Formeln findest du bei http://excelformeln.de/formeln.html

Ansonsten würde ich mal die Funktionsliste von Excel durchstöbern und mir die Hilfe zu den einzelnen Funktionen durchlesen. Bei youtube gibt es auch viele Tutorials.

=SUMME(WENN(ISTZAHL(B2:B3);B2:B3*24;0))+ZÄHLENWENN(B2:B3;"HS")*20

Mit Strg + Shift + Enter abschließen

alternativ zum array

=WENNFEHLER(WENN(B2="HS";20;B2*24);0)+WENNFEHLER(WENN(B3="HS";20;B3*24);0)

Stehen die Werte HS immer nur in diesen beiden Zellen?  Steht 0,5 oder 1 nur in einer Zelle oder kann es auch in 2 Zellen stehen?

Um auf den Wert 36 zu kommen muss die Formel (0,5+1)*24 bzw (1+1)*24 lauten

Was möchtest Du wissen?