Excel: auf Wochenende fallenden Termin auf Montag verlegen

2 Antworten

Stelle sicher, dass das Datum in Spalte A von Excel als Datum erkannt wird. Trage jetzt in D1 bis D15 (je nachdem wieviele du brauchst) die Daten der Feiertage ein (1.1.14, 6.1.14, usw.)

In B1 trägst du ein

=WENN(ZÄHLENWENN(D$1:D$15;A1)>0;A1+1;A1)

Diese Formel kopierst du nach unten. Jetzt stehen in Spalte B alle Daten aus A, bei den Feiertagen aber der nächste Tag.

In C1 trägst du ein

=WENN(WOCHENTAG(B1)=7;B1+2;WENN(WOCHENTAG(B1)=1;B1+1);B1))

und wieder nach unten kopieren. Jetzt sollten in Spalte C die Daten richtig stehen, mit auf Montag verschobenen Feiertags- und WE-Terminen.

Ich hab diese zweispaltige Lösung gewählt, weil ein Feiertag auf Freitag fallen könnte. Dann muss der Termin natürlich nicht auf den nächsten Tag (Samstag), sondern auf den nächsten Montag verschoben werden.

Auch wenn die Frage nicht von mir kam, Danke.

1
@beglo1705

Ganz lieben Dank! Jetzt habe ich wirklich eine Menge dazugelernt, das hilft auch für künftige Aufgabenstellungen. Hut ab vor euch hilfsbereiten Excel-Profis!

0

ohne Feiertage:

=WENN(WOCHENTAG(A1;2)>5;A1+2-REST(A1;7);A1)

besser da ohne kürzer und vor allem ohne WOCHENTAG

=WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1)

0
@augsburgchris

Letzte Variante (ohne Hilfsspalte, mit Feiertagen, ohne WOCHENTAG): Feiertage in D1:D20

=WENN(ZÄHLENWENN($D$1:$D$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))

1
@augsburgchris

Super, vielen Dank! Ich bin ganz "platt" über die Möglichkeiten von Excel und werde heute gleich damit loslegen!

1
@Skyliner67

DH!
hab es nicht geschafft, mein nebulöses Konzept scharf zu formulieren!

Nur eine Einschränkung: an Weihnachten funktioniert das vermutlich wegen der zwei Feiertage nicht, ist sicher zu verschmerzen, sollte Skyliner aber wissen!

Und der "schmotzige Donnerstag" ist ebenso wie der Rosenmontag selten in einer Feiertagsliste zu finden!

0
@Iamiam

Damit es auch mit 2 Feiertage hintereinander klappt:

=WENN(ZÄHLENWENN($I$1:$I$20;WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1)))>0;WENN(REST(WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+1;7)<2;WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+1+2-REST(WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+1;7);WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+1);WENN(REST(WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1));7)<2;WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+2-REST(WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1));7);WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))))

PS: bei 3 Feiertagen macht die Formel schlapp da ich nur 8192 Zeichen pro Formel habe.

0

Excel-Vergleich: 2x2 Spalten miteinander vergleichen und den Inhalt einer fünften Spalte ausgeben?

Hallo zusammen,

Ich möchte die Routen-ID (A) und die dazugehörige Sender Location (B) aus Reiter 1 mit der Routen-ID (C) und der Sender Location (D) aus Reiter 2 vergleichen. Bei Übereinstimmung möchte ich die dazugehörige Distance in km aus (E) in einer Spalte (F) ausgeben.

Excel Reiter 1: Daten

  Routen-ID (A)             Sender Location (B)

1 DE24DE40                 Remscheid

2 DE25DE40                  Alsdorf

3 …

 Excel Reiter 2: Routen-Distanz

  Routen-ID (C)               Sender Location (D)                   Distance in km (E)

1 DE24DE40                   Remscheid                                               32,2

2 DE25DE40                    Alsdorf                                                     85,4

3 …

Bei einem Vergleich ohne die Sender Location zu berücksichtigen habe ich es folgendermaßen gelöst:

=WENN(ISTNV(VERGLEICH(A1;'Routen-Distanz'!C:C;));"";INDEX('Routen-Distanz'!E:E;VERGLEICH(Daten!A1;'Routen-Distanz'!C:C;)))

Die Sender Location ist notwendig, da eine bestimmte Routen-ID mehrere Sender Location haben kann und somit andere Distanzen zu berücksichtigen sind. Zur eindeutigen Zuordnung muss daher ein weiteres Merkmal, in dem Fall die Routen-ID hinzugezogen werden.

 (F)

=?

Ich freue mich über eure Antworten.

VG

...zur Frage

Excel bedingte Formatierung Datum markieren?

Hallo, weiss jemand wie die Excel Formel aussieht für folgendes vorhaben.

In einer Spalte ist ein Datum eingetragen. Diese Spalte ist ohne farbliche Formatierung.

Nun soll sich die Spalte farblich markieren sobald das Datum in 3 Tagen fällig ist.

Zum Beispiel: In Spalte A Datum 12.10.2016

Diese Spalte soll nun ab dem 09.10.2016 automatisch rot markiert werden.

Wie mache ich das mit einer Formel?

...zur Frage

Excel: Was bedeutet das * Sternchen in einer Formel?

Also, ich habe da eine Tabelle geschickt bekommen zur Lohnberechnung/ Gewinnermittlung eines Tages (Bruttoeinnahme und Nettoeinnahme) und in dem Feld das die Nettoeinnahme beziffern soll ist folgende Funktion eingefügt:

=L3-(I3+K3)*1,24

In L3 steht der Bruttolohn, in I3 der Bruttoverdienst des Tages und K3 ist das anteilige Weihnachtsgeld für diesen Tag.

Was genau macht das * für eine Funktion? In Verbindung mit der 1,24?

Danke schön!

...zur Frage

Excel-Pro text +1 addieren?

Hallo ist es möglich mit einer Excel Funktion in Excel einen Wert pro Feld auszugeben, wenn ein Text darin steht? Angenommen in A1 bis E1 (5 Zellen) steht jeweils ein Text mit 1 Wort. Nun will ich daneben in 1 Zelle sehen, wie viel Wörter das sind. Anderes Beispiel: In Zelle A1, C1, D1 und E1 (4 Zellen; ohne B1) steht jeweils 1 Wort. Nun möchte ich durch die Funktion ausgegeben bekommen, dass 4 Wörter im Zellbereich A1:E1 stehen. Bitte HIlfe :)

...zur Frage

Excel ZÄHLENWENN das Datum am Wochenende ist?

Hallo an alle!

Ich habe in Excel eine Spalte mit verschiedenen Datum's (manchmal Wochenende), Neben dieser Spalte sind zu diesen Datum's verschiedene Zeiten (0:30 min, 0:40 min etc.)

Ich möchte nun: a) Zählen wie oft Das Datum ein Wochenende, sprich Samstag und Sonntag ist und b) die Summe der Zeiten zählen, welche zu der Zeile gehören, wo das Datum ein Wochenende ist.

Ich habe es mit ZÄHLENWENN und weiteres versucht, hat aber leider nie funktioniert.

Wäre euch sehr dankbar für eure Hilfe.

Danke! :)

...zur Frage

Excel Mit Sverweis Datum vergleichen

Hallo zusammen :)

Ich habe in Excel ein Liste in Spalte B und eine Zelle 1 mit einem Datum drinnen. Nun soll Excel für mich überprüfen, ob das Datum in der Liste enthalten ist und dann in einer anderen Zelle mit Wahr (also das Datum ist in der Spalte enthalten) oder Falsch (das Datum ist nicht in der Liste enthalten) antworten. Außerdem soll die Zelle 2, wenn als Antwort Wahr kommt, einen grünen Hintergrund haben und wenn als Antwort falsch kommt, soll die Zelle rot gefüllt werden. Ich hab es jetzt schon mit der Funktion sverweis probiert, aber Excel meldet nur: "#Bezug!" Könnt ihr mir weiter helfen?

Lg

...zur Frage

Was möchtest Du wissen?