Excel: auf Wochenende fallenden Termin auf Montag verlegen

...komplette Frage anzeigen

2 Antworten

Stelle sicher, dass das Datum in Spalte A von Excel als Datum erkannt wird. Trage jetzt in D1 bis D15 (je nachdem wieviele du brauchst) die Daten der Feiertage ein (1.1.14, 6.1.14, usw.)

In B1 trägst du ein

=WENN(ZÄHLENWENN(D$1:D$15;A1)>0;A1+1;A1)

Diese Formel kopierst du nach unten. Jetzt stehen in Spalte B alle Daten aus A, bei den Feiertagen aber der nächste Tag.

In C1 trägst du ein

=WENN(WOCHENTAG(B1)=7;B1+2;WENN(WOCHENTAG(B1)=1;B1+1);B1))

und wieder nach unten kopieren. Jetzt sollten in Spalte C die Daten richtig stehen, mit auf Montag verschobenen Feiertags- und WE-Terminen.

Ich hab diese zweispaltige Lösung gewählt, weil ein Feiertag auf Freitag fallen könnte. Dann muss der Termin natürlich nicht auf den nächsten Tag (Samstag), sondern auf den nächsten Montag verschoben werden.

Auch wenn die Frage nicht von mir kam, Danke.

1
@beglo1705

Ganz lieben Dank! Jetzt habe ich wirklich eine Menge dazugelernt, das hilft auch für künftige Aufgabenstellungen. Hut ab vor euch hilfsbereiten Excel-Profis!

0

ohne Feiertage:

=WENN(WOCHENTAG(A1;2)>5;A1+2-REST(A1;7);A1)

besser da ohne kürzer und vor allem ohne WOCHENTAG

=WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1)

0
@augsburgchris

Letzte Variante (ohne Hilfsspalte, mit Feiertagen, ohne WOCHENTAG): Feiertage in D1:D20

=WENN(ZÄHLENWENN($D$1:$D$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))

1
@augsburgchris

Super, vielen Dank! Ich bin ganz "platt" über die Möglichkeiten von Excel und werde heute gleich damit loslegen!

1
@Skyliner67

DH!
hab es nicht geschafft, mein nebulöses Konzept scharf zu formulieren!

Nur eine Einschränkung: an Weihnachten funktioniert das vermutlich wegen der zwei Feiertage nicht, ist sicher zu verschmerzen, sollte Skyliner aber wissen!

Und der "schmotzige Donnerstag" ist ebenso wie der Rosenmontag selten in einer Feiertagsliste zu finden!

0
@Iamiam

Damit es auch mit 2 Feiertage hintereinander klappt:

=WENN(ZÄHLENWENN($I$1:$I$20;WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1)))>0;WENN(REST(WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+1;7)<2;WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+1+2-REST(WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+1;7);WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+1);WENN(REST(WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1));7)<2;WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))+2-REST(WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1));7);WENN(ZÄHLENWENN($I$1:$I$20;A1)>0;WENN(REST(A1+1;7)<2;A1+1+2-REST(A1+1;7);A1+1);WENN(REST(A1;7)<2;A1+2-REST(A1;7);A1))))

PS: bei 3 Feiertagen macht die Formel schlapp da ich nur 8192 Zeichen pro Formel habe.

0

Was möchtest Du wissen?