excel 2010 namen zuordnen

4 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Angenommen, in Tabelle1 stehen die Kundennummern in Spalte A und die Namen in Spalte B. In Tabelle 2 stehen die Kundennummern in Spalte A und die E-Mails in Spalte B.
Dann in C1 dieser Tabelle diese Formel (und runterkopieren):

=SVERWEIS(A1;Tabelle1!A:B;2;0)

oder:

=INDEX(Tabelle1!B:B;VERGLEICH(Tabelle2!A1;Tabelle1!A:A;0))

HIlft Dir das weiter?

Die bisherige Antwort enthält ja schon ein wenig Inhalt (Link), aber um hier zu helfen, ist etwas mehr Information nötig.

Als erstes fällt auf, dass in der Frage eine "Zeile A" angesprochen wird.
Da in Excel die Spalten mit Buchstaben versehen sind (die Zeilen mit Zahlen), ist also unklar, wie die Herkunftsdaten organisiert sind. Weiterhin ist es nötig zu wissen, ob die Daten in irgendeiner Weise sortiert sind.

Es wäre also angebracht, entweder
- eine ganauere Beschreibung der Daten oder
- zwei Screenshots (hierzu muss eine "neue Antwort" gemacht werden)
beizufügen.

Gruß aus Berlin

Bei OpenOffice funktioniert die folgende Formel für den Fall, dass beide Tabellen in einem Dokument sind.

=WENN(Tabelle1.A1=Tabelle2.A1;Tabelle1.B1)

Excel VBA, automatische Befüllung der ersten freien Zeile in mehreren Spalten mit Informationen

Hi,

ich werde langsam wahnsinnig mit den Mengen an echt schlechten Codebeispielen, die man im Netz findet. Ich habe eine sehr konkrete Frage zur Übertragung von Daten zwischen Tabellen. Szenario: Kundendaten werden in der Tabelle Auftragsannahme erfasst. Nach der Erfassung kann der Kunde in die Kundenliste übernommen werden. Spalte A bis I mit Kundennummer, Anrede, Vorname, Nachname, Adresse, PLZ, Ort, Email, Zahlungsbedingungen. Der Code muss also zunächst die nächste freie Zeile in der Kundenliste ermitteln. Dies ist Zeile 28 im laufenden Beispiel. Dann muss er die Werte aus der Auftragsannahme korrekt in die Kundenliste überführen. Kundennummer von H6 in Spalte A, Anrede von D4 in Spalte B und so weiter.

Ich habe nun bereits folgenden Code generiert: Worksheets("Kundenliste").Cells(Range("A1").End(xlDown).Row + 1, 1).Value = _ Worksheets("Auftragsannahme").Range("H6") 'Kundennummer

Dieser Code ermittelt erfolgreich das Feld A28 als erste leere Position und trägt die Kundennummer dort ein. So weit so gut. Wenn ich aber auf diese Art weitermache, also mit:

Worksheets("Kundenliste").Cells(Range("B1").End(xlDown).Row + 1, 2).Value = _ Worksheets("Auftragsannahme").Range("D4") 'Anrede

Dieser Code überschreibt den ersten Kunden in Zeile 3, anstatt bis zur freien Zeile 28 hinunterzuspringen.

Nun ist meine Frage: Wie schreibe ich es, dass auch die Anrede (und die 6 weiteren Informationen, die dann noch folgen) korrekt in die nächste freie Spalte transferiert werden und mir nicht meinen ersten Kunden in Zeile 3 überschreiben?

Danke schonmal!

...zur Frage

Excel-Tabelle in Word 2010 bearbeiten!

Ich hab eine Excel-Tabelle in Word 2010 eingefügt und eine Tabelle erstellt. Dazu noch n Makro geschrieben und das alles gespeichert. Nun hab ich aber das Problem, dass die Excel-Tabelle in eine Grafik umgewandelt wurde. Ich hab da sehr viel Zeit hineininvestiert, aber ich weiß einfach nicht wie ich das bearbeiten kann. Kann mir bitte bitte jemand helfen?

...zur Frage

Kann excel muster in zahlen oder wörtern erkennen?

Gibt es eine möglichkeit das excel muster wie "HALLO" oder "12338" erkennt und sie so aus einer reihe zahlen denen zuordnet die auch aus 4 verschiedenen ziffern bestehen und die 3. und die 4. gleich sind?

...zur Frage

Excel 2010: erste Zeile festmachen

Hallo, ich suche die Funktion für Excel 2010 bei der man die erste Zeile einfriert, das heißt dass man sortieren kann, ohne dass die erste Zeile in die restlichen zeilen "wegrutscht"

(ich meine nicht das mit dem Frame, sodass die fest ist und man scrollen kann und immer die erste Zeile sieht)

...zur Frage

Bei Speichern von Excel in CSV Datei wird die Namensdefinitionen nicht übenommen

Hallo, ich habe folgendes Problem. Ich muss Email Adressen aus einer Excel Datei in Outlook überspielen. Zuerst habe ich die Ecxel Datei in CSV abgespeichert. Dann in Outlook importiert. Ergebnis war, das die Spalten aufgelöst wurden und alle Angaben in einer langen Zeile importiert wurden (so: Name;Wohnort;Email;etc.) Dann habe ich herausgefunden, dass ich die einzelnen Spalten erst mit Namen definierten muss. Das habe ich dann in der ursprünglichen Ecxel Datei gemacht (Office 2010). Nach dem abpeichern in CSV waren dann allerdings die Namensdefinitionen verschwunden. Dann habe ich die Namen in der CSV selbst definiert und abgespeichert. Nach erneutem schließen und öffnen der CSV Datei waren die Namen aber wieder verschwunden. Kann mir jemand sagen, was ich falsch mache? [vermutlich alles :) ] Danke und Gruß

...zur Frage

Excel Tabelle in eine lange Zeile verwandeln?

Hallo Ich habe eine lange Liste mit Namen und zugehörigen Daten die momentan in einer Tabellen untereinander stehen.

Ich möchte die Tabelle so umändern das nachher alle Daten die zu einem Namen gehören in einer Zeile hintereinander stehen. Also transponieren hilft da leider nicht, weil dann die Daten auch untereinander stehen, will eine lange foltlaufende Liste in einer Zeile. Kann mir jemand einen Tipp geben wie man das bei Excel macht.

...zur Frage

Was möchtest Du wissen?