Excel Getränkeautomat

...komplette Frage anzeigen

4 Antworten

Mittlerweile hast Du Dich sicher schon ausreichend mit der Frage herumgeschlagen, so dass ich Dir meinen Lösungsvorschlag komplett zukommen lassen kann (siehe Screenshot: oben die Formeln, unten die zugehörigen Werte, Excel-Formelschema Getränkeautomat):

Excel-Formelschema Getränkeautomat - (Excel, Tabellenkalkulation, getränkeautomat)

Ich will dir jetzt nicht alles vorkauen, aber du wirst eine WENN()-Funktion brauchen. Am besten schaust du dazu mal in die Hilfe von Excel. Da werden die funktionen sehr schön erklärt. Die funktion muss sich in dem FGeld befinden, wo du die Aussage haben willst, ob dein Betrag ausreicht oder nicht.

Kleines Beispiel:

Du willst eine Aussage darüber, ob in Feld A1 eine Zahl größer als 0 steht:

Formel (in z.B. Zelle B1): =wenn(A1>0;"Wert ist größer als 0";"Wert ist kleiner oder gleich Null")

Hallo junge,

wenn Preis und Einwurf in B2 und C2 stehen, dann würde ich diese Formel in D2 schreiben:

D2: =WENN(C2>B2;"Rückgeld: "&TEXT(C2-B2;"0,00 €");WENN(C2<B2;"Zuzahlung: "&TEXT(B2-C2;"0,00 €");("Warenausgabe erfolgt")))

diese Formel kannst du für alle Getränkearten nach unten kopieren.

LG Distel

Mit diesen Informationen könnte ich das auch nicht.

junge2012 24.10.2012, 13:27

Das soll so funktionieren

Du hast ein Feld für dein guthaben. Wenn die Flasche Cola 1.00€ kostet dann kannst du ja z.B. 2,00€ einwerfen.

So dann muss es ein feld geben wo drinnen steht: Ihr getränk kommt gleich Rückgeld 1,00€.

Das dies funktionieren kann muss das Feld wo du das geld "reinwirfst" einen höheren Wert haben als die Cola kostet.

Wenn man weniger geld einwirf muss da stehen: Guthaben nicht ausreichend. Hoffe mir kann jetzt jemand helfen.

0

Was möchtest Du wissen?