Wie kann ich in einer Excel Tabelle alle Zellen in denen "0" steht in leere Zellen verwandeln?

3 Antworten

Es sind verschiedene Möglichkeiten vorhanden und die hängen davon ab wie die „0“ dort hingekommen sind.

Würden die einfach alle manuell herein gegeben und anstatt alle „0“ zu löschen suchen Sie ein sogenannten „Shortcut“ um alle mit einen Mouse-Click zu löschen?

Dann selektieren Sie alle Zellen bzw. alle Spalten oder Zeilen in der die ungewollte „0“ sich befinden. Öffnen Sie die Registerkarte „Suchen und Auswählen“ (befindet sich in Registerkarte Start, ganz rechts) und wählen Sie „Ersetzen“. Schreiben Sie ein „0“ bei „Suche nach“ und lassen Sie das Feld „Ersetzen durch“ leer, und schließlich drucken Sie der Taste „Alle ersetzen“.

Dass gleiche können Sie auch machen um alle Zellen wo „ja“ steht in „1“ zu verwandeln (Suche nach: Ja, Ersetzen durch: 1 ) und dass gleiche um alle leere in „0“ zu verwandeln (Suche nach: leer lassen, Ersetzen durch: 0 )

Wenn das nicht der Fall ist sondern die „0“ Ergebnisse von eine Formel sind, und Sie wollen entweder eine Ergebnis die mehr als „0“ ist oder ein leere Zelle.

Dann haben Sie die Möglichkeit Ihre Formel so zu schreiben dass wenn seine Ergebnis „0“ betrefft, bleibt die Zelle leer.

Nehmen wir ein Beispiel: Sie wollen in Zelle A11 die Total von Zellen A1 bis A10. Formel: =WENN(SUMME(A1:A10)<=0;"";SUMME(A1:A10))

Die gleiche Bedingung können Sie zu jeder Formel hinzufügen.

schon einige Zeit her, aber falls noch weiter von Interesse:

Formelergebnisse mit Wert 0 werden so nie entfernt!

Bei dem mit Strg+h aufgerufenen Feld gibts noch die Schaltfläche Optionen.
Hier unbedingt die Option "gesamten Zellinhalt vergleichen" anhaken, weil sonst auch zB 100 zu 1 und 101 zu 11 wird!

im Übrigen ist eine Formel, die "" (leer) ergibt, nicht wirklich leer!
Man kann das sehen, wenn man den Cursor einige (Leer-)Zellen drunter setzt und dann Ende nach_oben drückt: Der Cursor bleibt auf dieser Formelzelle stehen!
Sowas zu entfernen, geht m.W. nur mit einem (einfachen) Makro:

Sub AlleNullZellenLeeren()
Dim c
For each c in selection
if c.value = 0 then c.value = ""
Next c
end sub

0
@Iamiam

war missverständlich: obiges Makro entfernt die Werte und Formeln, die 0 ergeben.

Formeln, die 'leer' ergeben, werden möglicherweise nicht erfasst (mag ich aber jetzt nicht ausprobieren)

Und Du könntest auch schon per Makro verhindern, dass eine einzelne Null überhaupt eingegeben wird!

0

Wenn du Strg + H drückst, kannst du nach Ja suchen und bei Ersetzen 1 schreiben.

leere Zellen kannst du so nicht mit 0 füllen!

Nur ich denke, dass du diesen Vorgang automatisch erfolgen lassen möchtest?! Ich meine, es geht nicht.

ich möchte die Tabelle markieren und danach soll das was ich möchte passieren. Ist es vielleicht mithilfe einer Formatierung möglich

0
@Jaiio

Soweit ich weiß, wird es nicht gehen, denn in den Zellen daneben müsste eine Formel stehen, die auf die vorhergehende Zellen Bezug nimmt.

Sonst beschäftige dich mal mit Zirkelbezug Excel bei Google eingeben

0

[STRG] + [H]

Was möchtest Du wissen?