Ist es möglich,wenn in einer Zelle ein Wert drin steht <>"", dass dann ein Datum aus einer anderen Zelle gleiche Spalte ausgeworfen wird?

...komplette Frage anzeigen

2 Antworten

ich denke, Du meinst Zeile un d Zellen in verschiedenen Spalten?
Erstreckt sich Deine Ausgabeezeile ebenfalls über die Spalten N:AZ? oder
sollen das 4 Zellen nebeneinander sein? Ersteres wäre halbwegs einfach:

füge eine neue Zeile oberhalb ein (als Zeile1, kannst Du später nach weiter unten versetzen) und belege die ZelleM1 mit der abzufragenden Zeilennummer (lt. Beispiel: 80), dann in N1 die Formel:

=WENN(INDEX(INDIREKT($M$1&":"&$M$1);SPALTE(N1))<>"";AD4;"-")

[N4, weil Zeile 3 durchs Einfügen einer neuen Zeile zu N4 wurde] das als Datum formatieren und nach rechts kopieren bis AZ1

Soll das aber auf vier Spalten komprimiert werden, dann ebenfalls in M1 die gewünschte Zeile, in N1 (meinetwegen auch N2 oder sonstwo) die Formel:

=SUMMENPRODUKT(INDIREKT(ADRESSE(4;KGRÖSSTE((INDIREKT("N"&$M$1&":AZ"&$M$1)<>"")*SPALTE($N:$AZ);4))))

Die Formel ist mir jetzt zu umständlich, um sie auf Verdacht hin zu erklären, nimms hin und frag ggf zurück!

diese Formel nur 1 nach rechts kopieren, dann das );4)))) durch );3)))) ersetzen, wieder eins nach rechts, durch ;2) und zum letzten mal eins nach rechts und ;1) reinschreiben, das ist das K von Kgrösste

(Du hast ja gesagt, max. 4 Einträge).

Für mehr  Einträge würde es sich lohnen, das mit irgendeiner Spalte()-Anzahl()-KombiFunktion (ab Spalte N) zu automatisieren oder mit KKleinste zu arbeiten, aber KKleinste macht Komplikationen mit Leerzellen, und dann würds völlig undurchschaubar!

Jetzt hab ich das mit den € 200000 vergessen: morgen dann!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von steppi1980
19.01.2016, 11:36

Hi Lamiam,

danke für die Rückantwort. Korrekt ich meinte Zeile und nicht Zelle und ja die Ausgabezelle ist ebenfalls von N:AZ.

Trotzdem bekomme ich es derzeit nicht hin. :(

Meine/ Deine Formel steht in N1:  =WENN(INDEX(INDIREKT(N80&":"&N80);SPALTE(N80))<>"";N3;"-")

Die Spalte die ausgegeben werden soll, somit die Datumsspalte steht in Zelle N3 und die Zelle die den Wert beinhalten könnte steht in N80. Leider bekomme ich in N1 nur einen Bezugsfehler gezeigt :(.

Der erste Wert steht derzeit in Zelle U80, da zeigt er logischerweise auch einen Bezugsfehler an. 

Sorry aber deine Formel ist mir derzeit ein bisschen zu hoch! ;) :(

Gruß

Stefan

0

Das erste wäre: =INDEX(N3:AZ3;1;VERGLEICH(A1;N80:AZ80;0))
Unter der Annahme, dass der zu suchende Wert in A1 steht. Habe ich es aber richtig verstanden, dass genau dieser Wert mehrfach vorkommen kann? Das wäre etwas haarig.

Das zweite (auch hier nur, wenn 1 Wert über 200.000 ist)
=WENN(MAX(DL232:GB232)>200000;INDEX(DL231:GB231;1;VERGLEICH(MAX(DL232:GB232);DL232:GB232;0));"")

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von steppi1980
18.01.2016, 10:30

Hi,

danke für deine Antwort. Leider können mehrere Werte in der Spalte stehen und es gibt auch keinen Suchwert, der Wert ist '<> "" '. 

Zur 2. Fragen, in der Regel, steht nur ein Wert über 200.000 in der Zeile, aber wenn es mehrere sind, dann wäre es super, wenn er diese Werte auswerfen könnte. 

Noch mal danke für deine Hilfe,

Stefan 

0

Was möchtest Du wissen?