in Excel alle Zeilen löschen, falls der Spalte O (mit Datum-Werten (03.05.1997 usw)) das Datum kleiner gleich 31.12.2004 ist?

2 Antworten

Das geht zwar auch mit einer - anderen - Formel, aber so wie ich das sehe ist das eine einmalige Aktion. Also warum nicht:
Die Tabelle nach Spalte O sortieren.
Alle Zeile bis 2005 löschen.
Die Tabelle wieder nach z.B. den Namen oder Eintrittsdaten sortieren, oder wie immer sie vorher sortiert war.

P.S.: Zum Beispiel diese Formel würde funktionieren:

=WENN(A1<=38352;"löschen";"")

1

So wie du das mit =wenn() versucht hast, geht das nicht. Abgesehen davon, dass das Datum eine Zahl ist und der Wert in der Wenn-Funktion als String behandelt wird, wird dir die Funktion nur das Wort "löschen" in die Zelle schreiben.

Was du vorhast, geht nur über ein VBA-Makro.

Was möchtest Du wissen?