Wie in Excel alle Suchwerte ausgeben, statt mit dem SVERWEIS, der nur den ersten Wert liefert?

2 Antworten

Probier es mal mit der Pivot Table Funktion. Du markierst deine Tabelle und nimmst im Reiter "Einfügen" "Pivot Table". Das soll dir Excel in einem neuen Tabellenblatt darstellen. Dann klickst du in den leeren Table und rechts öffnet sich das Pivot-Menü.

Dann ziehst du beispielsweise "Datum" in das entsprechende Feld in das Pivot Menü (glaube oben rechts)

"Aufgaben" ziehst du dann in das gleiche Feld, aber unter "Datum"

Schwer zu erklären, probier das mal aus. Ansonsten eventuell mit =mtrans( aber da musst du vorher den Bereich markieren (also die Anzahl der Zellen) wo die einzelnen Datumswerte erscheinen sollen und musst dann strg+umschalt+enter drücken, wenn ich das noch richtig im Kopf habe. Falls das nicht funktioniert schreib, dann probier ich das mal an einem Rechner der Excel drauf hat... sry für die unpräzise Erläuterung.

Danke, werd ich versuchen. Wird schon klappen.

0

Excel sverweis weitersuchen Bezug in anderer Tabelle

Hallo Community,

Ich habe ein Problem: Ich habe 2 Tabellen. In einer sind die Spalte folgendermaßen. Artikel, Artikelnummer, EAN (diese ist leer), Preis (der Richtige). In der 2. Tabelle sind die Spalten. Artikel, Artikelnummer, EAN (hier steht er auch drin), Preis (der Falsche)

Ich habe als Bezug in beiden Tabellen die Artikelnummer aber in Tabelle 1 leider keinen EAN. Das Problem ist das es zu jeder Artikelnummer in Tabelle 2 mehrere EAN gibt, sodass ich mit einem normalen Sverweis immer nur den ersten EAN in die Tabelle 1 bekomme. Ich brauche aber zu jeder Artikelnummer in Tabelle 1 jeden verfügbaren EAN aus Liste 2 der zu dieser Artikelnummer passt. Dieser sollte in eine Zelle, wobei jeder EAN beim scannen noch einzeln findbar sein muss. Den Sverweis den ich bis jetzt benutzt habe habe ich mal eingefügt.

=WENN(H6<1;"";SVERWEIS(H6;Tabelle3!$A$1:$V$21024;2;))

ich wäre froh und dankbar wenn mir Jemand helfen könnte :)

MFG EXCELROOKIE

...zur Frage

Excel soll Automatisch Text ausfüllen wenn eine Zahl angegeben wird?

Hallo

Ich bekomme eine Liste mit Zahlen und muss diese dann in Excel eintragen, bzw. Raussuchen welches Wort zu welcher Zahl passt und dann das noch eingeben. Excel soll dann anhand der von mir angegeben Zahl in einerm anderen einen Passenden Text hinsetzten. Wenn aber nichts da steht soll da nicht WERT oder NAME oder so stehen sondern es soll leer bleiben.

Beispiel Ich bekomme die Liste Name | Datum | Objekt

Das Objekt ist nur eine Zahl

Hans | 1.6.16 | 5

Excel soll mir dann neben der Zahl das Objekt in Worte fassen

Hans | 1.6.16 | 5 | Garten

Wenn dann aber bei der Objekt Zahl noch kein Wert drin steht soll da auch nichts stehen. Auch kein Fehler.

Zudem möchte ich die Formel eingeben können und einmal nach unten ziehen und nicht jedesmal alles eingeben müssen.

Ich habe alle Werte in der Selben Arbeitsmappe in Tabelle 2 eingegeben. In Tabelle 1 Arbeite ich.

Tabelle 2 sieht in etwa so aus

1 | Wohnung 2 | Haus 3 | Platz 4 | Abstellraum 5 | Garten

Habe dann versucht das ganze mit sverweis zu lösen.

=SVERWEIS(B1;Tabelle2!A1:B16;2)

Sprich Wenn in B1 eine Zahl steht; Aus Tabelle 2 A1-B16; in der zweiten spalte dann soll er das Wort dahinter nehmen.

Klappt soweit ziemlich gut, nur Probelem sind trotzdem da.

  1. Wenn noch Kein Wert (Zahl) in Tabelle 1 steht dann steht da #NV Wie bekomme ich das Weg?

  2. Ich kann die Formel nicht runter ziehen sonst werden alle Werte geändert

=SVERWEIS(B1;Tabelle2!A1:B16;2) =SVERWEIS(B2;Tabelle2!A2:B16;3) =SVERWEIS(B3;Tabelle2!A3:B16;4)

jedoch sollte es beim runterziehen der Formel so aussehen:

=SVERWEIS(B1;Tabelle2!A1:B16;2) =SVERWEIS(B2;Tabelle2!A1:B16;2) =SVERWEIS(B3;Tabelle2!A1:B16;2)

Weil die Matrix (A1:B16) bleibt ja die selbe.

Bin dankbar über jeden Rat. Es muss nicht mit sverweis gelöst sein. Jedoch suchen und ersetzen ist auch keine Option, da es zum einen mehr aufwand ist und zum anderen benötige ich ja die Zahl und das dazugehörige Wort.. Geht aber auch nicht immer.

Danke euch Gruss Grischabock

...zur Frage

Sverweis über eine ganze Spalte ohne dass sich der Berreich des Nachschlagewerts verändert?

Wahrscheinlich sind es nur ein paar clicks, aber bis jetzt habe ich keine Lösung gefunden. Ich möchte eine Spalte einfügen die dem Begriff in der Spalte davor einem Wert zuordnet. Der Wert steht in einer separaten Tabelle auf einem anderen Blatt. Ich habe dafür Sverweis geschrieben, als Suchkrieterium die Zelle links, als Bereich die erste und letzte Zelle der Tabelle auf der anderen Seite, den Spaltenindex und false, und dann die eine Zelle bis nach unten gezogen.

Für die ersten Zellen hat das funktioniert, für die weiteren steht nur NV da, das liegt daran dass jede Zelle den Bereich der Matrix um 1 ändert. War der Bereich in der ersten Zelle, A1:B3 ist er in der zweiten A2:B4, in der dritten A3:B5. Das passiert auch wenn ich als Suchkriterium die gesamte linke Zeile auswähle. Natürlich lässt sich das manuell die Matrix in jeder Zeile bearbeiten, aber es würde mich wundern wenn es kein simple, schnelle Lösung gibt mit der Ich die Formel beliebig weit ziehen kann und sich nur das Kriterium anpasst.

LG Max

...zur Frage

Was möchtest Du wissen?