Minecraft Plugin mit Gui geht nicht?

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Ist ein Fehler im Plugin selber (wenn keine anderen Plugins als ‚benötigt‘ markiert sind)

Vielleicht liegt es an der Version von Spigot.

Auf welcher Version läuft dein Server?

Tausche die Version mal aus und versuch es dann nochmal!

Alle Programmierten Plugins Laufen Zwar (In manchen fällen ) Über spigot Aber schon beimprogrammieren sollte man sehen das da zum beispiel nicht steht

bsp.

spigot.runnable

sondern auch bei spigot plugins steht

bukkit.runnable

also theroretisch kannst du Spigot Plugins Auf Bukkit/CraftBukkit nutzen und andersrum da es sich nicht viel nimmt aber bei manchen plugins kann es dort aber wirklich daran lieben ^^ =)

0

Da hat der Pluginersteller wohl geschlampt

Minecraft Server mit Plugin gehackt!?

Hey, ich habe einen Minecraft Server bei MC-HOST24.de gehostet (Spigot 1.8.8). Jedoch habe ich ein großes Problem: Ich suche Developer für meinen Server. Jemand hat sich gemeldet und hat mir dabei das CashPloit Plugin "angedreht". Damals (glaube am 21.6.17) kannte ich dieses Plugin noch nicht (CashPloit = Grief- & HackPlugin - Jeder Spieler kann +op name eingeben und ist op, das geht mit allen Commands. Nur ein '+' davor). Dass sich Spieler OP geben können, habe "ich" behoben (Plugin: NOOP), aber die "Hacker" können wie gesagt alle Commands mit einem '+' davor auch schreiben. CashPloit wurde von CashDeZZ (oder so ähnlich) gecodet und ich habe dieses Plugin natürlich sofort gelöscht. Aber: Es hat (laut der "HackerGruppe") andere Plugins infiziert und es geht immernoch. Bevor mir jemand sagt, ich solle doch Backups hochladen - Ja. das ginge. Aber das letzte Backup habe ich leider erst vor einem Monat gemacht (besser als nichts aber in der Zwischenzeit hat sich sehr viel geändert). Nun zur Hauptfrage: Kennt jemand ein Plugin, dass das (gelöschte) CashPloit Plugin ausser gefecht stellt? Das Plugin: https://dev.bukkit.org/projects/antivirus geht bei mir nicht, da sich der Server nicht mehr starten lässt, wenn das Plugin auf dem Server ist. Meine einzige Lösung sonst wäre, die Version Spigot 1.8 zu installieren da der Hack nur auf 1.8.8 funktioniert. Bestimmt funktioniert das nicht auf großen Servern wie GommeHD.net, das heißt, es muss eine Möglichkeit geben (ich weis, dass diese Server ein sehr gutes Developer Team hat und nicht mit anderen wie meinen zu vergleichen ist, aber fragen kostet nichts). Ich bitte sehr um Hilfe, weil mein Server damit schon über 15 mal gegrieft wurde und ich ihn nun nicht starten kann, weil zu viele Hacker kommen.

...zur Frage

Was möchtest Du wissen?