Excel Wenn Summe der Stunde größer als, dann

2 Antworten

Ich denke, das Problem ist, dass du in Rechenformeln die Zeiten nicht einfach im Format hh:mm schreiben kannst. Ich hab sie mal in Zahlenwerte umgerechnet:

05:00 = 0,21875

00:30 = 0,0208333333333333

00:15 = 0,0104166666666667

Damit schreibe ich in Zelle E2 (wenn in D2 die Stundenzahl steht):

=WENN(D2>0,21875;C2-0,0208333333333333;C2-0,0104166666666667)

Vielleicht geht es professioneller, aber so müsste es zumindest funktionieren.

Folgendermaßen sieht das jetzt bei mir aus:

Spalte A: Beginn Spalte B: Ende Spalte D: Differenz zwischen den Spalten B und A in Stunden:Minuten Spalte E: Länge der Pause in Stunden:Minuten (Bis 5 Stunden=15 Minuten, bei mehr als 5 Stunden 30 Minuten) Spalte F: Summe der Stunden (Spalte D - Spalte E) in Stunden:Minuten)

Formel für Spalte D (am Beispiel der Zeile 2): =B2-A2

Formel für Spalte E: =WENN(D2>ZEIT(5;0;0);ZEIT(0;30;0);ZEIT(0;15;0))

Formel der Spalte F: =WENN(D2=0;0;D2-E2)

Erklärung für die letzte Formel: Da ich zur Zeit nur 20 Stunden / Woche arbeiten darf, und auch mal Überstunden anfallen (von Do. letzter Woche bis Mo. 51 Stunden gearbeitet), gibts natürlich auch Tage, wo ich zuhause bleiben muss.

Um keine Ausgabe wie ##### zu erhalten wird geprüft ob die Spalte D Null Stunden enthält. Ist das der Fall, dann ist der Wert =0, Ansonsten ist zu rechnen Spalte D - Spalte E.

Und bislang passt es

 - (Excel, Uhrzeit, WENN-Formel)

Guuuut ! In deiner ersten Formel hattest du Anführungszeichen drin; daher hat die wohl nicht funktioniert.

0

Wie kann man die Differenz berechnen bei Excel mit +/- Zeichen?

Hallo, ich habe mich zwar schon hier im Forum gut belesen, aber leider immer noch nicht das richtige gefunden. Ich habe 2 Spalten mit Rechnungssummen: in der 1. Spalte die beantragte RE-Summe und in der 2. Spalte die tatsächliche RE-Summe. Da diese tatsächliche Summe höher und niedriger sein kann, möchte ich gerne in einer Spalte die Abweichungen mit +/- angezeigt haben. D.h. also, wenn z.B. die geforderte Summe 75,00 ist, aber nur 73,00 in Rechnung gestellt werden, habe ich eine Differenz von -2,00 €. Werden aber 78,00 € in REchnung gestellt, habe ich eine Differenz von +3,00 €. Wie lautet nun die Formel??

versaje

...zur Frage

Wie kann ich das bestehende Excel-Formular richtig bearbeiten?

Hallo zusammen

Ich habe eigentlich fixe Arbeitszeiten (07:30-12:00 und 13:15-17:20. Im erstellten Excel-Formular hat er aber nun das Problem, dass er alles vor der effektiven Arbeitszeit nicht erkennt und fehlerhaft berechnet.

Stunden Haben unter Spalte G: =(C-B)+(E-D)

Differenz unter Spalte H =G-F

Total unter H10
=GANZZAHL(SUMME(H5:H9))&":"&TEXT(REST(SUMME(H5:H9);1);"hh:mm")

Kann mir jemand das entsprechend umbasteln?

...zur Frage

Excel Formel zur Stundenabrechnung?

Liebe Leute ich bin am verzweifeln. Unzwar brauche ich wie bereits oben beschrieben eine Formel mit der ich Die Pausenzeit rechnen kann. Hier ein par Werte. Anfangsuhrzeit: C4 Als Uhrzeit formatiert Ende-Uhrzeit: D4 Als Uhrzeit formatiert Folgendes soll Ecxel errechen. Bei oder/länger als 8 Stunden soll es 45 Minuten Pause geben bei unter 8 Stunden soll Excel 15 Minuten Aufschreiben die Pausezeit in Minuten Form in Spalte E4

Top wäre es wenn es eine Formel gibt die mir aus den Oben genanten Daten sofort die Netto Stunden in einer Dezimalzahl gibt

Ich hoffe ihr könnt mir helfen

MfG Nico

...zur Frage

Excel WENN Abfrage mit Uhrzeit [h]:mm

Hallo Leute,

ich sitze gerade vor einem Excel Problem: Ich habe eine Tabelle in dem die Zellen folgendermaßen formatiert sind: [h]:mm, da ich in Stunden und Minuten über 24 Stunden hinaus rechnen muss. Ich möchte nun eine Abfrage einbauen, wenn in K12 ein Wert steht, der größer als 10 Stunden ist dann soll in L12 die Differenz (also Wert - 10) stehen. Wenn der Wert nicht größer ist, dann soll (als Test) 150 ausgegeben werden. Das Problem ist nun, dass ich in der WENN Abfrage keine 10:00 Als Wert angeben kann! Also das geht nicht: =WENN(K12>10:00;K12-10:00;150) Kann mir da jemand behilflich sein?

Danke im voraus

Gruß BB

...zur Frage

Was möchtest Du wissen?