Excel Wenn Summe der Stunde größer als, dann

2 Antworten

Ich denke, das Problem ist, dass du in Rechenformeln die Zeiten nicht einfach im Format hh:mm schreiben kannst. Ich hab sie mal in Zahlenwerte umgerechnet:

05:00 = 0,21875

00:30 = 0,0208333333333333

00:15 = 0,0104166666666667

Damit schreibe ich in Zelle E2 (wenn in D2 die Stundenzahl steht):

=WENN(D2>0,21875;C2-0,0208333333333333;C2-0,0104166666666667)

Vielleicht geht es professioneller, aber so müsste es zumindest funktionieren.

Folgendermaßen sieht das jetzt bei mir aus:

Spalte A: Beginn Spalte B: Ende Spalte D: Differenz zwischen den Spalten B und A in Stunden:Minuten Spalte E: Länge der Pause in Stunden:Minuten (Bis 5 Stunden=15 Minuten, bei mehr als 5 Stunden 30 Minuten) Spalte F: Summe der Stunden (Spalte D - Spalte E) in Stunden:Minuten)

Formel für Spalte D (am Beispiel der Zeile 2): =B2-A2

Formel für Spalte E: =WENN(D2>ZEIT(5;0;0);ZEIT(0;30;0);ZEIT(0;15;0))

Formel der Spalte F: =WENN(D2=0;0;D2-E2)

Erklärung für die letzte Formel: Da ich zur Zeit nur 20 Stunden / Woche arbeiten darf, und auch mal Überstunden anfallen (von Do. letzter Woche bis Mo. 51 Stunden gearbeitet), gibts natürlich auch Tage, wo ich zuhause bleiben muss.

Um keine Ausgabe wie ##### zu erhalten wird geprüft ob die Spalte D Null Stunden enthält. Ist das der Fall, dann ist der Wert =0, Ansonsten ist zu rechnen Spalte D - Spalte E.

Und bislang passt es

 - (Excel, Uhrzeit, WENN-Formel)

Guuuut ! In deiner ersten Formel hattest du Anführungszeichen drin; daher hat die wohl nicht funktioniert.

0

Was möchtest Du wissen?