Frage von Xarlysin, 61

Mehrere Werte in mehrere Excel-Spalten suchen?

Hallo, ich habe eine Frage bezüglich Excel 2013? Ich habe eine Spalte mit mehrere Werte/Zahlen. Gleichzeitig habe ich viele andere Spalten mit verschiedene Werten. Ich möchte wissen, ob die Werte aus der erste Spalte irgendwo in den anderen Spalten kommen. Mir ist egal wo. Ich will nur wissen, ob sie vorkommen. Mit Sverweis funktioniert nicht. Danke!

Antwort
von gfntom, 40

"Irgendewo" vorkommen bedeutet irgendwo in der Spalte oder Irgendwo in der gesamten Tabelle (außer in der ersten Spalte?)

Mein Ansatz wäre mit ZÄHLENWENN - Ist das Ergebnis > 0 kommt der Wert irgendwo vor. (Ich kanns im Moment leider nicht ausprobieren)

Kommentar von gfntom ,

Ja, funktioniert - sowohl wenn du nur in einer Zeile suchst, als auch in mehreren.

=ZÄHLENWENN(A1;B1:P100)

Liefert einen Wert> 0 wenn A1 irgendwo im Berecih B1:P100 vorkommt.

Antwort
von augsburgchris, 36

{=SUMME(ZÄHLENWENN(B1:Z100;B1:Z100)>1}

Ohne geschweifte Klammern eingeben und mit Strg+ Shift+Enter abschließen.

Ungetestet da gerade kein Excel zur Verfügung.

Kommentar von augsburgchris ,

Sorry gerade gesehen:
{=SUMME(ZÄHLENWENN(B1:Z100;A1:A100)>1}

Kommentar von Ninombre ,

den Matrixansatz fand ich interessant, zumindest unter Excel 2010 wir aber nur der erste Wert aus A1:A100 gesucht. Würde mit Hilfsspalte funktionieren, aber der Ehrgeiz sollte ja sein, ohne auszukommen..

Kommentar von Oubyi ,

zumindest unter Excel 2010 wir aber nur der erste Wert aus A1:A100 gesucht

Mit meiner kleinen Korrektur funktioniert das einwandfrei.
Vom Prinzip her eigentlich auch mit Chris` Formel.

Kommentar von Oubyi ,

Nach meinem Test sind klein Verbesserungen notwendig.
So funktioniert Deine Idee:

{=SUMME(ZÄHLENWENN(B1:Z100;A1:A100))>0}

Die Formel muss natürlich außerhalb der Bereiche stehen.

Kommentar von augsburgchris ,

Hi Uwe. Ja bei der 1 hatte ich nen Denkfehler. Wollte >= 1 schreiben aber das ist ja auch Quatsch. >0 reicht vollkommen. Mega culpa.

Auch 2010 kann mit der Matrixformel korrekt umgehen wenn man sie mit Strg+Shift+Enter sbschliesst. Sonst wird klar nur der erste Wert gesucht.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten