EXCEL: Spalten über mehrere Tabellenblätter zählen?

...komplette Frage anzeigen

2 Antworten

ich kenne keine außer der mühsamen

=zählenwenn(Januar!A6:Z6;"k")+zählenwenn(Februar!A6:Z6;"k")....

Sonst halt per Makrofunktion, falls das in Betracht kommt.

Antwort bewerten Vielen Dank für Deine Bewertung

Schreib in das Übersichts-Tabellenblatt die Monatsnamen der vorhandenen Tabellenblätter, z.B. in A1:A12 die Monate Januar bis Dezember (geht ja recht schnell durch autovervollständigen)

Dann verwendest du folgende Formel:

{=SUMME(ZÄHLENWENN(INDIREKT("'"&A1:A12&"'!A6:Z6");"k"))}

Das ist eine Matrixformel. Die geschweiften Klammern {} werden NICHT eingegeben, sondern die Formel wird mit Strg+Shift+Enter abgeschlossen. Das erzeugt die {}.

(adaptiert von http://www.excelformeln.de/formeln.html?welcher=234 und erfolgreich getestet. Man kann natürlich auch was aus der weiter unten stehenden Monatsnamenumwandlungsformel basteln, aber die scheint mir noch etwas unübersichtlicher zu sein)

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?