Excel - Gefärbte Zellen + Inhalt zählen - Formel?

Zellenfarben mit Inhalt automatisch zählen - (Excel, Formel, Farben zählen)

2 Antworten

Ersteinmal danke dafür, dass du mit deiner Frage meinen Horizont erweitert hast.

Eine ähnliche Frage wurde schon auf http://www.at-exceltraining.de/index.php/artikel/48-formeln-und-funktionen/203-die-funktion-zellezuordnen.html

von Frank Arendt-Theilen beantwortet. Vielleicht entspricht die Lösung deinen Vorstellungen.

"Hallo Hendrik Maaß,
vielen Dank für dein Interesse an meiner Webseite.

>Kann ich Farben zählen?

Ja!
1. Vergib folgende benannte Formel im Namens-Manager von Excel 2012:
Name: Farbe
Bezieht sich auf: =ZELLE.ZUORDNEN(38;INDIREKT("ZS(-1)";FALSCH))

2. Zelle A1 wurde mit einer Füllfarbe eingefärbt.
3. Zelle B1 enthält folgende Formel: =WENN(Farbe>0;1;0)
4. Die Formel gibt eine Eins zurück falls die linke Zelle eingefärbt wurde, ansonsten Null.

Anschließend kannst du die Einsen (1) mit der Funktion SUMME() zählen."

Danke schön, auch eine fast komplette Antwort. ;) Nun fehlt mir aber noch, dass die gefärbten Zellen, die nach deiner Anweisung in der neuen Spalte eine 1 aufweisen, die entsprechende Anzahl anzeigt, die auch in der gefärbten Zelle drin ist. Ich will ja nicht nur die gefärbten Zellen zählen, sondern auch dessen Inhalt summieren. Hast du auch hierzu eine Lösung?

0
@micebaby

Die gefärbten Zellen zählst du mit ZÄHLENWENN. Als Bereich legst du die Spalte mit den Einsen fest.

Die Inhalte der gefärbten Zellen summierst du mit SUMMEWENN. Funktioniert wie ZÄHLENWENN, nur dass du als letzten Parameter (Summe_Bereich) die Spalte mit den eingefärbten Zellen wählst.

0
@Suboptimierer

Also du meinst: =SUMMEWENN(G3:G173;Farben;H3:H173) In G habe ich die Anzahl in den farblich markierten Zellen, in H habe ich die 1 deiner Formel, also die hinter den farblich markierten Zellen. Mit der Formel (=SUMMEWENN(G3:G173;Farben;H3:H173) ) bekomme ich nur eine 1 raus. :/ Ich versteh es leider nicht. Kannst du mir das bitte in einer richtigen Formel noch mal hier aufschreiben? Mit Copy und Paste (nur noch die Spalten anpassen) ist es irgendwie einfacher... DANKE

0
@micebaby

Ha, ich habs!! :) Lieben Dank an Euch :)

Ich habe jetzt einfach in Spalte G folgende Formel eingetragen und diese nach unten kopiert und habe somit die Anzahl der bereits farblich markierten Zellen: =WENN(Farben>0;G5;0)

1

Farbige Zellen summieren - mit und ohne Bedingung (432)

Aufgabe Es soll die Summe aller farbigen Zellen gebildet werden. Die Zellen wurden NICHT per Bedingter Formatierung gefärbt. Lösung Die Summe - ohne Bedingung:

In A1:A100 stehen Zahlen - manche sind rot formatiert.

Einfügen - Namen - Definieren, Name: Farbe Bezieht sich auf:

a) =ZELLE.ZUORDNEN(24;INDIREKT("ZS(-1)";)) für die Schriftfarbe oder b) =ZELLE.ZUORDNEN(63;INDIREKT("ZS(-1)";)) für die Hintergrundfarbe

In B1 (Hilfsspalte): =Farbe und runterkopieren

a) Dadurch wird die Schriftfarbe der LINKEN Nachbarzelle (ZS(-1)) ausgelesen - z.B. 3 für Rot (Blau wäre 5).

Die Summe der roten dann mit: =SUMMEWENN(B:B;3;A:A)

Soll noch ne Bedingung eingebaut werden - z.B. nur alle Zahlen aus A1:A100, die Rot UND größer 10 sind, dann: =SUMMENPRODUKT((A1:A100>10)*(B1:B100=3);A1:A100)

b) analog für die Hintergrundfarbe: Gelb z.B. ist 6 und Grau: 15

Erläuterung Wird ein Eintrag in Spalte A nachträglich eingefärbt, wird das erst nach Neuberechnung wirksam.

Gehört eigentlich in die Kategorie "Excel4-Macrofunktionen" - wird aber in den Foren fast täglich gefragt - und unter den Macrofunktionen wird keiner suchen. Ist natürlich auch auf alle anderen Funktionen anwendbar (MIN, MAX, MITTELWERT etc.)

Soweit war ich auch schon ,allerdings funktioniert das leider nicht. Weiß nicht ob es an der Farbe liegt, oder woran? Ich sagte ja bereits, dass auch diese Formel nicht funktioniert. In meiner Liste bekomme ich immer nur das Ergebnis 43 dabei sind es weit über 100 die schon händisch farblich markiert sind. Gibt es denn einen anderen Farbcode hierzu? Mit Makros kenne ich mich leider nicht aus, ich brauche daher die Formel und kann kein extra Makro dazu erstellen.

Danke aber trotzdem schon mal für deine sehr schnelle Antwort.

0

Excel Formel Berechnung Anzahl2?

Ich habe folgendes Problem:

In einer Liste mit diversen Einträgen soll die Summe in einer Spalte errechnet werden.

In dieser Spalte gibt es Bereiche mit Zahlen und Datum und Bereiche mit Text und Datum.

Gezählt werden sollen aber nur die Bereiche mit Zahlen und Datum. Bisher habe ich im Interent dazu nichts gefunden, wie ich die Bereiche mit Text und Datum ausschließen kann.

Ich bedanke mich jetzt schon für die sicherlich zahlreichen Lösungsvorschläge.

(Ein Beispiel wollte ich anfügen, das klappte aber leider nicht)

Meine benutze Formel lautet:

=ANZAHL2(G4:G251)

anzumerken wäre noch, dass es auch leere Zellen gibt, die ich natürlich nicht zählen möchte

...zur Frage

Wie heißt die Makro-Formel zum Zellen Inhalt löschen und wie packt man sie auf ein Button?

Kennt wer die Antwort? Wie heißt die Formel und wie geht das?

...zur Frage

In Excel Anzahl gefärbter Zellen zählen?

Hallo allerseits,

kennt einer von Euch eine Formel mittels der ich mit die Anzahl eingefäbter Zellen zählen kann.

also Bsp: ich habe eine Tabelle in der ich 10 Zeilen habe, 3 davon sind grün, 5 rot und 2 blau. Nun will ich unten je eine Formel haben die mir die Anzahl der blauen, roten und grünen Zeilen zählt.

gibt es sowas oder geht das evtl. über kleine Umwege?

Ich danke Euch im voraus.

Gruß Gipfelstürmer

...zur Frage

EXCEL Formel gesucht ( Kniffel programmieren)

Hallo, ich soll in Informatik das Spiel Kniffel in Excel programmieren. Ich habe soweit auch schon alles fertig. Das Einzige, dass mir noch fehlt ist eine Formel um die 5 Zufallswürfel, die mit dem Befehl ZUFALLSBEREICH 1;6 , per Klick auf ein Kästchen beim nächsten Wurf nicht mehr neu würfeln. Also ganz kurz nochmal: Ich habe 5 Würfel, die auch würfeln. Ich brauche nur noch eine Formel um bestimmte Würfel, die man anklickt bei einem erneuten Wurf nicht mehr würfeln. Zusätzlich soll es eine Sperre geben, dass mannl nur 3x würfeln kann.

Danke für eure Hilfe.

...zur Frage

Excel - Kopieren einer Zellen in gefilterter Tabelle

Hallo,

ich habe eine Excel-Tabelle erstellt, in der aufgrund einer SVERWEIS-Formel in einer Spalte einige Werte #NV ergeben. Diese habe ich per Filter ausgeblendet. In der nächsten Spalte will ich 2 Werte multiplizieren und kopiere die Formel runter. Er kopiert die Formel aber leider auch in die durch den Filter eigentlich ausgeblendeten Zeilen mit #NV. Wie kann ich das verhindern, dass er die Zeilen mit #NV, die er überspringen soll, trotzdem mit der kopierten Formel befüllt?

Danke

...zur Frage

Excel Zellen zählen wenn keine Hintergrundfarbe?

Hallo liebe Community,

ich habe ein Problem, das ich leider nicht lösen kann:

Ich bin gerade dabei, einen Stundenzettel für meine Arbeit zu entwerfen, der so viel wie möglich gleich ausrechnet.

Er soll auch automatisch die Arbeitstage ausrechen. Allerdings brauche ich dazu die Formel, dass er nur die Zellen mit Datum zählt, die weiß und nicht grau hinterlegt sind (siehe Foto).

Kann mir jemand helfen? Ich bin fast am Verzweifeln :/

https://images.gutefrage.net/media/fragen/bilder/excel-zellen-zaehlen-wenn-keine-hintergrundfarbe/0_big.jpg?v=1515146167629"/>

...zur Frage

Was möchtest Du wissen?