Du hast Dich wohl verlesen. Der Raspberry Pi 3 hat eine eingebaute WLAN-Schnittstelle. Der Raspberry Pi Zero W ebenfalls. Der Raspberry Pi B jedoch nicht.

...zur Antwort

Ivacy hat nach eigener Aussage Server in mehr als 100 Ländern. Wenn Du einen VPN aufbaust, bist Du mit einer IP-Adresse des VPN-Servers unterwegs. Wenn Dein VPN nun auf einem Server im Irak terminiert und Du loggst Dich bei Google ein, denkt Google, da kommt jemand aus dem Irak.

Wenn Du Dich bei Google oder Amazon einloggst, wird das zwischen Rechner und Zielserver Ende-zu-Ende verschlüsselt. Selbst in einem öffentlichen Hotspot ist das nicht entschlüsselbar. In diesem Falle ist ein VPN also überflüssig bis kontraproduktiv. Oder suche Dir einen VPN-Anbieter, der seine Server in Deutschland stehen hat. Wenn Du Webseiten per http und nicht per https aufrufst, wäre das ohne VPN mitlesbar.

...zur Antwort

Ja, das ist möglich. Ich möchte die durchaus korrekte Rechnung von kmkcl verfeinern. Die Mikrowelle sendet innerhalb des Ofenraums mit bis zu etwa 1.000 Watt. WLAN darf bei 2,4 GHz mit maximal 100 mW senden. Wenn der Accesspoint diese Leistung abgibt, kommen nicht, wie von kmkcl geschrieben, 10 mW beim Empfänger an. Es ist viel weniger, was beim Empfänger ankommt:

Ich sitze hier mit meinem Rechner direkt neben einem Accesspoint. Der Abstand zwischen Sender und Empfänger beträgt etwa 50 cm. Der Rechner empfängt den Accesspoint mit -33 dBm. Das ist ein Faktor von 2000 weniger als 100 mW, also 0,05 mW.

Wenn wir das jetzt in Relation setzen zur Leistung der Mikrowelle, ist das ein winziger Bruchteil dessen Sendeleistung. Das bedeutet, dass schlecht geschirmte Mikrowellen (oder ein paar Krümel in der Türdichtung) bereits ausreichend Leistung nach außen verlieren, um im Vergleich zur WLAN-Strahlung eine erhebliche Störung zu verursachen.

...zur Antwort

Nein und nein. Man kann beim Raspberry Pi weder Speicher nachrüsten noch den Prozessor wechseln (wie sollte das auch gehen, der ist schließlich zentraler Bestandteil des Designs). Es gibt auch keine Adapter. Der RasPi ist wie er ist.

...zur Antwort

Du irrst. Du hast kein Recht auf diese Domain.

Schau mal hier: http://www.jurpc.de/jurpc/show?id=20020144

"Unter dem Namen versteht man die sprachliche Kennzeichnung einer Person zur Unterscheidung von anderen. Der Name hat somit Ordnungs- und Unterscheidungsfunktion und ist zugleich Ausdruck der Persönlichkeit. (...) Zudem wurden als Namen nicht nur der vollständige Name, sondern auch schlagwortartige Bestandteile oder Abkürzungen anerkannt, sofern diese Verkehrsgeltung erlangt haben."

Ein Vorname allein ist im Internet sicher nicht geeignet, eine Person von anderen zu unterscheiden. Das reicht mitunter noch nicht einmal innerhalb einer Schulklasse. Der Vorname ist auch kein vollständiger Name. Wenn also jemand eine Domain reserviert hat, die nach Deinem Vor- und Nachnamen benannt ist, könnte man sich über § 12 BGB unterhalten. So aber sicher nicht.

Zudem sind Deine Annahmen unbelegt: Woher weißt Du, dass die Domain keinem "richtigen" Unternehmen gehört? Was ist überhaupt ein "richtiges" Unternehmen? Was heißt, die Domain wäre inaktiv? Sie hat einen individuellen Inhalt und nicht nur eine Standard-Seite des Providers. Möglicherweise heißt der Inhaber der Domain Fridtjof?

...zur Antwort
weswegen der Ordner sich laufend aufhängt

Als angehender ICT-Fachmann solltest Du Dir schleunigst eine angemessene Ausdrucksweise angewöhnen. Ein Ordner hängt sich nicht auf. Nein, wirklich nicht. Was passiert also wirklich? Ein Blick in die Protokolldateien des Servers, der diesen Ordner bereitstellt, könnte auch mal helfen.

eigentlich ICT-Fachmann in Ausbildung

Wieso eigentlich "eigentlich"?

...zur Antwort

Im Regelfall steht die Firewall an der Grenze zum Internet. Um den SPOF zu vermeiden, stellt man dort zwei Firewalls hin, die im "Failover-Betrieb" laufen. Eine Firewall ist aktiv, die andere ist quasi in Wartestellung. Die Firewalls überwachen sich gegenseitig und wenn die aktive ausfällt, wird die andere aktiv. Das kann über Protokolle wie VRRP realisiert werden, oft sind es aber proprietäre Mechanismen, die dort zum Einsatz kommen. Manche Hersteller sprechen von "Cluster".

Beide Firewalls aktiv zu haben, geht unter Umständen auch. Hier muss mal allerdings asymmetrisches Routing verhindern, was nicht ganz einfach ist.

Bei dem von Dir skizzierten Netzaufbau hat wird nicht ganz deutlich, sie der Datenverkehr gesteuert werden soll. Welches Gerät ist das Gateway für die Endgeräte im "Private network"? Wie willst Du sichertellen, dass die Endgeräte das Gateway wechseln, wenn es ausfällt? Mit OSPF bist Du da nicht richtig bedient. Das funktioniert so nicht.

Im Zweifel ist mindestens der Router ein SPOF. Der Internetzugang ist es sowieso. Meiner Erfahrung nach ist es eher der Internetzugang, der ausfällt und weniger die Firewall.

...zur Antwort

Das Gerät, welches im 2. Stock steht und "das Internet verstärkt", ist ein Repeater. Der muss weg. Repeater und "zocken" geht gar nicht. Der WLAN-Router muss so positioniert werden, dass überall ausreichender WLAN-Empfang möglich ist. Wenn das nicht geht, braucht es einen weiteren Accesspoint, der per Kabel am WLAN-Router angeschlossen wird. Mit etwas Glück funktioniert auch DLAN (Powerlan) ausreichend gut.

...zur Antwort

Wenn die Excel-Dateien im aktuellen Format (*.xlsx) abgespeichert sind, sind das nichts anderes als in Zip-Archive verpackte XML-Dateien. Die kannst Du relativ leicht per Python parsen.

...zur Antwort

Prinzipiell geht das. Pi-Hole installiert jedoch nginx als Webserver und dnsmasq als DNS-Server/-Forwarder. Auf Debian ist per Default Apache als Webserver vorhanden. nginx und Apache einerseits und die vorhandene dnsmasq-Konfiguration andererseits kollidieren dann. Das müsstest Du also aufräumen. Pi-Hole ist dazu gemacht, um auf einem "jungfäulichen" Raspberry Pi installiert zu werden. Aus diesem Grund habe ich Pi-Hole "nachgebaut", indem ich lediglich das Script zum Aktualisieren der Serverlisten verwende. Die Konfiguration von dnsmasq habe ich manuell gemacht, um ein 1x1-Pixel auszuliefern verwende ich dann den Apache, der bei mir für diverse Zwecke bereits auf dem Pi läuft.

...zur Antwort

Wie verbinde ich 3 Router per bgp-Routing (Cisco)?

Ich habe 3 Router die ich mithilfe von dynamischem Routing verbinden soll. jeder router hat 2 verwendete Interfaces. Fa 0/1 und Fa 0/0 bei R1 sollen in bgp 12 sein und Fa 0/1 und Fa 0/0 bei R3 sollen in bgp 23 sein. Fa 0/1 von R2 soll ich bgp 12 und F 0/0 soll in bgp 23 sein. Siehe Veranschaulichung: https://drive.google.com/file/d/1jURbSi3lEJJLmmffu4j_GYXe4sEPhUci/view?usp=sharing

Ich komme nicht mehr weiter. Meine konfiguration lautet:

R1

enable
conf t
interface fastEthernet 0/1
ip adress 10.10.10.2 255.255.255.0
no shutdown
exit
interface fastEthernet 0/0
ip adress 10.10.11.1 255.255.255.0
no shutdown
exit
interface loopback 0
ip address 192.0.2.1 255.255.255.0
exit
router bgp 12
network 192.0.2.0 mask 255.255.255.0
neighbor 192.0.2.2 remote-as 12

 

R2

enable
conf t
interface fastEthernet 0/1
ip adress 10.10.11.3 255.255.255.0
no shutdown
exit
interface fastEthernet 0/0
ip adress 10.20.11.3 255.255.255.0
no shutdown
exit
interface loopback 0
ip address 192.0.2.2 255.255.255.0
exit
router bgp 12
network 192.0.2.0 mask 255.255.255.0
neighbor 192.0.2.1 remote-as 12
neighbor 192.0.2.3 remote-as 23

R3

enable
conf t
interface fastEthernet 0/1
ip adress 10.20.11.1 255.255.255.0
no shutdown
exit
interface fastEthernet 0/0
ip adress 10.20.10.2 255.255.255.0
no shutdown
exit
interface loopback 0
ip address 192.0.2.3 255.255.255.0
exit
router bgp 23
network 192.0.2.0 mask 255.255.255.0
neighbor 192.0.2.2 remote-as 12

Kann mir wer weiterhelfen?

...zur Frage

Ich fürchte, Du hast die Funktion von BGP noch nicht wirklich verstanden. Und ich sehe noch Schnitzer bei der IP-Konfiguration.

  1. Du hast die Loopback-Interfaces aller Router in ein Netz gepackt: 192.0.2.0/24. Das kann nicht funktionieren. Jedes Loopback-Interface muss in einem eigenen Netz stehen. Nimm also die /32 als Maske.
  2. Wie soll R1 eine Verbindung zu seinem BGP-Peer aufbauen? Schau mal in die Routingtabelle, wie er die 192.0.2.2 erreicht. Er wird Dir sagen, dass er das Netz direkt an Lo0 angeschlossen hat. Der Router hat also schon Probleme, die TCP-Verbindung aufzubauen. Merke: Ein BGP-Nachbar muss erreichbar sein. Da ein BGP-Nachbar, insbesondere bei iBGP, nicht zwingend ein physikalischer Nachbar ist, braucht der Router eine Route zum Nachbarn. Konfiguriere also ein IGP oder setze statische Routen.
  3. Wie soll R2 eine externe BGP-Verbindung zu seinem Nachbarn R3 aufbauen? Neben dem unter Punkt 2 erwähnten Erreichbarkeitsproblem kommt hier hinzu, dass externes BGP mit einem TTL-Wert von 1 arbeitet. Von R2/Lo0 nach R3/Lo0 ist es routingtechnisch aber mehr als 1 Hop. Merke: eBGP wird in der Regel nicht über Loopback-Interfaces aufgebaut, sondern über die physikalischen. Damit ist das Erreichbarkeitsproblem gelöst und der TTL 1 reicht aus.
  4. Die Netze 10.10.10.0/24 und 10.20.10.0/24 müssen auf den Routern R1 bzw. R3 als network-Befehl im Routing aufgenommen werden. Ansonsten sind die Netze nicht erreichbar.
...zur Antwort

Das kann man nicht ausrechnen. So etwas wird ausgemessen. Man nennt das Site Survey. Man kann allenfalls eine Schätzung für den Anfang vornehmen, als Vorstufe für eine Messung.

0 dB sagt nichts aus. dB ist eine vergleichende Skala, Du benötigst also einen Bezug. Möglicherweise meinst Du 0 dBm, das wären 1 mW. Was willst Du mit 1 mW kalkulieren?

RSSI hat keine genormte Skala und ist damit keine geeignete Vergleichsgröße.

Die Formel und die Parameter kann ich nicht ganz nachvollziehen. Die Parameter sind teils falsch.
P + Tx ergibt, sofern keine externen Antennen verwendet werden, die EIRP. Der erlaubte Maximalwert im 2,4 GHz-Band liegt bei 20 dBm. Tx wird in dBi und nicht in dB gemessen. Wird mit externen Antennen gearbeitet, ist zusätzlich die Kabeldämpfung zu berücksichtigen.

Rx: Der Antennengewinn des Empfängers ist höchst unterschiedlich und unbekannt. Oder hast Du Informationen über den Antennengewinn diverser Mobiltelefone, Tablets, Notebooks, USB-WLAN-Sticks? Rx wird in dBi und nicht in dB gemessen.

Pathloss: Ist hier der Free Path Loss gemeint? Also die Dämpfung im Medium? Das ist natürlich entfernungsabhängig.

Penetration Loss: Was soll das sein? Der Verlust beim Durchdringen von Hindernissen? Das hängt von so vielen Faktoren ab, dass man das nicht vorhersagen kann. Also eine weitere Unbekannte in der Gleichung.

Transmitpower gibst Du mit 100 W an. Ich hoffe, Du meinst 100 mW, das würde mit 20 dBm übereinstimmen. Und gewöhne Dir an, Einheiten richtig zu schreiben. dB, nicht db.

Mit Penetration Loss Puffer (eher Buffer ...) kann ich nichts anfangen. Eine Reserve für die Schätzung?

Zusätzlich ist das Frequenzband zu berücksichtigen. Heutzutage sollte man sein WLAN auf 5 GHz auslegen. Das bedeutet eine im Vergleich zu 2,4 GHz vierfache Dämpfung und eine Sendeleistung von max. 200 mW (23 dBm). In manchen Kanälen sind auch 30 dBm (1 W) zulässig. Das führt jedoch zu starker Asymmetrie. Man hat wenig davon, wenn ein Endgerät den Accesspoint noch sieht, weil der mit 1 W strahlt, wenn das Endgerät jedoch nur mit 100 oder 200 mW sendet und vom Accesspoint nicht mehr gesehen wird. Würde ein Endgerät mit 1 W senden, wäre der Akku ziemlich schnell leer. Ein 5 GHz-WLAN benötigt also deutlich mehr Accesspoints als ein 2,4 GHz-WLAN. 802.11ac ist jedoch nur bei 5 GHz verfügbar.

Fazit: Du hast ziemlich viele Unbekannte in der Gleichung. Und Du hast etwas vor, was nicht möglich ist. Um den Bedarf an Accesspoints abzuschätzen, bedarf es vor allem eines genauen Umrisses der Fläche inklusive Wänden und Möblierung. Dazu muss dann auch noch berücksichtigt werden, wie viele Clients pro Fläche bedient werden müssen. Ein weiterer Faktor ist, ob unterbrechungsfreies Handover gefordert ist und welche Art von Anwendungen genutzt werden. Insbesondere Voice over WLAN ist ein Faktor, der die Anzahl der benötigten APs in die Höhe treibt.

...zur Antwort

Ein feines Schätzchen hast Du da.

Möglicherweise besteht ein Zusammenhang zwischen der Funktion des Schnellspannhebels und des eingedrückten Rückspulknopfes. Es kann sein, dass erst ein Film eingelegt werden muss, dann der Rückspulknopf herausspringt und der Schnellspannhebel greift.

Unter https://www.libble.de/includes/handleiding.asp?id=10516&c=224,276055577674&t=7-10-2018%2012:31:58 findest Du eine Bedienungsanleitung. Allerdings ist die Bildqualität schlecht.

Hier die Qualität besser, man benötigt allerdings einen Login für den Download. Anschauen geht aber auch so: https://de.scribd.com/document/28321150/K1000-Instruction-Manual

Hier findest Du eine Diskussion über das Problem eines klemmenden Rückspulknopfes: https://www.flickr.com/groups/891454@N24/discuss/72157629247855537/

Eine Wartungsanleitung, wo auch das Abnehmen des Bodendeckels etc. beschrieben ist, findest Du hier: http://www.pentax-manuals.com/markroberts/k1000_man.pdf (leider auch mit suboptimaler Bildqualität).

Hier gibt es auch noch einige Service-Manuals für die Kamera, die habe ich mir aber jetzt nicht angeschaut: https://www.eserviceinfo.com/index.php?what=search2&searchstring=pentax-k1000

Möglicherweise hilft das weiter. Ich würde aber wirklich erst mal einen Film einlegen.

...zur Antwort

Ich habe mal eine Kombination aus

http://pgl.yoyo.org/adservers/serverlist.php
http://winhelp2002.mvps.org/hosts.txt
https://adaway.org/hosts.txt
http://hosts-file.net/.%5Cad_servers.txt
http://www.malwaredomainlist.com/hostslist/hosts.txt
http://adblock.gjtech.net/?format=unix-hosts
http://someonewhocares.org/hosts/hosts
http://adblock.mahakala.is/

verwendet.

...zur Antwort

Der Entwurf ist schon sehr gut.

"mein Name ist ..." - hier musst Du klein beginnen, weil die Anrede zum Satz gehört.

"ich bin ein Schüler ..." - das ist nicht falsch, aber ich würde das "ein" weglassen.

"findet an meiner Schule ..." - Das Praktikum findet eigentlich nicht an Deiner Schule statt. Schreibe so etwas wie: "Im Rahmen der Berufsorientierung möchte ich bei xxx ein Berufspraktikum absolvieren." Benenne das Unternehmen konkret mit Namen. Formulierungen wie "in Ihrem Unternehmen" klingen nach abgeschriebenem Standardsatz, den man genau so in zwanzig anderen Bewerbungen auch schon geschrieben hat.

"Im Anhang finden Sie ein Anschreiben der Schule." - "ein" statt "einen" und das "Sie" würde ich groß schreiben. Die Rechtschreibregeln erlauben meines Wissens zwar auch ein kleines "sie", "Sie" ist aber höflicher. Du kennst Deinen Ansprechpartner ja noch gar nicht.

Viel Erfolg!

...zur Antwort

Möglicherweise ist an dem Adapter der Micro-SD-Karte ein Schieber, der einen Schreibschutz auslöst.

...zur Antwort

Minimum Hop bedeutet, dass der Weg über möglichst wenige Knoten (Router) führt. Minimum Cost bedeutet, dass die Anzahl der Knoten egal ist, aber die Kosten müssen minimiert werden.

Ein Beispiel für Minimum Hop ist der Bellman-Ford-Algorithmus, mit dem zum Beispiel das RIP arbeitet. Aber auch beim BGP können die Anzahl der Hops relevant sein, wobei hier nicht ein Router als Hop gewertet wird, sondern ein Autonomes System.

Minimum Cost wird vom Dijkstra-Algorithmus verwedent. Der wird von OSPF und IS-IS genutzt.

...zur Antwort