Wie berechne ich mit Excel eine Summe bis zum heutigen Datum?

... komplette Frage anzeigen

3 Antworten

Mit den Summenprodukt-Lösungen von Ninombre (DH!) fährst du bei sowas sehr gut, sie bieten mehr Möglichkeiten als Summewenn.

In deinem Fall würde auch ein
=SUMMEWENN(A6:A36;"<="&HEUTE();L6:L36)
klappen. Du darfst Funktionen im Kriterium nicht in Anführungszeichen setzen.

Wenn du in Spalte L nur 1 und 0 setzt, also wissen willst, wieviele Tage von A schon vergangen sind, kannst du auch
=ZÄHLENWENN(A6:A36;"<="&HEUTE())
verwenden

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von icasait
05.03.2016, 11:15

Ok super, danke! Jetzt habe ich nicht nur mehrere Lösungen, sondern weiß sogar wo der Fehler lag. Was will man mehr? :D

0

Wenn ich es richtig verstehe, geht es nicht um eine echte Summe (bspw. Umsatz je Tag und das summiert) sondern um die Anzahl der Tage zwischen heute und einem bestimmten Datum. Richtig?

Das kannst Du mit Datumsfunktionen direkt angehen bzw. wenn es ganz einfach gehalten werden kann:
=heute()-A6 (wenn in A6 der Beginn steht)
Das musst Du wieder als Zahl formatieren, da Excel meist ein Datum daraus macht.

Wenn es die Anzahl konkreter Datums-Einträge kleiner heute sein soll, ginge es bspw. über diesen Weg
=SUMMENPRODUKT((A6:A36<=HEUTE())*1)
Achtung: ohne weitere Bedingung werden auch leere Zellen als Treffer gewertet. Um das abzufangen:
=SUMMENPRODUKT((A6:A36<=HEUTE())*(A6:A36<>"")*1)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von icasait
04.03.2016, 19:42

Danke für deine Antwort, mit Datumsfunktionen kenne ich mich nicht aus, aber das Anfangsdatum vom aktuellen Datum abzuziehen klingt sinnvoll...auf so etwas einfaches bin ich nicht gekommen :D

0

Was möchtest Du wissen?