Excel "Teile einer Matrix können nicht geändert werden"?

...komplette Frage anzeigen

2 Antworten

Du hast in einem Bereich, der nicht dem Bereich N22:R100 entspricht eine oder mehrere Matrixformeln stehen. Und wohl so, dass mindestens eine davon sowohl innerhalb als auch außerhalb der Bereiches N22:R100 steht.
Sagt der Begriff Dir etwas?
Du musst suchen, wo in dem Bereich eine Formel in der Form:
{=.....}
steht, also in geschweiften Klammern.
Wenn Du so eine Zelle hast, drücke F5 (Gehe zu) und klicke auf
"Inhalte.../ Aktuelles Array".

Dann werden Dir alle Zellen angezeigt, die diese Matrix beinhalten.
DIE musst Du alle mit verschieben.
Du kannst NICHT nur ein paar davon verschieben.

Hilft Dir das?


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von lasttobi12
27.06.2017, 21:38

Du hast in einem Bereich, der nicht dem Bereich N22:R100 entspricht eine oder mehrere Matrixformeln stehen. Und wohl so, dass mindestens eine davon sowohl innerhalb als auch außerhalb der Bereiches N22:R100 steht.

Jap. Das ist der Fall <.<

Die Matrixformeln befinden sich in der Spalte Q, sowohl vor Q22 als in Q22:Q100.

Alle verschieben bringt mir leider nichts, da ja nur eine/mehrere Zeile nach 

N22:E22 eingefügt werden sollen.

Vielleicht wird es hier deutlich:

https://www.pic-upload.de/view-33413524/Petert.png.html

1(Bild): Hier sollen die Zeilen eingefügt werden

2(Bild): Soll im Prinzip nach unten/oben verschoben werden (darunter befinden sich noch mehr solcher Tabellen.

Die Matrixformel in Q sieht wie folgt aus:

{=WENN(ISTZAHL(O10);WENN(ZÄHLENWENN(P$1:P9;P10)=0;1;KGRÖSSTE(WENN(P$1:P9=P10;Q$1:Q9);1)+1);"")}

glaube nicht, dass das ohne Matrixformel möglich ist <.<

Lg Tobi

0

Ich kann mir das heute (und morgen untertags) nicht mehr näher anschauen, aber häufig sind die Matrixformelm einzeln kopierbar:

mach eine Formel vor Zeile 22 auf(merken welche!), kopiere DEN STRING in die Zwischenablage (oder in eine Zelle weiter rechts), löche das ganze Matrixformelarray, setze Deine Zeile unterhalb ein.

Füge den String an derselben Stelle (oder eins unterhalb? je nach Formel) wieder ein (Eingabe wieder mit Strg+Umsch+Enter nicht vergessen), und kopiere die Zelle mit der Matrixformel wieder nach unten/oben

Vorsichtshalber das Ganze erst mal in einer Blattkopie!

PS: manchmal sind Korrekturen nötig, wenn zB Zeile(1:1) oder Zeile(A1) verwendet wird, da muss dann entweder -1 oder +1 oder eine sonstige Korrektur stehen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von lasttobi12
28.06.2017, 16:13

Das Problem hat sich eigentlich schon indirekt gelöst. 

Dein Vorschlag hört sich recht sinnig an, jedoch müsste ich dass dann vermutlich jeden Tag wiederholen. Da bleibe ich lieber bei der indirekten Lösung ^_^

Danke trotzdem ;)

0

Was möchtest Du wissen?