Robot Karol ganze Welt durch laufen?

2 Antworten

Sorry dass es so spät ist,aber hier habe ich eine Lösung für die,die es vielleicht brauchen und keine Infos fanden:

wiederhole solange NichtIstWand

wiederhole solange NichtIstWand

Hinlegen

Schritt

 *wiederhole

 LinksDrehen

 LinksDrehen

 wiederhole solange istziegel

 Schritt

*wiederhole

Hinlegen

Schritt

RechtsDrehen

wenn nichtistwand

dann Schritt

sonst

rechtsdrehen

rechtsdrehen

*Wenn

RechtsDrehen

*wiederhole

wiederhole solange NichtIstWand

Hinlegen

Schritt

*wiederhole

linksdrehen

wiederhole solange nichtistwand

schritt

*wiederhole

linksdrehen

Sie funktioniert in allen Welten,egal wie groß sie ist.

Plus:Robot Karol geht an seine Startposition zurück

while no tree.front():

     kara.move()

        if tree.front():

           kara.turnRight()

           kara.move()

           kara.turnRight()

So irgendwie sollte es funktionieren, wenns keine Bäume gibt, leg einfach ein Kleeblatt aus und orientiere ich daran

Ich glaube du hast es für das falsche Programm gemacht.Ich brauche das für Robot Karol, aber trotzdem danke :)

0

Was möchtest Du wissen?