Frage von smirre77, 124

Wie kann ich fehlende Messwerte in Excel ergänzen?

Hallo,

ich habe eine Tabelle mit Messwerten in Excel. Ich muss nun zwischen jedem Messwert drei zusätzliche Zwischenwerte berechnen. Das Rechnen ist nicht das Problem, da wird im einfachsten Fall linear interpoliert oder ich ermittle die Werte über einen Spline.

Das Problem ist, dass ich ca. tausend Werte habe und ich es nicht hinbekomme aus der Ursprünglichen Spalte eine neue mit mehr Messwerten zu generieren.

Ich hänge mal ein Bild an, wie das Ergebnis beispielhaft für 5 Werte in Excel aussehen sollte. In Spalte B liegen meine Messwerte. In Spalte D dann die "erweiterte" Messreihe. Die grünen Felder sind die Stützwerte. Die Zwischenwerte sind berechnet.

Hat da jemand eine Idee oder vielleicht sogar ein Beispiel?

Gruß Smirre

Expertenantwort
von Ninombre, Community-Experte für Excel, 86

Das Aufteilen der Messwerte um quasi Platz für die berechneten Werte zu schaffen, könntest Du einfach per Makro machen (wenn Du mit VBA/Makros gar nichts zu tun hattest, kurz Info, dann kann man das etwas erläutern):

Sub aufteilen()
For i = 1 To 5
Cells(i * 4, 2).Value = Cells(i, 1).Value
Next
End Sub

Dann in eine Spalte daneben: =WENN(B1<>"";deine Formel";B1)

Oder im Makro selbst die Berechnung durchführen. Die "Formel" durch die richtige ersetzen bzw. noch mal hier erläutern, wie berechnet werden soll, dann kann ich oder ein anderer das auch im Makro ergänzen.

Sub aufteilen()
For i = 1 To 5
Cells(i * 4, 2).Value = Cells(i, 1).Value
Cells(i * 4 + 1, 2).Value = "FORMEL"
Cells(i * 4 + 2, 2).Value = "FORMEL"
Cells(i * 4 + 3, 2).Value = "FORMEL"
Next i
End Sub

Antwort
von smirre77, 58

Da die Lösung über die IDIREKT-Funktion einfacher zu handhaben ist (meine VB-Kenntnisse sind eher sehr rudimentär) habe ich diese zuerst getestet. Funktioniert einwandfrei und löst das Problem!!

Vielen Dank!

Ob die elegantere Lösung über ein Makro auch funktioniert, habe ich nicht überprüft.

Antwort
von Jackie251, 64

Das ginge mit dieser Formel in Spalte E

=WENN(REST(ZEILE();4)=0;INDIREKT("B"&ZEILE()/4+3);INDIREKT("B"&ABRUNDEN(ZEILE()/4+3;0))+REST(ZEILE();4)/4*(INDIREKT("B"&ABRUNDEN(ZEILE()/4+4;0))-INDIREKT("B"&ABRUNDEN(ZEILE()/4+3;0))))


vermutlich lässt sich auch ein einfacherer Algorithmus finden, ich sehe ihn nur grad nicht


Kommentar von Sawascwoolf ,

Mhhh... als ich meine Antwort formuliert hatte war deine noch nicht da^^

Kommentar von Jackie251 ,

das passiert ja schnell ma l^^

Antwort
von Sawascwoolf, 50

Nehme dir eine neue Spalte und verwende eine Formel in der Art:

WENN REST(ZEILE();4

DANN: INDIREKT("B"&ZEILE()/4)

FALLS NICHT deine Formel für die Interpolation

Keine passende Antwort gefunden?

Fragen Sie die Community