Frage von lukaswue, 45

Excel: Wie berechne ich den Mittelwert von Auswahlmöglichkeiten im Dropdownmenü?

Guten Abend! Ich möchte gerne eine Excel-Mappe zur Weinbewertung erstellen. Auf einem Blatt gibt man den Wein ein und kann (neben anderen Dingen, die für mich wichtig sind) in einem Dropdownmenü die Rebsorten auswählen. Da gibts dann für "Rebsorte1", "Rebsorte2", "Rebsorte3" und "Rebsorte4" jeweils ein Dropdownmenü. Daneben gebe ich dem Wein noch eine Bewertung von 0 bis 10. Auf einem anderen Blatt sind die einzelnen Rebsorten aufgeführt. Ich möchte dort nun gerne den Mittelwert der Bewertungen der Weine, weilche die entsprechende Rebsorte enthalten.

Als Beispiel: Ich habe einen Wein, der besteht aus Garnacha, Syrah und Cariñena. Diese drei Rebsorten wähle ich in den Dorpdown Menüs auf dem "Bewertungsblatt" aus. Der Wein erhält eine Bewertung von 8. Da dies der erste Wein ist, soll jetzt gerne auf dem "Rebsorten-Blatt" neben Garnacha, Syrah und Cariñena jeweils der Mittelwert 8 errechnet werden. Wie bekomme ich das hin? :-D

Vielen Dank an alle, die sich die Mühe machen, das zu verstehen und mir vielleicht zu helfen!

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 25

Ich muss eine neue Antwort schreiben, da ich sonst kein Bild anhängen kann. So ist es vielleicht verständlicher bzw. wenn Deine Tabelle ganz anders aufgebaut ist, kannst Du den Unterschied konkreter beschreiben.

Die Formel arbeitet so: Es wird zeilenweise die Summe ermittelt, wie oft die Rebsorte, die in A1 steht in Tabelle1 B:E erscheint und das Ergebnis mit der Punktzahl in Spalte F multipliziert (SummenProdukt). Da ja jede Rebsorte je Wein nur einmal genannt wird, ist es also immer 1 * Punktzahl. Für den Mittelwert wird das Ergebnis noch durch die Anzahl geteilt, wie oft die Rebsorte genannt wurde. Du muss, wenn die Zahl der Spalten vom Beispiel abweicht, also zwei Bereich anpassen: B:E in dem die Rebsorten stehen und die Spalte F mit den Punkten.

=SUMMENPRODUKT((Tabelle1!B$2:E$5=A1)*(Tabelle1!F$2:F$5))/ZÄHLENWENN(Tabelle1!B$2:E$5;A1)

Expertenantwort
von Ninombre, Community-Experte für Excel, 45

Das mit dem Dropdown hatte mich erst etwas irritiert. Wenn ich es aber richtig verstehe, entsteht doch einfach eine Tabelle, bspw.
Spalte A=Wein
Spalte B=Rebsorte 1
Spalte C=Rebsorte 2
Spalte D=Rebsorte 3
Spalte E=Rebsorte 4
Spalte F=Punkte

Wie diese Tabelle entsteht ist ja eigentlich egal.

Du möchtest doch herausfinden, wie oft bspw. Syrah genannt wurde und welche Punktzahl jeweils vergeben ist.

In einer Tabelle würdest Du also die diversen Rebsorten auflisten. Im konkreten Beispiel steht z.B Syrah in Zelle B12 und in C12 die Formel
=SUMMENPRODUKT((B$2:E$5=B12)*(F$2:F$5))/ZÄHLENWENN(B$2:E$5;B12)
Wenn die Rebsorten bzw. Punkte in anderen Spalten stehen, als ich im Beispiel genannt habe, musst Du das noch anpassen. Ich habe auch nur Zeile 2 - 5 verwendet.

Kommentar von lukaswue ,

Vielen Dank, bei mir funktioniert es leider nicht, da unter den Spalten B bis C Rebsorten stehen und keine Zahlen

Kommentar von Oubyi ,

DAS wird von Ninombres Formel auch so berücksichtigt.
Hast Du die Bereiche denn richtig angepasst.
Falls z.B. die Punkte bei Dir nicht in Spalte F stehen, musst Du das in der Formel ändern!

Kommentar von Oubyi ,

Wie ich sehe hast Du die Frage erneut eingestellt.
Sinnvoller wäre es imho gewesen, wenn Du erstmal auf meine Frage geantwortet hättest.
Notfalls wäre es auch sinnvoll, wenn Du den Aufbau Deiner Tabelle genau beschreibst oder sogar einen Screenshot hochlädst (dazu musst Du Dir hier - leider - selbst eine Antwort geben, das es im Kommentar nicht geht). Weise aber in einem Kommentar hier zustätzlich noch darauf hin.

Antwort
von TorDerSchatten, 40

Das dürfte mit Index und Vergleich in einer verschachtelten Funktion mit Mittelwert möglich sein.

Kommentar von Iamiam ,

ein Lichtblick! leider etwas zu sehr abgeschattet, um was erkennen zu können...

@FS: Habe Deine Frage mit dieser verwechselt/vermischt:

www.gutefrage.net/frage/excel-zaehlfunktion?

Schau mal, ob Du aus meiner AW dort was verwerten kannst!

(mach übrigens kein Dropown, sondern nimm die Summenproduktformel (ich glaube, die von Ninombre stimmt auch?), deren Ergebnisse sind dauerhaft!


Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten