Frage von ROHMNI1, 55

Excel Zählfunktion?

Hi Leute, ich bräuchte eure Hilfe.

Ich hab eine Exceltabelle mit 800 Zeilen in jeder Zeile steht ein Monat jeder Monat kommt mehrmals vor. Jetzt bräuchte ich eine Funktion die mir sagt wie oft jeder Monat vorkommt? Geht das?

Ich freue mich auf Antworten

Mit besten Grüßen

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Koellemann, 55

Die funktion heisst ZAEHLENWENN()

LG :)

Kommentar von ROHMNI1 ,

Kannst du mir die Formel dafür schreiben weil ich es leider nicht verstehe

Kommentar von Koellemann ,

Du schreibst in eine Zelle: 

=ZÄHLENWENN(A1:A800,"Januar")

Also als erstes den Bereich in dem nach dem Suchbegriff gesucht werden soll, danach den Suchbegriff, das kannst du fuer jeden Monat machen, soweit klar? :)

Expertenantwort
von Iamiam, Community-Experte für Excel, 29

wenn Du "Monat" als String in der Zelle stehen hast und nicht nur ein als Monat formatiertes Datum, kannst Du die beiden anderen Lösungen verwenden.

Ansonsten musst Du anders vorgehen:

  1. schreibe in die auszuwertende Zelle =TEXT("5.12.2015";"MMMM") oder - wenn Du
  2. eine Bezugszelle verwenden willst/musst: =TEXT(DatZelle;"MMMM") , beides liefert Dir einen Quasi-Text zur Auswertung mit Zählenwenn.
  3. Willst Du aber einen bestimmten Monat, zB März 2012, dann die Formel: =UND(A1>"29.02.2012"+0;A1<"1.1.12"*1) zur weiteren Auswertung ( beachte Schaltjahr!)hab hier zwei Eingabeformate exemplarisch aufgeführt. Die Rechenoperationen +0, *1 oder auch -0, /1 wandeln den Datumsstring zu einer Datumszahl um, die weiter ausgewertet werden kann. Ein Datumsbezug (ohne Gänsefüßchen) tuts natürlich auch.

im 3. Fall macht die Auswertung per Zählenwenn Schwierigkeiten: besser ist da =Summenprodukt(istdatum(A1:A9)(A1:A9>"28.02.2015"+0)(A1:A9<"1.1.16"1)) . Wichtig: die Zellenzahl aller 3 Nennungen muss gleich sein, ihre Lage kann aber anders sein, zB wenn in C1:C9 die Reb-Sorte steht:
=Summenprodukt((A1:A9>"28.02.2015"+0)(A1:A9<"1.1.16"1)(C1:C9="Trollinger"))
Kannst Du beliebig weiterführen, zB mit (D1:D9="Weissherbst")*(N1:N9<3) (wenn in Spalte N die Bewertung in Schulnoten steht, ergibt das alle guten und sehr guten, wegen >3 nicht mehr die Note 3 selbst!)
Hoffe, das gibt Dir Anregung zu weiteren Auswertungen. Zum nach-unten-Kopieren übrigens $-Zeichen verwenden oder (A:A>"28.02.2015"+0) etc. zur Auswertung der ganzen Spalten.

Kommentar von Iamiam ,

Die Fkt istdatum gibt es offenbar nicht, müsstest Du weglassen oder durch ISTZAHL() ersetzen (sollte nur eine Demofunktion für weitere Möglichkeiten sein)

im erklärenden Abshnitt ist mir mehrmals der Dezember 2015 reingerutscht bzw Mischformen Dez<=>Feb, konnte es nicht mehr korrigieren, wirst das schon bemerken. Ausserdem scheinen bei Aufzählungen die Mängel des alten Editors zu greifen: Vor und nach Kursivschrift muss ein * rein, zB:

=Summenprodukt(istzahl(A1:A9)*(A1:A9>"28.02.2015"+0)*(A1:A9<"1.1.16"*1))

oder

=Summenprodukt((A1:A9>"28.02.2015"+0)*(A1:A9<"1.1.16"*1))

Bei wenigen Zellen kann man auch die Einzelergebnisse überprüfen: Markierst Du in der Bearbeitungszeile zB den Abschnitt

(A1:A9>"28.02.2015"+0), so erhältst Du die entsprechenden WAHR/FALSCH aufgelistet, beim Markieren eines Produktes die entsprechenden 0/1  (das wird von Summenprodukt dann zusammengezählt)


Kommentar von Iamiam ,

Da hab ich Mist gebaut: hab diese Frage mit der vermischt: Wie berechne ich den Mittelwert von Auswahlmöglichkeiten im Dropdownmenü?

Kommentar von Iamiam ,

Für Dich gilt einfach (wenn alle November -auch diejenigen mehrerer Jahre- gezählt werden sollen):

=SUMMENPRODUKT((MONAT(A:A)=11)*1)

Du kannst ganz einfach weitere Bedingungen dranhängen, zB wieviele Dienstage in all diesen November(n,s?) vorkamen:

=SUMMENPRODUKT((MONAT(A:A)=11)*(Rest(A:A;7)=3))

Dienstag ist charakterisiert durch die Datumszahl mit Rest(A:A;7)=3.

Die Zahl gibt nicht die Zahl der Dienstage wieder, sondern die Zahl der Nennungen von Novemberdienstagen: das können mehr sein, wenn zB mehrere Aktivitäten(Nennungen) am selben Di erfolgt sind oder weniger, wenn nicht an jedem Dienstag eine Nennung erfolgte. Natürlich auch alle Kombinationen.

Kommentar von Iamiam ,

Korrektur:

Markierst Du in der Bearbeitungszeile zB den Abschnitt

(A1:A9>"28.02.2015"+0)

" und drückst F9 "

so erhältst Du die entsprechenden WAHR/FALSCH aufgelistet, beim Markieren eines Produktes die entsprechenden 0/1  (das wird von Summenprodukt dann zusammengezählt)

Antwort
von PWolff, 52

Ja, mit der ZÄHLENWENN-Funktion.

Kommentar von ROHMNI1 ,

Kannst du mir die Formel schreiben weil ich verstehe es nicht wie ich es machen soll?

Kommentar von PWolff ,

Wenn die Monate in Spalte C stehen und du in F1 stehen haben willst, wie oft in Spalte C "Februar" steht, schreibst du in F1

=ZÄHLENWENN(C:C;"Februar")

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten