Frage von nextwifey2k7, 51

Excel: Letzter Wert der Tabelle addieren - kann mir da einer weiterhelfen?

Hallo liebe Excel Freunde, ich tüftele schon seit mehreren Stunden rum, komme aber nicht auf die richtige Formel. Und Zwar möchte ich einen Wert aus einer anderen Zeile (Wenn >0) in einer Tabelle (Überschrift „Zahlungen“, in die letzte Zeile hinzuaddieren. Jedoch kann die Zeile in der Tabelle, je nach Datum, sich variieren. Es soll aber immer zu den letzten Betrag in der Tabelle hinzuaddiert werden. Kann mir da einer weiterhelfen? Wäre sehr Dankbar. Viele Grüße

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 51

Gehen wir davon aus, dass der zu addierende Betrag in XY1 steht.

In der Spalte (A) mit dem Betrag schreibst du:

A2: =WENN(UND(A3="";XY1>0);<Betrag>+XY1;<Betrag>)

In Worten: Wenn das direkt unten angrenzende Feld leer ist und der zu addirende Betrag größer als 0, dann addiere den Betrag zu dem, der hier sonst stünde, ansonsten schreibe in diese Zelle ganz normal den Betrag, ohne etwas zu addieren.

Wenn du die Beträge als fixe Werte vorliegen hast, kannst du eine Hilfsspalte einfügen mit der o. g. Formel und die Originalwerte später ausblenden.

Kommentar von nextwifey2k7 ,

Danke für die schnelle Antwort. Leider ist es nicht so einfach, da ich den Betrag bzw. Zeile auf den XY1 hinzuaddiert werden soll nicht kenne. Ich weiß nur die Spalte, die Zeile kann sich je nach Datum variieren. Der letzte Betrag in der Spalte könnte L4 sein, aber auch L90.

Kommentar von Suboptimierer ,

Dann wähle die zweite, vorgeschlagene Variante.

Füge hinter L eine Hilfsspalte M ein mit der Formel in M2 beginnend:

=WENN(UND(L3="";XY1>0);L2+XY1;L2)

Oder die erweiterte Version, die das Ende berücksichtigt:

=WENN(L2="";"";WENN(UND(L3="";XY1>0);L2+XY1;L2))

Ziehe die Formel herunter und blende dann die Spalte L aus.

Expertenantwort
von Iamiam, Community-Experte für Excel, 27

Da ich nicht weiß wie Deine Formelbezüge gestaltet sind, rate ich dazu, den Restwert (also die 5000) aus dem Rechenbereich herauszuverschieben, zB nach U1 (kannst später ausprobieren, wo überall es keinen Fehler gibt)

Dann gibst Du in T7 die Formel ein:

=wenn(und(E8="";E7>0);T1;0)

hoch- und runterziehen

Der Restwert erscheint nun nur einmal in der letzten gefüllten Zeile und Du kannst Deine Formel in L(7) einfach erweitern um +T(7) (ich bin davon ausgegangen, dass der Restwert nur einmal dazuaddiert werden darf, sonst ergäbe die Frage vermutlich keinen Sinn)

Anstatt E8║E7 kannst Du natürlich auch D8║D7 verwenden, sollte das Datum in die Berechnungen einfließen.

Das sollte es dann auch schon gewesen sein!

Wenn nicht, melde Dich nochmal!
Kommentar von Iamiam ,

Schlamperei! natürlich nicht T1, sondern U1, also

=wenn(und(E8="";E7<>"");U1;0)

das <>"" habe ich nur der Systematik wegen so formuliert, es geht auch >0, da auch Texte >0 sind

Kommentar von Iamiam ,

Ach ja, und zum Kopieren natürlich U$1, oder aber einen Namen vergeben, zB RestwertA, ein Name wird absolut übernommen.

Antwort
von nextwifey2k7, 49

So, anbei nochmal als Bild die Tabelle. In der Spalte T, ist ein Restbuchwert von 5000. Der muss in L7 hinzuaddiert werden. Und Zwar immer in der letzten Zeile. Es ist nur ein Zufall dass die letzte Zeile L7 ist. Es könnte auch, L12 sein, dann müssen die 5000 in L12 hinzuaddiert werden. Ich hab es leider mit deiner Formel nicht geschafft, und befürchte das wie übereinander reden.

Antwort
von PWolff, 46

Nicht besonders elegant, und kann vielleicht auch schiefgehen, aber im Versuch hat's geklappt:

=VERWEIS(9,999999E+307;L:L)

Vorausgesetzt, ich habe dich richtig verstanden, und du suchst den letzten Eintrag in Spalte L.

Kommentar von nextwifey2k7 ,

leider nicht, ich brauch ja noch den Bezug zu den Restwert von 5000. Die müssen ja in der letzten Zeile hinzuaddiert werden. Danke für deine Antwort

Kommentar von PWolff ,

In welcher Zeile soll die gesuchte Formel / das Ergebnis stehen?

Wie würde die Formel für verschiedene letzte Zeilen aussehen, wenn die letzte Zeile sich nicht verändern würde? (z. B. Zeile 7, Zeile 12, Zeile 15)

Kommentar von nextwifey2k7 ,

Die Formel kann beliebig stehen. Das Ergebnis muss nur in der letzten Zeile im L stehen. In dem Fall 15000 + 5000. Die Formel müsste also automatisch den Restwert in die letzte Zahlung hinzuaddieren.

Kommentar von PWolff ,

Woher kommt der Wert in Spalte L? Wenn er aus einer Formel kommt (und z. B. in Spalte E genau dann ein Wert steht, wenn in Spalte L ein Wert steht / stehen soll), ist es einfach - hier für L7:

= (bisherige Formel) + WENN(ANZAHL2(E:E)=ANZAHL2(E$1:E8); 0; R$4)

Wenn der Wert in Spalte L von Hand eingetragen wird, ist es ohne Rückgriff auf Makroprogrammierung kaum möglich.

Kommentar von nextwifey2k7 ,

funktioniert leider auch nicht. er berechnet einfach nicht die 5000 in die letzte Zeile der Leasingzahlungen :(

Kommentar von PWolff ,

Was steht jetzt in den Zellen der Spalte L drin?

Kommentar von nextwifey2k7 ,

da steht leider nichts drin, er hat die 5000 nicht berücksichtigt. Die Zeile in der ich die Formel eingegeben habe, steht 20000, die sollten aber in der letzten Zeile L stehen.

Diese Formel habe ich eingegeben:

=VERWEIS(9,999999E+307;L:L)+ WENN(ANZAHL2(E:E)=ANZAHL2(E$1:E8); 0; B$22)

(B22 = Betrag des Restwerts)

Kommentar von PWolff ,

Hä?

Wenn du L1 markierst, was steht dann in der Eingabezeile?

Wenn du L2 markierst, was steht dann in der Eingabezeile?

...

Kommentar von nextwifey2k7 ,

tut mir leid, ich hab dich falsch verstanden.

also die Formel bei L: =WENN(D8="";"";$B$8)

In B8 ist die Leasingrate als Zahl eingegeben.

Kommentar von PWolff ,

Dann müsste

=WENN(D8="";"";$B$8+WENN(ANZAHL2(E:E)=ANZAHL2(E$1:E8);0;R$4))

funktionieren. (Wobei ich mich noch frage, warum da $B$8 statt $B8 steht.)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten