Frage von goodQ2, 140

Excel Spalte auslesen?

Mojn, ich komme bei Excel nicht weiter.

Ich habe zB eine Tabelle mit 3 Spalten und 10 Zeilen, in jedem Feld steht ein Buchstabe. Ich möchte gerne aus der dritten Spalte alle "A" gezählt haben, wenn in deren Zeile in Spalte 1 ein A ist und in Spalte 2 ein B (oder umgekehrt).

Mit ZÄHLENWENN komme ich hier nicht weiter oder?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von DeeDee07, Community-Experte für Excel, 67

Probier mal

=SUMMENPRODUKT(((A1:A10&B1:B10="AB")+(A1:A10&B1:B10="BA"))*(C1:C10="A"))

Kommentar von goodQ2 ,

Klappt ebenfalls wunderbar, vielen Dank!

Kommentar von Ninombre ,

summenprodukt löst gefühlt die Hälfte aller Probleme und Sorgen mit Excel

Kommentar von DeeDee07 ,

Ja. Wobei man auch kürzer

{=SUMME(((A1:A10&B1:B10="AB")+(A1:A10&B1:B10="BA"))*(C1:C10="A"))}

verwenden könnte. Aber dann muss man noch den Umgang mit Matrixformeln erklären :)

Kommentar von Iamiam ,

wobei ZählenwennS wahrscheinlich die geforderte Lösung wäre, aber da wir hier keine Hausaufgaben bearbeiten wollen, sehe ich auch Summenprodukt als die "fortschrittlichste" Lösung an, die ich auch für eigene Probleme -Pardon: natürlich Herausforderungen!-  bevorzuge! (bei uns im Konzern war das Wort Problem verboten, es gab nur "challanges")

Antwort
von Rubezahl2000, 71

Mach doch eine Hilfsspalte, in Spalte D, in der die 3 Buchstaben aus den 3 Spalten A, B, C zusammen in 1 Zelle sind.
Dazu gibst du in Zelle D1 die Formel =A1&B1&C1 ein und kopierst die Formel runter. In D1 steht dann "ABA", in D2 steht dann "DDD", und so weiter.

Deine "Zählenwenn-Formel" beziehst du dann auf Spalte D und gibst als Vergleichswert "ABA" ein.

Wenn dich die Hilfsspalte in der Ansicht stört, kannst du sie ausblenden.

Kommentar von goodQ2 ,

Super, funktioniert. Danke!

Kommentar von DeeDee07 ,

Die Formel sollte lt. Aufgabe aber auch "BAA" zählen, oder?

Kommentar von goodQ2 ,

Ist richtig, diese Variante hätte ich noch ein wenig modifizieren müssen

Antwort
von ShadowYukkii, 91

Ich bin mir nicht sicher ob das auch mit Buchstaben klappt aber es wenn du diese Reihe auswählst dann ist oben so eine leite da musst du dann z.B. =C1:C10 eingeben und dann Enter drücken! Hoffe es klappt bei dir, da ich nicht weiß ob es mit Buchstaben auch geht! Kannst mir ja bitte Bescheid sagen ;)

Kommentar von goodQ2 ,

Danke für die Antwort, aber ich glaube das löst mein Problem nicht. Ich habe kein Problem damit, eine Spalte auszuwählen, sondern eher die Formel zu erstellen um das o.g. Ergebnis zu bekommen :)

Kommentar von ShadowYukkii ,

=C1:C10

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten