Frage von FelixWerner,

Excel: Tabelle nach bestimmten Inhalten durchsuchen und ganze Zeile ausgeben

Hallo. Ich habe eine riesige Excel Tabelle A1:H4999. Jetzt möchte ich diese "sortieren". Ich möchte das diese Tabelle durchsucht wird und alle (kompletten) Zeilen ausgegeben werden in denen in Spalte D das Wort "Werbung" , in Spalte F das Wort "Italien" und in Spalte H das Wort "privat" steht. Jemand ne Idee?

Danke.

Antwort von Iamiam,

Wenn die genannten Wörter innerhalb eines Textes vorkommen, in einer Zusatzspalte die Formel:
=ZÄHLENWENN(D2;"* werbung* ")+ZÄHLENWENN(F2;"* italien* ")+ZÄHLENWENN(H2;"* privat* ")

setzen (Leerzeichen nach den * alle rausnehmen!) und runterziehen.
Dann mit dem Autofilter nach Ergebnis = 3 suchen

Antwort von Jangor,

Verwende die (Auto)Filterfunktion - je nach Version. Ganze Tabelle markieren - unter Daten/Autofilter (2003) bzw. Filter (2007 & 2010) auswählen. Dann hast Du in der Überschrift bei jeder Spalte einen kleinen Button. Wenn Du den anklickst, kannst Du die Begriffe auswählen die Du filtern möchtest.

Kommentar von FelixWerner,

Super. Danke, klappt hervorragend.

Kommentar von Iamiam,

wenn nichts anderes als jeweil dieses Wort in der Zelle steht, ja, aber ich habe die Frage so verstanden, dass diese Wörter innerhalb eines Textes vorhommen?

Keine passende Antwort gefunden?

Verwandte Fragen

Fragen Sie die Community

Weitere Fragen mit Antworten