Frage von Enrico87, 58

Excel - Wie Zellen mit doppelten Artikelnumnmern zusammenrechen?

Hallo Ich habe in einer Tabelle doppelte Artikelnummern, deren Duplikate jeweils unterschiedliche Mengen haben.

Die Mengen aller Duplikate, weürde ich gern addieren und die Duplikate dabei entfernen.

Weiß jemand, wie das geht?

Danke Euch :)

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von daCypher, 31

Mein algemeiner Klugscheißerspruch: Excel ist eine Tabellenkalkulationssoftware und keine Datenbanksoftware. Daher macht es auch keinen Sinn, Datenbanken in Excel zu führen.

Um dir trotzdem zu helfen: Schau dir mal die Funktion "Pivot-Tabelle" an. Also alles markieren, dann auf Einfügen > Pivot-Table gehen. Dann geht rechts so ein Auswahlfenster auf. Da machst du bei "Item" und "Menge" einen Haken rein und guckst, dass weiter unten im Feld Zeilenbeschriftung das Item drinsteht und bei Werte muss "Summe von Menge" drinstehen.

Kommentar von Enrico87 ,

Leider klappt das mit der Pivottabelle nicht, das habe ich bereits versucht, die zeigt mir dann bei jedem Artikel "Anzahl von Menge" 1

Kommentar von daCypher ,

So wie es aussieht, sind die Zahlen bei dir alle als Text formatiert. Wandel die erstmal alle in Zahlen um. Also in C2 die Formel: =WERT(B2) und das dann runterziehen.

Wenn dir dann in der Pivot-Tabelle bei Werte immer noch Anzahl von Menge angezeigt wird, kannst du raufklicken, dann auf "Wertfeldeinstellungen" und dort aus der Liste dann Summe auswählen.

Kommentar von Enrico87 ,

Super 1000-Dank es hat an den Wertefeldeinstellungen innerhalb der Pivottabelle gelegen :)

Kommentar von daCypher ,

Bitteschön :)

Antwort
von Rubezahl2000, 11

Genau für solche Zwecke gibt's Pivottabellen in EXCEL!
Leg in EXCEL eine Pivottabelle an zu deiner Tabelle!
Da kannst du ganz einfach auswerten nach den Artikelnummern und da werden dann automatisch die doppelt vorhanden Artikelnummern zusammengefasst und die Werte addiert bzw. zusammen gezählt - wie du möchtest.


Antwort
von iMPerFekTioN, 24

Hallo =)

Versuche doch mal =ZÄHLENWENNS()

Ansonsten, kannst du das auch mit nem =SVERWEIS() regeln. (Denke ich zumindest)

Wenn du alle Daten ausgefiltert hast, kopiere die ausgefilterten Daten und gehe in ein neues Tabellenblatt. Gehe dann auf einfügen und dann auf Inhalte einfügen.

Wähle dort dann Nur Text aus, somit werden die ausgaben gespeichert und die Formeln ersetzt.

Dann kannst du die alte Tabelle löschen und hast alle Werte die du brauchst ohne deine doppelten Einträge.

Grüße,

iMPerFekTioN

Kommentar von Enrico87 ,

Klingt für den Anfang ganz gut, mit einem kleinen Schwachpunkt :) wenn ich wüsste, wie ich den Sverweis nutzen muss, wäre ich bestimmt selbst drauf gekommen - nur leider hab ich gar keine Ahnung wie ich die Funktion definieren muss :(

Kommentar von iMPerFekTioN ,
=SVERWEIS(A1;$A$1:$B$900;2;0)+SVERWEIS(A1;A2:$B$900;2;0)

Würde zum Teil funktionieren.

Jedoch ist das Problem, das ich und du wahrscheinlich auch nicht weißt, wie oft ein Wert doppelt vorkommt.

Darum sind die anderen Antworten echt besser =D

SUMMEWENN() wäre also auch besser als ein SVERWEIS()

Hab das vorher falsch geschrieben tut mir Leid....

Dazu musst du nur deine Artikelnummern einmal hierarchisch untereinander schreiben, in die Zeile D dann gibst du in die Zelle E1 ein

=SUMMEWENN(A1:B200;D1;B1:B200)

Dann hasst du die Daten zusammengefasst.


Grüße,


iMPerFekTioN

Antwort
von Sansibar007, 9

Zählenwenn ist hier die praktikabelste Lösung.

SVERWEIS macht hier keinen Sinn, da er beim ersten "Treffer" aufhört.

Antwort
von FGO65, 24

Duplikate addieren geht mit Teilergebnissen und Duplikate entfernen mit der Funktion "Duplikate entfernen"

Keine passende Antwort gefunden?

Fragen Sie die Community