Das ist VBA-Code und wird im Visual Basic-Editor eingegeben:

  • platziere das Drehfeld auf Deinem Tabellenblatt
  • Rechtsklick auf das Drehfeld und "Code anzeigen" auswählen
  • lösche den Text "Private Sub SpinButton1_Change()" und "End Sub"
  • füge den Code aus Deiner Frage ein

Wenn nun in A1 eine Zahl steht, dann wird auf jeden Drehfeld-Klick 0,1 addiert oder subtrahiert.

...zur Antwort

Hallo,

starte im Excel den Visual Basic-Editor (Extras --> Makro --> Visual Basic-Editor) und wähle im Projekt-Explorer Dein Projekt und das entsprechende Tabellenblatt aus (s. Bild). Gib dann im Codefenster folgenden Code ein:

 Private Sub Worksheet_Change(ByVal Target As Range)
     If Range("D19").Value = "Falsch" Then Range("D20").Value = ""
 End Sub

Das Makro wird ab sofort jedesmal aufgerufen, wenn in Deinem Tabellenblatt ein Wert geändert wird.

...zur Antwort

Hi, antworte Dir hier nochmal separat, da ich zwei Bilder angehängt habe (was bei Kommentaren nicht geht).

Also wenn ich Dich recht verstehe, willst Du Internet-Seiten mit Bild und Text ins Excel kopieren und anschließend die Bilder löschen. Dieser Vorgang soll mehrmals wiederholt werden, wobei Excel jedesmal den Zähler für die Bilddateien erhöht. Soweit richtig?

Mit folgendem Codebeispiel sollte Dich der von Excel vergebene Name nicht interessieren, da das ganze über eine For Each-Schleife abgearbeitet wird. Hier kommts dann auch nicht zu einem Zählerüberlauf. Die 4 oder 5 Objekte, die Du selbst erstellt hast und die nicht gelöscht werden sollen nimmst Du explizit heraus.

Dim o As Object
For Each o In ActiveSheet.Shapes
   If o.Name <> "Bild 1" And o.Name <> "Bild 2" And o.Name <> "Bild 3" And o.Name <> "Bild 4" Then
        o.Delete
   End If
Next

Im folgenden Beispiel (s. Bild 1) sind die auszuschließenden Objekte mit "Bild 1" bis "Bild 4" benannt. Nach dem Ausführen des Skriptes sind alle Bilder (bis auf die erwähnten 4) gelöscht (s. Bild 2).

Vielleicht hilft Dir das weiter?

...zur Antwort

Normalerweise solltest Du die eingefügten Bilder über ActiveSheet.Shapes("Name des Bildes") ansprechen können. Für "Name des Bildes" steht der im Namensfeld angezeigte bzw. zugewiesene Name. Beim Einfügen aus anderen Anwendungen bekommen die Bilder normalerweise die Namen "Bild 1", "Bild 2" oder "Objekt 1", "Objekt 2" usw. zugewiesen.

Um jetzt den Namen (und damit den Zähler) zu ändern weist Du im VBA-Code einfach einen neuen Namen zu. Bsp.:

  ActiveSheet.Shapes("Alter Name").Name = "Neuer Name"

Hilft Dir das weiter? Wenn nicht, dann poste mal nen Stück Quellcode.

...zur Antwort

Du kannst Dir die Zeichen innerhalb der Klammern über eine Excel-Funktion zurückgeben. Bsp. steht der Text in Spalte A1 dann gib folgende Formel ein:

=WENN(ISTFEHLER(FINDEN("(";A1));"";TEIL(A1;FINDEN("(";A1)+1;FINDEN(")";A1)-FINDEN("(";A1)-1))

Möchtest Du den Ergebnis-Text an anderer Stelle weiterverwenden, so einfach alles kopieren und über "Bearbeiten --> Inhalte einfügen... --> Werte" die Ergebniswerte einfügen.

...zur Antwort