Wie kann ich, wenn bestimmter Wert überschritten dann x in in nächste Spalte eintragen?

... komplette Frage anzeigen

6 Antworten

Das kannst du hiermit sehr leicht erreicht

=WIEDERHOLEN("x";A1/20)

wenn die Zahl in A1 steht

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
30.11.2016, 11:57

oh sehe grad an deinen Kommentaren das du etwas ganze anderes meintest als das wie ich deine Frage verstanden hatte.
Sorry

0
Kommentar von augsburgchris
30.11.2016, 11:58

Noch nicht ganz. Ok, so bekomme ich ein x in alle Zellen grösser 20 und 2x in in alle grösser 40 usw. 

Aber ich will hier jeweils nur das erste vorkommen angezeigt haben. 

Ansatz aber soweit schon mal super. 


1

siehe meine AW zu

www.gutefrage.net/frage/wie-runden-oder-schwellenwerte-verwenden?

Du musst nur  die Terme Ganzzahl(C1) und Ganzzahl(C1+A1) ersetzen durch

Ganzzahl(C1/20) und Ganzzahl((C1+A1)/20) ersetzen und die Spalten anpassen  -glaube ich ;)

Antwort bewerten Vielen Dank für Deine Bewertung

Noch ein Vorschlag:

=WENN(REST(A1;20)=0;"X";"")

Gruß aus Berlin

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von augsburgchris
30.11.2016, 12:48

Funktioniert aber leider nur wenn die 20 enthalten ist. Wenn der erste Wert über 20 die 23 ist klappt es leider nicht mehr. Aber trotzdem Danke. Gute Verkürzung für diesen Fall.

0

in die Zelle, in der das X stehen soll =WENN(<vorherige Zelle> > 20; "X"; "")

Das kannst du dann auf alle anderen Zellen weiterziehn.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von augsburgchris
30.11.2016, 11:36

nein kann ich nicht, weil dann jeder Wert über 20 markiert wird. ich will aber nur die erste Zeile die über 20 ist markiert haben. respektive das selbe mit 40, 60, 80

0

erster Wert über 20, erstere Wert über 40, erster Wert über 60 und erster Wert über 80.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jackie251
30.11.2016, 12:04

hier nochmal damit es nicht untergeht

=WENN(GANZZAHL(A2/20)>GANZZAHL(A1/20);"x";"")

sollte das Problem lösen

1
Kommentar von Oubyi
30.11.2016, 15:14

20 ist aber nicht "erster Wert über 20,"
Ansonsten siehe meine Antwort.

0

Ich habe mich jetzt mal - auf die Schnelle - nur an Deinem Screenshot orientiert und mich nicht durch die Antworten gearbeitet:

Wie wäre es mit dieser Formel in B2! und runterkopieren:

=WENN(A2>((ZÄHLENWENN($B$1:B1;"x")+1)*20);"x";"")

Sieht zumindest in meinem Test so aus wie Dein Beispiel.

Antwort bewerten Vielen Dank für Deine Bewertung