Frage von mexrrrh, 193

Excel 2010 farbige Zellen zählen aber unter bestimmten Vorraussetzungen?

Hallo,

ich habe folgendes Problem. Ich habe vor mir eine Excel Tabelle. Es gibt in einer Spalte verschieden farbig markierte Zellen. Ich möchte diese nun Zählen. Ich habe bereits eine Hilfspalte mit den Zahlen für die Farben. Nun mein Problem: Ich möchte die Zellen zählen in denen die Farbe grün ist, aber nur die Zählen die auch in einer anderen Spalte einen bestimmten Wert haben. Wie kann ich das machen?

Vielen Dank schonmal im vorraus!

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 142

Das kannst Du mit zählenwenns machen. 

z.B. =zählenwenns(A1:A10;"X";D1:D10;3) Das zählt die Zeilen bei denen A = X und Farbe = 3 (in der Hilfsspalte D) ist.

Generell: Farbige Markierungen sind keine gute Lösung in Excel, v.a. nicht die Variante Farben manuell zu setzen und dann versuchen auszuwerten. Wenn Farbe, dann über bedingte Formatierungen, denn diese Regeln kann man auch in Formeln sauber auswerten.


Kommentar von mexrrrh ,

Perfekt, danke!

Das ist genau das was ich gesucht habe. Ist ja gar nicht schwer.

Antwort
von marzia7, 130

1. Starten Sie Excel auf Ihrem Computer.

2. Wechseln Sie in den Tab "Formeln" und klicken Sie auf "Namen definieren".

3. Nun können Sie eine neue Formel definieren Benennen Sie diese mit "Farbe" und fügen Sie unter "Bezieht sich auf" die Eigenschaft "=ZELLE.ZUORDNEN(24;INDIREKT("ZS(-1)";))" ein, sofern Sie die Schriftfarbe zählen möchten.

4. Möchten Sie stattdessen die Hintergrundfarbe der Zelle zählen, müssen Sie hier die Eigenschaft "=ZELLE.ZUORDNEN(63;INDIREKT("ZS(-1)";))" einfügen. Speichern Sie die Eingaben mit "OK".

5. Fügen Sie jetzt in der Hilfsspalte B1 die Formel "=Farbe" ein und kopieren Sie sie herunter, bis Sie das Ende der farbigen Zellen erreicht haben.

6. Sie sehen in der Hilfsspalte nun die Zahlen für der jeweiligen Farben (3 ist z. B. rot). Um eine bestimmte Farbe zu zählen, nutzen Sie nun die Formel "=ZÄHLENWENN(B:B;3)" – die "3" definiert hier die Farbe, die gezählt werden soll.

http://praxistipps.chip.de/excel-farbige-zellen-zaehlen-so-gehts_31568

Also bei mir klappt das immer^^

Kommentar von mexrrrh ,

Das weiß ich danke.

Ein Beispiel:

Ich habe in Spalte C die Farben.

In Spalte D meine Hilfsspalte mit den Zahlen.

Nun möchte ich die grünen Zellen in Spalte C zählen, aber nur die die in Spalte A einen bestimmten Wert haben.

Kommentar von marzia7 ,

Ohne Datei ist das schwer zu erklären... ich würde ja gerne sagen, schick sie mir und ich maches^^ aber davon weisst du ja auch nicht wies geht...

Kommentar von mexrrrh ,

aber ich seh die Formel und kann es dann übertragen ;)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten