Frage von MarissaassiraM, 85

Wie codiert man bzw. wertet man eine Frage mit Mehrfachantworten bei Excel aus?

Hallo, ich muss einen Fragebogen mit mehreren Fragen mit Mehrfachantworten auswerten. Für die anderen Fragen verwende ich ja einfache Zahlencodes, welche ich dann mit der ZÄHLENWENN Funktion zählen lasse um die Häufigkeit zu erhalten. Nun ist das bei Mehrfachanworten ja nicht möglich, weil das Programm nur einen einfachen Zelleninhalt (z.B. 3) zählt und nicht mehrere gleichzeitig (z.B. 3, 4, 5).

Hat jemand eine Idee wie ich das lösen könnte (ohne für jede Frage eine eigene Spalte erstellen zu müssen)? Glg Marissa

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von DeeDee07, Community-Experte für Excel, 83

Ich bin für den Grundsatz "Jede Information in eine eigene Zelle", würde also für jede Angabe eine eigene Spalte verwenden.

Da du das nicht möchtest, kannst du auch für jedes Produkt (lassen wir mal "Sonstiges" weg) zwei Zeichen für angekreuzt und nicht angekreuzt verwenden. Du hättest dann z.B. eine Zahl wie 10110001, d. h Kreuz, kein Kreuz, Kreuz, Kreuz, kein Kreuz usw. (bei 1 und 0 die Zellen als Text formatieren wg. führender Nullen)

Wenn du jetzt wissen möchtest, wie oft an der ersten Stelle eine 1 steht, erhälst du das mit

=SUMMENPRODUKT((TEIL(A1:A99;1;1)="1")*1)

Expertenantwort
von Ninombre, Community-Experte für Excel, 81

Eine Variante wäre vielleicht:
Wenn Du als Antwort tatsächlich 3,5 / 2,3,4 / 1,3 da stehen hast (untereinander bspw. in Spalte E)
=ANZAHL(FINDEN("3";E1:E10))

Kommentar von Iamiam ,

geht vermutlich nicht, sondern so: =Summenprodukt(Nicht(istfehler(Finden("3";E1:E10)))*1)

aber DeeDee hat mittlerweile eine einfachere Lösung.

Kommentar von Iamiam ,

geht doch, aber nur als Matrixformel:

{=ANZAHL(FINDEN("3";E1:E10))}

(also ohne { } schreiben und mit Strg+Umsch+Enter eingeben)

Kommentar von Ninombre ,

Argh, ja Danke für die Ergänzung, ich hatte das natürlich als Matrixformel ausprobiert, dann aber nicht in der Antwort dazugeschrieben.

Antwort
von PWolff, 73

Wie speicherst du die Werte der Mehrfachauswahl?

Wie wäre es mit mehreren ZÄHLENWENN-Abfragen?

Keine passende Antwort gefunden?

Fragen Sie die Community