Frage von blaueraupe, 163

Wie addiert man den jeweils aktuellen Monat hinzu?

Hallo, ich habe in Excel eine Tabelle mit Werten in jedem Monat von Jan - Dez. Ich möchte nun eine Summe mit den jeweiligen Monaten bilden. D.h. im Januar soll nur der Wert aus Januar stehen, im Februar soll er Jan + Feb addieren, im März soll er Jan + Feb + Mrz addieren. Ich möchte aber nicht jeden Monat einen neue Formel eingeben müssen. Gibt es eine andere Lösung?

Expertenantwort
von Oubyi, Community-Experte für Excel, 67

Zitat:
"Bei mir steht z.B. folgendes in den Zellen:

A1 = Jan = 5 Euro
A2 = Feb = 8 Euro
A3 = Mrz = 3 Euro usw.
A13 = Summe
Dann soll er im Januar nur die Summe von Januar bringen (nämlich 5),
im Februar soll er aber dann die zwei Monate zusammenzählen (Ergebnis
13) usw."  

Dann in A13 z.B. diese Formel (wobei ich davon ausgehe, dass die "Euro" per Formatierung angezeigt werden):

=SUMME(INDIREKT("A1:A"&MONAT(HEUTE())))



Expertenantwort
von Ninombre, Community-Experte für Excel, 121

=SUMME($A2:INDIREKT(ADRESSE(2;SPALTE(A4))))

Für das Beispiel, dass die Werte in Zeile 2 zu addieren sind.
Normale Summe über einen Bereich, wobei der Beginn des Bereichs mit A2 fixiert ist und beim "rüberziehen" der Formel auf die anderen Monate jeweils um eine Spalte erweitert wird.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 115

Wenn du in Spalte A die Datumswerte hast (15.01.2016, 18.03.2016,...), kannst du mit SUMMENPRODUKT dir die Werte aus Spalte B bis zum angegebenen Monat kumulieren:

=SUMMENPRODUKT((MONAT(A1:A3)<=2)*B1:B3)
Antwort
von Shiftclick, 110

Schau mal bei SUMMEWENN() nach.

https://support.office.com/de-de/article/SUMMEWENN-Funktion-169b8c99-c05c-4483-a...

Kommentar von blaueraupe ,

Danke, ich kenne die WENN Funktionen

Kann ich die auch 12x anlegen?

D.h. Wenn A1 = "Jan";Summe Jan;

Wenn A2 = "Feb";Summe Jan+Feb;

usw

Antwort
von toterbiber, 77

Du addierst immer einfach den Wert aus dem aktuellen Monat mit der vorherigen Summe.

Sagen wir mal A1, A2, A3, ..., sind die Monate Januar, Februar, März, ..., im B1, B2, B3, ..., stehen die einzelwerte, in C1, C2, C3, ..., willst du die summe bilden. Dann ist

C1 = B1,

C2 = C1 + B2,

C3 = C2 + B3,

C4 = C3 + B4,

usw.

Die Formel kannst du einfach runterziehen nur die erste Zelle ist halt eine andere Formel.

Kommentar von blaueraupe ,

So einfach gehts leider nicht. Ich möchte, dass sich die Formel ändert, wenn sich der Monat ändert.

D.h. im Januar muss er etwas anderes rechnen, als im Februar usw.

Bei mir steht z.B. folgendes in den Zellen:

A1 = Jan = 5 Euro

A2 = Feb = 8 Euro

A3 = Mrz = 3 Euro usw.

A13 = Summe

Dann soll er im Januar nur die Summe von Januar bringen (nämlich 5), im Februar soll er aber dann die zwei Monate zusammenzählen (Ergebnis 13) usw.

Ich kann die Formel auch nicht jeden Monat verändern, weil ich die Tabelle für jemanden anderes mache und derjenige sich überhaupt nicht auskennt.

Kommentar von toterbiber ,

Aha, du möchtest also, dass sich die Summe ändert je nachdem welche Monat wir aktuell haben? Verstehe ich das nun richtig?

Kommentar von blaueraupe ,

ja genau! Habe schon überlegt, ob ich irgendwo ne Hilfszelle mit einbaue, aber ich komm auf keine gescheite Lösung.

Kommentar von toterbiber ,

Die Antwort von Suboptimierer sollte dann funktionieren. Du verwendest für den Filter <=2 dann statt der 2 einfach Monat(Heute()), das ergibt dann eine Zahl zwischen 1 und 12.

Kommentar von Shiftclick ,

Vielleicht habe ich es mir auch zu kompliziert vorgestellt....

Vielleicht tut es auch eine Formel, die einfach den Wert des Monats zu der Summe aus dem Vormonat addiert?

http://www.pic-upload.de/view-29488252/Excelsheet.jpg.html

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten