Wenn dann Sonst Funktion bei Excel mit 3 Kriterien?

... komplette Frage anzeigen

4 Antworten

woran hängt es noch? Wenn ich die fertige Formel hinschreibe, hast Du nichts neues gelernt.

WENN DANN SONST
Bei Sonst setzt dann die nächste WENN Abfrage an.
die letzte Bedingung (unter 20 Grad) musst Du nicht explizit abfragen - das ist dann das SONST

Wichtig ist nur die Reihenfolge der Prüfungen, denn sobald die erste Bedingung erfüllt wird, prüft Excel nicht mehr die weiteren Bedingungen. Wenn Du mit > als arbeitest, also zunächst die höchste Temperatur abfragen, dann absteigende Temperaturen.

 

Antwort bewerten Vielen Dank für Deine Bewertung

Das kannst du nahezu 1:1 in die WENN-Funktion übernehmen

WENN(Temp>25;"baden";WENN(Temp<20;"Rad fahren";"lernen"))

Antwort bewerten Vielen Dank für Deine Bewertung

Mach einfach noch ein Wenn in das Sonst der darüberliegenden Wenn-Funktion:
Wenn über 25 "baden" sonst wenn unter 20 "Rad fahren" sonst "lernen"

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von BODOPPELTZ
29.10.2016, 14:51

=WENN($B$2:$B$13 > 25;"baden";"Rad fahren") so ist es normal ohne lernen aber wie soll es mit lernen sein :/

0
Kommentar von MatthiasHerz
29.10.2016, 14:56

=WENN($B$2:$B$13 > 25;"baden";"Rad fahren") wäre nach der Vorgabe aber falsch, weil unter 20°C Rad fährst, nicht bei 25 oder weniger.

Du musst also auf jeden fall die zweite Bedingung abfragen.

0

Dazu verschachtelst zwei WENN-Funktionen:

Wenn (Bedingung1; ...; wenn (Bedingung2; ... ; ...))

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?