Frage von blir14, 185

Wenn A1=A2="X" Dann "Ja" sonst "nein" Excel Wenn dann formel?

Hallo ich möchte ein bisschen mit Excel rumprobieren und komme grad nicht weiter. Ich möchte ein Tikatoospiel erstellen die Frage ist nur wie sage ich das wen A1 und A2 und A3 X ist gewonnen wenn nicht leer machen kann. =WENN((A1=B2=C3)="X";"Gewonnen";"…") =WENN((A1&B2&C3)="X";"Gewonnen";"…") =WENN(A1=B2=C3="X";"Gewonnen";"…") =WENN(A1&B2&C3="X";"Gewonnen";"…") gehen alle nicht

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 109

Wenn in keiner Zelle X mehrfach stehen kann, ist am einfachsten

=WENN(A1&A2&A3="XXX";"gewonnen";"")

Mit deinem letzten Vorschlag bist du also schon nah dran.

Der normale Weg ohne Tricksen ist:

=WENN(UND(A1="X";A2="X";A3="X");"gewonnen";"")

oder 

=WENN(A1="X";WENN(A2="X";WENN(A3="X";"gewonnen";"");"");"")

_____________

Praktisch würde ich es so machen, dass du einfach unter jeder Spalte und rechts neben jeder Zeile und die Diagonalen überprüfst. =UND(A1="X";A2="X";A3="X") und dann nur noch überprüfst =WENN(UND(<Bereich Zwischenergebnisse>);"gewonnen";"")

Kommentar von blir14 ,

Vielen dank. habe ich noch die Möglichkeit mehrer Möglichkeiten zu erstellen in einer Zelle? so was wie:
=WENN(UND(A1="X";A2="X";A3="X")oder(und(A1="X";b2="X";c3="X");"Gewonnen";"")

Kommentar von Suboptimierer ,

Ja geht, wird nur unübersichtlich. Besser du machst pro Tripel eine Abfrage in einer eigenen Zelle.

Kommentar von blir14 ,

Schon möchte es aber dennoch testen. Wo wie ich es eingegeben habe geht es nicht haben Sie eine Idee?

Kommentar von Suboptimierer ,

Du musst das ODER ganz nach vorne ziehen. Die Schreibweise ist funktional, nicht wie man spricht:

=WENN(ODER(UND(...);UND(...);UND(...);...)

Kommentar von blir14 ,

habe es:

=WENN(ODER(UND(A1="X";A2="X";A3="X");UND(A1="X";B2="X";C3="X"));"Gewonnen";"")

Danke für die hilfe

Kommentar von Iamiam ,

da fehlen natürlich noch 6 Möglichkeiten (B1 senkrecht, C1 senkrecht, A2waagrecht, A3 waagrecht, 2 Diagonalen, aber das Prinzip mit den Und innerhalb der Oder ist genau das Richtige!

Expertenantwort
von Iamiam, Community-Experte für Excel, 68

übersichtlicher als mit einer verschachtelten Wenn-Formel ist eine verkettete, wobei ich hier

anstelle von zB =wenn(und(A1="x";B1="x";C1="x");1;0)

die Logik-Verknüpfung WAHR*WAHR*WAHR

(wird durch math. Operation * zu 1*1*1 (oder FALSCH =>0)) verwende, ist einfach kürzer. Das äussere Wenn braucht es natürlich trotzdem.

=WENN((A1="x")*(B1="x")*(C1="x")+(A2="x")*(B2="x")*(C2="x")+(A3="x")*(B3="x")*(C3="x")+(A1="x")*(A2="x")*(A3="x")+(B1="x")*(B2="x")*(B3="x")+(C1="x")*(C2="x")*(C3="x")+(A1="x")*(B2="x")*(C3="x")+(A3="x")*(2="x")*(C1="x")>0;"☻Gewonnen☺";"☹")

im Prinzip hat dkilli mit UND((A1="x";B1="x";C1="x")+... das Gleiche gemacht, nur vllt etwas xl-näher.

Aber da mehr als drei x auftreten könnten in 2 Gewinnkonstellationen (mind. 5 x), darf die Summe nicht =1 festgelegt werden, sondern muss einfach >0 lauten, das erfüllt hier denselben Zweck.
+ hat Priorität vor > , braucht also keine eigene Klammer.

Das Ganze erscheint Dir im Moment vllt noch etwas undurchsichtig, wirst Du aber später (sofern Du Dich wirklich in xl weiterbilden willst) vllt gut gebrauchen können. (Boule*sche Logikzahlen als Stichwort für zB gugl und/oder Wikipedia)

Kommentar von Iamiam ,

vor lauter Spiele hab ich Boule geschrieben, der Mann heißt natürlich Boole

hier ein Link (erfordert allerdings eine halbe Stunde Konzentration, ggf in 2 oder mehr Portionen)

Boolesche Algebra (Einführung) | Informatik Lernvideo

https://www.youtube.com/watch?v=pppTemykV5I

Kommentar von dkilli ,

Da lamiam eine bessere und eine kürze Formel für Tic-Tac-Toe gefunden hat als ich, so muss ich neidvoll zugeben, dass er die Auszeichnung verdient hat, dass seine Antwort als "Hilfreichste Antwort" ausgezeichnet wird! 

Ich hoffe, dass der, die Fragesteller(in) dies zu würdigen weiß. 

Leider ist es immer so, dass Leute die sich sehr viel Mühe geben eine Antwort zu geben am wenigsten belohnt werden.

Die Hoffnung stirbt als letztes. 

Antwort
von daCypher, 62

=WENN(UND(A1="X";A2="X";A3="X");"Gewonnen";"")

Kommentar von blir14 ,

Vielen dank. habe ich noch die Möglichkeit mehrer Möglichkeiten zu erstellen in einer Zelle? so was wie:
=WENN(UND(A1="X";A2="X";A3="X")oder(und(A1="X";b2="X";c3="X");"Gewonnen";"")

Kommentar von daCypher ,

Ja. Das "Oder" ist auch eine Funktion, wie das "Und". Also:

=WENN(ODER(
UND(A1="X";A2="X";A3="X");
UND(B1="X";B2="X";B3="X");
UND(C1="X";C2="X";C3="X");
UND(A1="X";B1="X";C1="X");
UND(A2="X";B2="X";C2="X");
UND(A2="X";B2="X";C2="X");
UND(A1="X";B2="X";C3="X");
UND(A3="X";B2="X";C1="X"));"Gewonnen";"")

Kommentar von daCypher ,

Oder mit "Verloren"-Auswertung:

=WENN(ODER(
UND(A1="X";A2="X";A3="X");
UND(B1="X";B2="X";B3="X");
UND(C1="X";C2="X";C3="X");
UND(A1="X";B1="X";C1="X");
UND(A2="X";B2="X";C2="X");
UND(A3="X";B3="X";C3="X");
UND(A1="X";B2="X";C3="X");
UND(A3="X";B2="X";C1="X"));"Gewonnen";WENN(ODER(
UND(A1="O";A2="O";A3="O");
UND(B1="O";B2="O";B3="O");
UND(C1="O";C2="O";C3="O");
UND(A1="O";B1="O";C1="O");
UND(A2="O";B2="O";C2="O");
UND(A3="O";B3="O";C3="O");
UND(A1="O";B2="O";C3="O");
UND(A3="O";B2="O";C1="O"));"Verloren";""))

(Kann sein, dass irgendwo eine Klammer auf oder zu zu viel oder zu wenig drin ist. Hab die Funktion nicht getestet)

Kommentar von blir14 ,

=WENN(ODER(UND(A1="X";A2="X";A3="X");UND(A1="X";B2="X";C3="X"));"Gewonnen";"")

habe es for 3 min selber hin bekommen vielen dank für die hilfe 

Kommentar von daCypher ,

Bitteschön :)

Antwort
von dkilli, 57

Die Spielregeln von Tic-Tac-Toe (auch 3 gewinnt genanntlauten: Wenn in einer Spalte, Zeile oder diagonal 3 x sind, so hat man gewonnen. 

Das ergibt insgesamt 8 Möglichkeiten zu gewinnen. Die müssen alle ausgewertet werden!

Das geht mit einer verschachtelte Wenn-Formel  nicht, da nur 7 Verschachtelungen zulässt. Außer mit Tricks. 

Daher meine Lösung, die alle Möglichkeiten zu gewinnen berücksichtigt:

=WENN(UND(A1="x";B1="x";C1="x")+UND(A2="x";B2="x";C2="x")+UND(A3="x";B3="x";C3="x")+UND(A1="x";A2="x";A3="x")+UND(B1="x";B2="x";B3="x")+UND(C1="x";C2="x";C3="x")+UND(A1="x";B2="x";C3="x")+UND(A3="x";B2="x";C1="x")=1;"Gewonnen";"")
Kommentar von Iamiam ,

"Das geht mit einer verschachtelte Wenn-Formel  nicht, da nur 7 Verschachtelungen zulässt"
die Zahl der Klammerebenen ist -ich glaube schon seit der letzten 2003-Version- gewaltig erweitert worden (32 oder mehr?)

Kommentar von Iamiam ,

ich habs mal mit 14 Klammerebenen in einem einfachen Modell getestet, kein Problem, trotzdem würde das recht unübersichtlich, die addierte Und-Verkettung ist in jedem Fall übersichtlicher!

Antwort
von EGitarre, 36

=Wenn(Und(A1=X;A2=X;A3=X);gewonnen;verloren)

Kommentar von blir14 ,

Vielen dank. habe ich noch die Möglichkeit mehrer Möglichkeiten zu erstellen in einer Zelle? so was wie:
=WENN(UND(A1="X";A2="X";A3="X")oder(und(A1="X";b2="X";c3="X");"Gewonnen";"")

Antwort
von blir14, 51

Vielen dank. habe ich noch die Möglichkeit mehrer Möglichkeiten zu erstellen in einer Zelle? so was wie:
=WENN(UND(A1="X";A2="X";A3="X")oder(und(A1="X";b2="X";c3="X");"Gewonnen";"")

Keine passende Antwort gefunden?

Fragen Sie die Community