Frage von Pressl, 58

Text in Excel abzählen?

Ich habe eine Excel Tabelle mit Namen die öfters vorkommen und nun möchte ich den Namen ermitteln welcher am häufigsten vorkommt? Kann mir jemand eine Formel sagen?

Danke im Voraus

Expertenantwort
von Iamiam, Community-Experte für Excel, 23

wie auch die anderen sagen, erst mal in eine Hilfsspalte die Formel

=ZÄHLENWENN(A$1:A$999;A$1:A$999)

dann in einer Zelle woanders (nicht in Namens- und nicht in Hilfsspalte!) diese:

=INDEX(A$1:A$999;VERGLEICH(MAX(B$1:B$999);B$1:B$999;0))

das liefert Dir den Namen Peter, wenn Peter der häufigste Name ist.

Die Formel versagt, wenn es zwei häufiigste Namen gibt, dann wird nur der oberste wiedergegeben.

Das per Formel zu korrigieren, wäre sehr aufwändig (ginge aber), Du kannst das aber folgendermassen testen: Füge in das erste Auftreten des häufigsten Namens noch ein Zeichen ein (zB einen Underbar).

Bei zwei Häufigsten  sowie dann, wenn der Zweithäufigste sich nur um einen Zähler unterscheidet, aber über der zweiten Nennung des Häufigsten steht, erscheint dann der andere, gleich-häufigste Name (Puh-so umständlich muss man formulieren, wenn man genau bleiben will!).

Genaueres musst du dann eruieren.

Antwort
von Rubezahl2000, 22

Entweder mit Pivottabelle (s. andere Antwort)

oder in einer Hilfsspalte für jeden Namen mit der Formel "Zählenwenn(...)" zählen wie oft der Name vorkommt.
Um den häufigsten Namen zu finden, entweder nach der Hilfsspalte sortieren oder mit der Max-Formel die größte Anzahl finden.

Expertenantwort
von Ninombre, Community-Experte für Excel, 27

Ich würde es mit einer Pivottabelle machen, das geht am schnellsten

Dafür muss die Spalte mit den Namen eine Überschrift haben,
Ribbon Einfügen (ganz links): PivotTabelle

Die Einträge samt Überschrift markieren. Dann geht ein neues Fenster auf, wie im Screenshot. Die Namen (also die Überschrift) in Zeilen und als Anzahl in Werte. Wenn dort nicht Anzahl steht, sondern Summe o.ä.: Auf den kleinen Pfeil und "Wertfeldeinstellungen" -> dort ändern.

Im Ergebnis, also der angezeigten Pivot kannst Du mit dem üblichen Autofilter/Sortieren auch die Reihenfolge ändern.

Alternativ zur Pivot: =zählenwenn(A:A;A1) und runterkopieren -> Annahme: Die Namen stehen in Spalte A. Die Namen samt ermittelter Anzahl kannst Du kopieren, als Werte einfügen und über Daten > Duplikate entfernen eine Liste erzeugen, in der jeder Name nur einmal enthalten ist.

Antwort
von Zuse07, 6

Ich hab da mal ein Beispiel gemacht, in dem ziemlich alle Trick vorkommen, die man in dieser Situation gebrauchen kann. https://drive.google.com/file/d/0B5Hy9UM68sNQeGN1RTBLa3pWNms/view?usp=sharing

Antwort
von safur, 26

Du könntest mal =Modalwert versuchen.

So wie hier in etwa..
http://www.excelformeln.de/formeln.html?welcher=66

Antwort
von Pressl, 23

dort steht das es nur mit zahlen funktioniert.

Keine passende Antwort gefunden?

Fragen Sie die Community