Frage von GooglePlayer, 100

Kann Excel Adressen automatisch erkennen und in die dafür vorgesehenen Spalten einfügen?

Hey,

ich habe Excel Tabelle mit Adressenlisten von Firmen erstellt(Firmenname, Adresse, Ort, Tel usw.) Diese kopiere ich von Gelbeseiten. Nun meine Frage: Wenn ich jetzt von dort einen Namen, Adresse und Ort kopiere und dann bei Excel einfüge, kann man das so einstellen, dass er dann automatisch erkennt was was ist und es automatisch sortiert? Klar wäre es nicht schwer alles einzeln zu kopieren und einzufügen, aber bei mehr als 500 Firmen wird das auf Dauer langweilig und anstrengend.

lg googleplayer

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 55

Das sollte machbar sein, solange eine Regelmäßigkeit vorliegt. D. h. dass alle Adresse eine vorgegebene Anzahl an Zeilen umfassen.

Ist dem nicht so, muss über ein Makro entschieden werden, welche Adresszeile welchem Feld in Excel zugeordnet wird.

Wird die Adresse beim Kopieren in nur eine Zelle eingefügt, kannst du sie evtl. mit "Text in Spalten" splitten.

Wird sie auf mehrere Excelzeilen verteilt, kannst du die Zeilen über das angesprochene Makro auf die anderen Spalten münzen.

Kommentar von GooglePlayer ,

Auf gelbeseiten.de wird das immer so angezeigt
Name
Adresse
Ort

und so kopiere ich das auch. Kann man das dann so einstellen das die erste Zeile der Zwischenablage der Name, die zweite die ? 

Und wie kann ich das denn dann einstellen?

Kommentar von Suboptimierer ,

Per Formel transponieren könntest du so:

B1: =WENN(REST(ZEILE();3)=1;A2;"")
C1: =WENN(REST(ZEILE();3)=1;A3;"")

B1:C1 herunterziehen.
In A1:An stehen die Adressen direkt untereinander.

Die überflüssigen Zeilen mit Adressen und Ort löscht du dann über einen Autofilter auf Spalte B oder C mit ungleich leer.

Kommentar von GooglePlayer ,

Sry keine Ahnung warum mein Kommentar so angezeigt wird. Hier nochmal:

Auf gelbeseiten.de wird das immer so angezeigt
Name
Adresse
Ort

und so kopiere ich das auch. Kann man das dann so einstellen das die erste Zeile der Zwischenablage der Name, die zweite die Adresse und der dritte der Ort ist und das so automatisch erkannt wird? 

Und wie kann ich das denn dann einstellen?

Kommentar von Suboptimierer ,

Hast du meinen Weg schon versucht, zu beschreiten? Bei mir klappt es.

Kommentar von GooglePlayer ,

Wie soll ich die Formel dann benutzten? bzw. wo eingeben? Kenne mich nicht sehr gut mit Formeln in Excel aus.

Kommentar von Suboptimierer ,

Rechts neben der Spalte A, in der du die Werte einfügst, gibst du die Formeln ein, ziehst sie herunter und löschst mittels Filter die überflüssigen Formeln. Zuletzt kannst du noch das Format mittels Formatpinsel normalisieren.

Kommentar von GooglePlayer ,

Okay das kommt mir jetzt etwas kompliziert vor, wie könnte man es denn mit einem Makro machen? Hab mir schon etwas angeschaut und bin bei dem Punkt, ein Makro aufzeichnen. 

Hab schon sowas:

Sub Makro1()
'
' Makro1 Makro
'
' Tastenkombination: Strg+k
'
Range("A2").Select
ActiveCell.FormulaR1C1 = "Musterfirma"
Range("C2").Select
ActiveCell.FormulaR1C1 = "Musterstr. 20"
Range("B2").Select
ActiveCell.FormulaR1C1 = "60XXX Musterstadt"
Range("D2").Select
ActiveCell.FormulaR1C1 = "(06X) XX XX XX"
Range("D3").Select

End Sub

Wie mache ich jetzt daraus das was ich gemeint hatte?

Nebenbei vielen Dank für deine Hilfe.

Kommentar von Ninombre ,

Ich weiß nicht, ob das Makro Dich glücklicher macht. Ich würde es dann zum Schluss über die Liste in Spalte A laufen lassen

Sub trennen()
i = 1 'Zeile in der die unsortierten Einträge beginnen
j = 1 'Zeile ab der die neuen erstellt werden
While Cells(i, 1).Value <> ""
Cells(j, 2).Value = Cells(i, 1).Value
Cells(j, 3).Value = Cells(i + 1, 1).Value
Cells(j, 4).Value = Cells(i + 2, 1).Value
Cells(j, 5).Value = Cells(i + 3, 1).Value
i = i + 4
j = j + 1
Wend
End Sub

Kommentar von GooglePlayer ,

Was hat der Makro denn für eine Funktion? Also was macht der?

Kommentar von Iamiam ,

@Subopt: Da hast Du Dir eine Riesenmühe gemacht, aber anscheinend ein Fass ohne Boden aufgetan...

Viele Leute meinen, einmal kurz drübergeblasen und das Bild ist fertig und vllt sogar kunstvoll. Dass ein Lehrling erst mal zB lernen muss, wie man eine Feile hält oder wie man sich zum Hobeln hinstellt, haben sie nie erfahren!

Kommentar von Suboptimierer ,

Anfängern (egal ob für Excel, VBA oder sonstwas) empfehle ich grundsätzlich:

  • Präzise Formulierung des Ist- / Sollzustands
  • Kenn dein Werkzeug
  • Entwickle idealerweise ein Konzept
  • Teile und herrsche!

Schon an den Fehlermeldungen kann man erkennen, ob jemand schon einmal Projekte bewältigt hat.

  • Das funktioniert nicht.
  • Ich vermute den Fehler nahe bei...
  • Nichts passiert.
  • Die Fehlermeldung lautet: "Fehler beim Konvertieren des Datentyps bla nach blub" in Zeile xy. Ich habe schon folgendes probiert, was aber zu diesen Fehlern führte... Anbei noch ein Screenshot.
    In der Codezeile yz steht noch der richtige Wert in myVar
    Mit Google oder in einschlägigen Office-Foren konnte ich dazu nichts Passendes zum Thema ABC finden.
    Der Fehler ist reproduzierbar, auch mit anderen Eingangsparametern.
    Das Programm läuft auf Win7, Office 2010 V...

Keine passende Antwort gefunden?

Fragen Sie die Community