Frage von LolaFelix, 140

Excel Formel: Wenn Zahlen zwischen 1-5 dann *1,5?

Hallo, ich versuche mich grad an einem Zeiterfassungsformular und komm bei den Überstunden nicht wieter: Ich will alle Überstunden zwischen 1 und 4,75 * 1 rechnen und in einer extra Zelle alle Überstunden ab 5 *1,5 rechnen.

Ich denke, dass man hier eine "Wenn - Dann" Formel braucht, aber ich schaffe es nicht die Multiplikation einzubauen.

Hat iwer die Lösung? Vmtl ist es ganz einfach... Google hat mir leider auch nicht weitergeholfen.

Danke :)

LG Laura

Expertenantwort
von Iamiam, Community-Experte für Excel, 61

Rechnest Du die Überstunden mit einfachen Zahlen (Industriestunden, also 8Std/Werktag als Basis), oder in Zeitstunden (Darstellung als 8:00 oder 8:00:00 etc) ?

ggf brauchst Du noch den Umrechnungsfaktor: 1 Std = 1/24 Tag (weil in den Tabellenkalkulationen der Tag die Einheit =1 ist)

Lösche mal das Format (indem Du das einer unformatierten Zelle draufkopierst und s chau nach, ob sich die Zahl ändert! Anschließend wieder rückgängig machen)

Antwort
von azmd108, 88

In Spalte A stehen die Zahlen zwischen 1 und X

Spalte B

=Wenn(A1<=4,75;A1;A1*1,5)

Voraussetzung: Die Zahlen können nicht kleiner als 1 sein. Wenn sie das sein können, schreibs in die Kommentare.

Die Formel oben prüft A1, ob der Wert kleiner oder gleich 4,75 ist. Wenn ja, schreibt er den Wert in die Zelle, wenn nicht (also größer als 4,75), multipliziert er den Wert mit 1,5 und schreibt ihn dann in die Zelle. Wenn du den Part mit 1,5 multipliziert in einer extra Zelle, z.B. daneben, haben willst. dann so

in B: =Wenn(A1<=4,75;A1;"")

in C =Wenn(A1>4,75;A1*1,5;"")


das "" bedeutet einfach nur "schreibe nichts in die Zelle"

Kommentar von LolaFelix ,

Danke!

Aber das stimmt nicht ganz.

Weil: die Stunden bis 4,75 müssen immer *1 gerechnet werden und erst ab der 5. Stunde werden sie *1,5 gerechnet. Verstehst du was ich meine? :)

Hast du vielleicht eine andere Lösung?

LG

Kommentar von azmd108 ,

Ja, ich weiß was du meinst. Wenn man allerdings etwas mit 1 multipliziert, ergibt es doch denselben Wert. darum habe ich die 1 einfach weggelassen. Aber ok, hier die Lösung mit *1


=Wenn(A1<=4,75;A1*1;A1*1,5)


bzw.


=Wenn(A1<=4,75;A1*1;"")


PS: Sollte der Wert in der Zelle übrigens keine Zahl sein, also in der Zelle nicht automatisch rechtsbündig stehen, dann setz die 4,75 bitte jeweils in Anführungsstriche, also "4,75"...

Kommentar von Jackie251 ,

Deine Rechnung paast doch schlicht nicht zur Aufgabe!
Wenn es zum Beispiel 6 Überstunden sind, dann werden die ersten 4,75 h mit 1,0 gerechnet und alles darüberhinausgehende mit 1,5
also sagt die Mathematik 4,75+(6-4,75)*1,5

Bei dir werden egal wieviele Überstunden es sind immer ALLLE Überstunden mit dem gleichen Faktor multipliziert.

Kommentar von azmd108 ,

Ach jetzt verstehe ich die Aufgabe erstmal. Ich habe die Aufgabe anders verstanden. Wenn die Aufgabe so lautet, wie Jackie251 sagt, dann ist das hier eine Möglichkeit:

=WENN(A1<=4,75;A1*1,5;WENN(A1>4,75;4,75*1+(A1-4,75)*1,5))

Kommentar von Jackie251 ,

den anfang noch auf
=WENN(A1<=4,75;A1*1,0;
korrigieren und es passt auch mit der Wennformel.

wobei gesagt sei, das man für 2 Fallunterscheidungen keine 2 Wennformel braucht. Es reicht ja DANN und SONST.

Kommentar von LolaFelix ,

Ich komme leider trotzdem nicht auf das richtige..

Antwort
von Jackie251, 70

wenn in A1 die Überstunden stehen, geht das hiermit

=MIN(4,75;A1)+MAX(A1-4,75;0)*1,5
Kommentar von Jackie251 ,

Ach du willst es in 2 getrennte Ergebniszellen, dann trennst du einfach beide Werte:

Überstunden bis 4,75 =

=MIN(4,75;A1)

Überstunden über 4,75 =

=MAX(A1-4,75;0)*1,5
Kommentar von LolaFelix ,

Hey, danke!

Hier hab ich as Problem: dass es mir nicht differenziert. Also es schreibt bei 7 Überstunden trotzdem in die erste Zelle 7.

Ich hätte gerne dass sich das von selbst aus der Summe der Überstunden ausfsplittet.

BSP: 7 Überstunden

4*1 und 3*1,5

Danke

LG

Laura

Kommentar von Jackie251 ,

Wie soll es bei 7 Überstunden auf das Ergebnis 7 kommen?

Die Formel lautet
=Min(4,75;ÜBERSTUNDEN) = Min (4,75;7) und da 7 nunmal größer als 4,75 ist, kommt auch 4,75 heraus, ansonsten ist etwas falsch eingegeben :-D

Weiterhin passt deine Angestrebte Lösung nicht zur Frage.
Gemäß Fragestellung sollen 7 Überstunden zu
4,75 einfache Überstunden und
2,25*1,5 Bonusüberstunden werden.

hier im Beispiel hast du es aber mit 4 zu 3*1,5 aufgeteilt.

Kommentar von LolaFelix ,

Hey,

vermutlich stlel ich mich einfach gerade wirklich viel zu dumm an.

Aber: die Berechnung wird bei mir einfach nicht unterteilt!

Also es funktioniert nicht, dass die ersten 4,75*1 gerechnet werden und erst ab 5*1,5.

Kommentar von Jackie251 ,

Dann müsstest du uns mal genauer deine Tabelle zeigen.
Dort wo die Überstunden bis 4,75 muss die Formel

=MIN(4,75;A1)

und dort wo die Üebrstunden ab 5h verrechnet werden sollen muss stehen

=MAX(A1-4,75;0)*1,5

jeweils ausgehend davon das der Basiswert der Überstunden in A1 steht.
Genauere Adressierung können wir erst angeben, wenn wir den Aufbau der Tabelle kennen.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten