Frage von Maxi5001, 108

Excel Feiertage automatisch markieren?

Hallo

ich habe eine Tabelle die mehrere Monate als Reiter hat, dazu einen Reiter Zeiten. Im Reiter Zeiten sind alle Feiertage aufgelistet (A1=Neujahr; A2=1.1.2016) Im Reiter Januar steht in Zelle B4 1.1.2016 und in Zelle C4 =B4+1 so geht das weiter bis alle 31 Tage durch sind.

Ich habe nun 2 Wege um das zu realisieren, aber bei gehen nicht.

http://www.office-loesung.de/ftopic83347_0_0_asc.php Der Beitrag von Peter ist bei mir umgetzt und die Formel lautet: =SVERWEIS(B4;Zeiten!$B$1:$C$12;FALSCH)="Ja") Bei C1-12 steht immer Ja, weil es Feiertage sind.

Meine andere Lösung ist es bei den Monaten in B3, C3, D3, etc. ein unsichtbares Feld zu nutzen, was diese Formel enthält: =VERGLEICH(B4;Zeiten!$B$1:$B$12) Dazu die bedingte Formel: =ODER(b$3>0) Format: einfärben

Wieso geht das einfach nicht, also bei letzterem macht er bei 1.1. und 2.1. die Spalten rot, was richtig ist, da der Wert höher als 0 ist. Aber ab dem 3.1. dürfte er es nicht mehr anzeigen und #NV schreiben. Das tut er aber nicht....

Hat jemand eine Idee?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 108

Das kann ich so noch nicht nachvollziehen. 

Schreibe nochmal gestaffelt auf:

Januar!A1: <WERT>
Januar!A2: <WERT>
Januar!A3: <WERT>
Januar!B1: <WERT>
Januar!B2: <WERT>
Januar!B3: <WERT>
Januar!C1: <WERT>
Januar!C2: <WERT>
Januar!C3: <WERT>

Dasselbe für den Reiter Zeiten.

Dann schreibe darunter, welche Formel du bislang verwendest, um welches Ergebnis zu erzielen und welcher Fehler dabei auftritt, bzw. was du gerne anders hättest.

Screenshots könnten auch helfen. Achte darauf, dass man die Werte darauf lesen kann.

Kommentar von Maxi5001 ,

Ich hab einen Screenshot mal hochgeladen: http://i.imgur.com/POo4Otm.jpg

Die verschiedenen Reiter spielen erstmal keine Rolle, da ich nun die Feiertage direkt in den Januar kopiert habe, dennoch funktioniert es nicht >.< Auch das Einfärben ist aktuell irrelevant, da es nur eine einfache Abfrage ist, ob der Wert grösser als 0 ist oder nicht.

Es geht nun nur um die Zeile 4, 45 und die Spalte AK.

In Zeile 4 stehen die Daten.

B4: 1.1.2016

C4: =B4+1

D4: =C4+1

etc...

In B45: =VERGLEICH(B4;$AK$4:$AK$16)

In C45: =VERGLEICH(C4;$AK$4:$AK$16)

etc...

In AK4: 01.01.2016

In AK5: 02.01.2016

etc.... nur das die Daten als TT MM angezeigt werden

Kommentar von Suboptimierer ,

Du solltest als letzten Parameter der VERGLEICHsfunktion 0 mitgeben und für den Fall, dass nichts gefunden wurde den #NV-Fehler mit WENNFEHLER abfangen.

Kommentar von Maxi5001 ,

Du bist mein Hero!

=VERGLEICH(B4;$AK$4:$AK$16;0)

Die ;0 am Ende hat den Unterschied gebracht x.x Ob da #NV steht ist mir ziemlich Hupe, da der Text ausgeblendet wird, alles wird versteckt, das soll ja niemand sehen. Es sollen im Endeffekt nur alle Feiertage automatisch wie Sonntage eingefärbt werden. Und das tut es nun!

Herzlichen Dank und sobald es geht bekommst du noch einen Stern von mir.

Kommentar von Suboptimierer ,

Bitteschön!

Antwort
von iMPerFekTioN, 87

Hallo =)
Deine Vergleichs-Funktion benötigt den letzten Parameter 0 in der Formel =)

Ohne diesen Parameter gehts nicht:p

Grüße,

iMPerFekTioN

Keine passende Antwort gefunden?

Fragen Sie die Community