Frage von Pazhec, 56

s-verweis formel funktioniert erst nach doppelklick?

Halloo. Ich bearbeite zurzeit eine Excel-Tabelle die den Bezug von diversen Artikeln festhält. Ich arbeite mit der SVerweis formel. D.h. falls ich den ARtikel eingebe, soll sofort der Preis erscheinen. Das Problem dabei ist, dass statt der preis "nv#" kommt und ich in die Zelle doppelklicken und enter drücken muss, bevor der richtige Preis kommt. (siehe foto)

Gibt es eine Lösung dafür? kann ich nicht den artikel eingeben ohne dass nv kommt?

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 47

Ich denke wie TimmiEberhardt, dass wahrscheinlich ein Formatierungsproblem vorliegt. Wenn du keine englische Version verwendest, solltest du das Komma als Dezimalseparator verwenden.

Excel scheint die Wertinterpretation erst nach manueller Bestätigung der Eingabe zu vollführen.

Kommentar von Suboptimierer ,

Überprüf mal, ob die Berechnungsoption auf "Automatisch" steht.

Formeln → Berechnung → Berechnungsoptionen

Antwort
von Funfroc, 40

Hallo,

ich gehe auch auf die schon angesprochene Formatierungsproblematik ein.

Ist eine der beiden verwendeten Tabellen per Export aus einem MS-fremden Datenbanksystem gezogen?

Oftmals steht dann zwar da, die Inhalte wären als "Standard" formatiert, sind es aber effektiv nicht. Mit der aus Fremdsystem gezogenen Liste mal über die komplette Tabelle die Aktion durchführen:

Daten --> Text in Spalten --> Fertig stellen.

LG, Chris

Antwort
von TimmiEberhadt, 50

Das #NV bedeutet eigentlich dass der Wert nicht gefunden wird. Hast du mal probiert alle Formatierungen aus den Zellen zu entfernen und dann erneut einen SVerweis gemacht? Welchen Wert hast du als 4. Stelle in der Formel? 0 oder 1? Vielleicht hast du nicht den genauen Wert, sondern den ungefähren. 

Kommentar von Pazhec ,

es ist falsch angegeben, da ich mich auf eine genaue Preisliste beziehe

Expertenantwort
von schmiddi1967, Community-Experte für Excel, 42

Naja ohne den Aufbau deiner Artikeltabelle und den sverweis zu kennen ist eine Lösung schwer.

Was mich wundert, ist das nach dem doppelklicken und enter dann der Preis kommt.

Also wie ist deine Tabelle aufgebaut und wie sieht dein sverweis aus?

Kommentar von Pazhec ,

Beim Kugelschreiber (siehe Bild) ist folgende Formel beim Preis hinterlegt

 

=SVERWEIS(C157;Listen!$B$2:$C$19;2;FALSCH)

Kommentar von schmiddi1967 ,

ok, wenn das bei allen Artikeln so ist versuche mal das was Supobtimierer in seiner Antwort geschrieben hat. Sollte das nicht der Fehler sein melde dich nochmal.

Kommentar von schmiddi1967 ,

Na wie schaut`s aus? Eine Reaktion wäre nicht schlecht :(

Antwort
von augsburgchris, 21

Register "Formeln" --> Berechnung --> Berechnungsoptionen --> Haken bei Automatisch?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten