Excel: bei Monat das Datum vervollständigen?

... komplette Frage anzeigen

4 Antworten

Formel für die erste Zelle: "=die Zelle, in der der Monat eingegeben wurde"

nur anders formatiert

Nächste Zelle: =Zelle davor +1

und so weiter

Bei Monaten mit weniger als 31 Tagen hat man dann aber in den untersten Zeilen schon Daten des Folgemonats.

Antwort bewerten Vielen Dank für Deine Bewertung


Wenn bspw. in G1 steht "Mrz 2016" und in Spalte A das Datum hochgezählt werden soll:

A1: =G1
A2 = A1+1

und die letzte Formel entsprechend in die anderen Zellen in Spalte A kopieren. Das Zellenformat unter benutzerdefiniert auf "TT, TTT" stellen


Am Rande: Als Thema reicht hier Excel aus, die Frage hat nichts mit Hardware oder anderen Officeprodukten zu tun.

Antwort bewerten Vielen Dank für Deine Bewertung

Ich kann nicht genau erkennen, wie du Monatsnamen und Jahreszahl eingibst. Deshalb nehme ich für das folgende mal an, Monatsname und Jahr stehen beide in Zelle F2. (Für Monat und Jahr in verschiedenen Zellen bzw. in Auswahllisten muss die Formel natürlich angepasst werden.)

Weiter nehme ich an, dass der 1. des Monats in A7 steht.

Formel in A7:

=DATWERT("1. " & $F$2)

Formel in A8 bis A37 (hier für A8 angegeben:)

=WENN(A7="";"";WENN(MONAT(A7+1)<>MONAT(A7);"";A7+1))

Zellenformat für A7 bis A37:

TTT, T.

Antwort bewerten Vielen Dank für Deine Bewertung

und woher soll xl "wissen", dass es des Datum 1. des Monats draus machen soll? Nur, weil Du Dir das gerade einbildest? Warum nicht 31.März 1900 23:59:59 ?

Der Shortcut Strg + . (Punkt) gibt das heutige Datum wieder und formatiert die Zelle auf Datum. (mit anschließend Leerzeichen und Strg + : die JetztZeit dazu, ebenfalls entsprechendes Format, sofern nicht vorher anders formatiert)

in so eine formatierte Zelle (zB.A1) kannst Du zB 1.3.00 schreiben, soviel Aufwand braucht es schon! Oder Du schreibst =heute() (ggf jetzt())

Dann in die Zelle drunter, also A2: =a1+1

A2 wird dadurch ebenfalls auf Datum formatiert und das kannst Du dann runterziehen, um eine Liste zu erstellen.

Hilft dir das weiter?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
08.05.2016, 00:36

hab grad Dein Bild noch registriert:

in die oberste Datumszelle die Formel: =F2*1 (F2? sei die Zelle, in der März 2016 steht). Diese Zelle (A5?) Ben-def (Strg+1, Zahlen, Ben-def) so formatieren: TTT, TT

die darunter genauso formatieren (Format übertragen) und mit der Formel fortführen wie oben: =A5+1

0

Was möchtest Du wissen?