AutoIT While schleifen Problem
#Include <file.au3>
#include <misc.au3>
#include <IE.au3>
#include <ButtonConstants.au3>
#include <EditConstants.au3>
#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>
#Region ### START Koda GUI section ### Form=
$Fenster = GUICreate("Fenster", 178, 200, 629, 361)
GUISetBkColor(0xC0C0C0)
$Button1 = GUICtrlCreateButton("Google", 32, 8, 121, 25)
$Button2 = GUICtrlCreateButton("Youtube", 32, 48, 121, 25)
$Button3 = GUICtrlCreateButton("Facebook", 32, 88, 121, 25)
$Button4 = GUICtrlCreateButton("Öffnen", 32, 128, 121, 25)
$Input1 = GUICtrlCreateInput("<a href="https://">https://</a>", 32, 160, 121, 21)
GUISetState(@SW_SHOW)
$input = GUICtrlRead($Input1)
#EndRegion ### END Koda GUI section ###
While 1
    $nMsg = GUIGetMsg()
    Switch $nMsg
        Case $GUI_EVENT_CLOSE
            Exit
        Case $Button1
            ShellExecute("<a href="http://www.google.de">http://www.google.de</a>")
        Case $Button2
            ShellExecute("<a href="https://Youtube.com">https://Youtube.com</a>")
        Case $Button3
            ShellExecute("<a href="https://Facebook.com">https://Facebook.com</a>")
        Case $Button4
            ShellExecute(GUICtrlRead($Input1))
    EndSwitch
WEnd

Hallo, ich habe es bereits mit funktionen versucht, jedoch wird dies einfach nicht ausgeführt (gibt keine fehlermeldung, es passiert eifnach nichts.) Bin total neu auf dem Gebiet. Ist die erste While schleife, bei der zweiten passiert jedoch nichts mehr. Es soll gespeichert werden welche buchstaben eingegeben werden in die Inbox und unter einer log datei gespeichert werden. Ich habe bisher alles auser eine weiter While schleife geschafft zum laufen zu bringen. Nehme ich das obere komplett raus funktioniert das andere. Nun funktioniert nur der obere Script. Bitte um Hilfe.

Internet, Programm, Programmieren, Programmierung, Informatik
3 Antworten
Weitere Inhalte können nur Nutzer sehen, die bei uns eingeloggt sind.