Frage von IngoKlotz, 53

Wie kann ich in Excel einen Eingabe- und Ausgabebereich einfügen?

Hallo, ich soll in Excel einen Eingabe- und Ausgabebereich einrichten.

In der Zelle B3 soll ich eine beliebige Zahl eintragen können, und in der Spalte A sollen sich ebenfalls die Zahlen verändern. Durch diese Veränderung soll sich in Spalte Bauch der EUR - Betrag verändern.

Wie soll ich das machen? Und wie formatiert man die "8 Jahre", dass diese als Zahl anerkannt wird?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Antitroll1234, 53

In Zelle A8:

=WENN($B$3>A7;A7+1;"")

Diese kopierst Du dir in Spalte A soweit runter wie benötigt.

Für die Zelle B3 um die Zahl und Jahre anzuzeigen.

Rechtsklick auf die Zelle --> Zelle formatieren --> Zahlen --> Benutzerdefiniert --> Bei Typ gibst Du manuell ein:

0 "Jahre"

Kommentar von Antitroll1234 ,

Ups, Spalte B vergessen ;-)

Dort in B7=

=WENN(A7="";"";A7*$B$2)

und diese Formel in Spalte B soweit runter kopieren wie benötigt.

Kommentar von IngoKlotz ,

Bombe!!! Danke!!!

Kommentar von Antitroll1234 ,

Gerne ;-)

Expertenantwort
von Ninombre, Community-Experte für Excel, 48

Für die Spalte A: =WENNFEHLER(WENN(A7+1<=B$3;A7+1;"");"")
Für die Spalte B: =WENNFEHLER(WENN(A7+1<=B$3;B7+B$2;"");"")

jeweils ab Zeile 8 bis zur maximal zulässigen Spardauer. Die Wenn-Formel prüft, ob ein weiteres Jahr angezeigt werden muss oder bereits die Spardauer erreicht ist. Gleiches für den Sparbetrag. Die zusätzliche Abfrage mit Wennfehler fängt unschöne Einträge ab.

Mit den Jahren geht über Zellen formatieren -> benutzerdefiniert. Dort bei Typ einfach # "Jahre" eintragen.


Edit: Als Erläuterung noch: Die $ Zeichen dienen dazu, dass der Zellbezug unverändert bleibt, wenn man die Formel nach unten zieht/kopiert. Es soll ja immer fest auf B3, also Spardauer abgefragt werden.

Kommentar von Ninombre ,

Nimm die Formel von Antitroll, ich habe mir bei der Variante das Leben unnötig kompliziert gemacht. Wenn man das < > andersherum einsetzt, entfällt das Problem mit ungültigen Werten.

Kommentar von IngoKlotz ,

Und wie stelle ich das ein wenn ich die Jahreszahl in B3 verändere, dass die Spalte B dann jeweils mit Spalte A und 30,00 € multipliziert wird?

Kommentar von Antitroll1234 ,

...habe meine Antwort durch ein Kommentar erweitert, sollte dir helfen ;-)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten