Wie kann ich in Excel einen Eingabe- und Ausgabebereich einfügen?

... komplette Frage anzeigen

2 Antworten

In Zelle A8:

=WENN($B$3>A7;A7+1;"")

Diese kopierst Du dir in Spalte A soweit runter wie benötigt.

Für die Zelle B3 um die Zahl und Jahre anzuzeigen.

Rechtsklick auf die Zelle --> Zelle formatieren --> Zahlen --> Benutzerdefiniert --> Bei Typ gibst Du manuell ein:

0 "Jahre"

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Antitroll1234
20.11.2015, 15:04

Ups, Spalte B vergessen ;-)

Dort in B7=

=WENN(A7="";"";A7*$B$2)

und diese Formel in Spalte B soweit runter kopieren wie benötigt.

0

Für die Spalte A: =WENNFEHLER(WENN(A7+1<=B$3;A7+1;"");"")
Für die Spalte B: =WENNFEHLER(WENN(A7+1<=B$3;B7+B$2;"");"")

jeweils ab Zeile 8 bis zur maximal zulässigen Spardauer. Die Wenn-Formel prüft, ob ein weiteres Jahr angezeigt werden muss oder bereits die Spardauer erreicht ist. Gleiches für den Sparbetrag. Die zusätzliche Abfrage mit Wennfehler fängt unschöne Einträge ab.

Mit den Jahren geht über Zellen formatieren -> benutzerdefiniert. Dort bei Typ einfach # "Jahre" eintragen.


Edit: Als Erläuterung noch: Die $ Zeichen dienen dazu, dass der Zellbezug unverändert bleibt, wenn man die Formel nach unten zieht/kopiert. Es soll ja immer fest auf B3, also Spardauer abgefragt werden.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
20.11.2015, 14:57

Nimm die Formel von Antitroll, ich habe mir bei der Variante das Leben unnötig kompliziert gemacht. Wenn man das < > andersherum einsetzt, entfällt das Problem mit ungültigen Werten.

0
Kommentar von IngoKlotz
20.11.2015, 15:07

Und wie stelle ich das ein wenn ich die Jahreszahl in B3 verändere, dass die Spalte B dann jeweils mit Spalte A und 30,00 € multipliziert wird?

0

Was möchtest Du wissen?