Frage von kaubakka, 74

Summe in Excel über jeweils mehrere Zellen kontinuierlich fortsetzen?

Ich habe eine sehr lange Excel Liste mit mitnütlichen Werten über ein Jahr. Diese würde ich gerne in eine Liste mit 15 minütiger Taktung zusammen fassen. Also es sollen immer blockweise 15 Werte summiert werden. A1-15 in der ersten Zelle A16-A30 in der zweiten und so weiter. Das sollte doch machbar sein oder? Wenn möglch möchte ich auch den Indirekt Befehl vermeiden, da dieser die Tabelle sehr stark bremst.

Wer hat eine Idee?

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 74

Vielleicht ist ein erster, guter Schritt, die Zeiten auf ein Vielfaches von 15 Minuten zu bringen, um danach besser gruppieren und mit der Teilergebnisfunktionalität arbeiten zu können:

=REST(OBERGRENZE(MINUTE(A1);15);60)

oder direkt

=ZEIT(STUNDE(A1)+WENN(MINUTE(A1)>45;1;0);REST(OBERGRENZE(MINUTE(A1);15);60);0)

(du musst wahrscheinlich noch das komplette Datum mit Tag, Monat und Jahr bilden)

Antwort
von Rubezahl2000, 67

Da bietet sich ein Pivottabelle zu der bestehenden Tabelle an.

Füg vorab in deiner Tabelle eine neue Spalte ein, in der immer jeweils DIE 15 Zeilen, die zusammengefasst werden sollen, die selbe Kennzeichnnung erhalten. Also z.B. in Zeile 1-15 eine 1 in der neuen Spalte, Zeile 16-30 eine 2 in der neuen Spalte und so weiter, kannst du ja runterkopieren bis ans Ende der Tabelle.

Dann legst du eine Pivottablle an und summierst darin pro Wert aus der neuen Spalte.
Weißt du, wie das geht mit Pivottabellen?
Pivottabellen sind ein geniales Tool, um bestehende Tabellen auszuwerten, zu komprimieren, umzustrukturieren, einzelne Merkmale auszuwerten, ...

Kommentar von kaubakka ,

Das würde klappen, danke. Allerdings habe ich mich jetzt dafür entschieden es mit der Summe als Array Formel zu versuchen {=SUMME(J2:J16)}. Das klappt auch soweit. Allerdings lässt sich diese mit den üblichen Tastenkombinationen (STRG+U) nicht nach unten kopieren, was mich gerade noch vor die Frage stellt wie ich ohne den Fokus zu verlieren ans Ende der Tabelle komme. bei 500 000 Zeilen ist scrollen unmöglich.

Kommentar von Rubezahl2000 ,

Eine Formel ganz bis nach unten kopieren (wenn die Nachbar-Spalte auch bis ganz nach unten gefüllt ist):
Ein Doppelklick auf die rechte untere Ecke der Zelle

Kommentar von kaubakka ,

Perfekt, genau danach hab ich gesucht!

Antwort
von Britzcontrol, 62

Nur mal zu Verständnis:

minütliche Werte über einJahr ??
also für eine Stunde 60 Werte
ein Tag (60*24) 1.440 Werte
ein Jahr (60*24*365) 525.600 Werte

Daraus alle 15 Minuten ein Wert = 35.040 Werte.

Ist die Frage so gemeint ?

Gruß aus Berlin

Kommentar von kaubakka ,

genau!

Antwort
von ShitzOvran, 45

ich würde eine extra Spalte anlegen, die dir das Ganze über eine Formel automatisch gruppiert. Darauf kannst du dann eine Pivottabelle legen. 

Ich weiß nicht, ob eine Pivot nicht vielleicht auch schon von haus aus irgendwie clustern kann. vielleicht funktioniert das auch ohne Hilfsspalte. 

hier mal ein Beispiel
https://drive.google.com/file/d/0B7RClrQFWfzhNWlfaUo2Z0hDMzg/view?usp=sharing

Expertenantwort
von Oubyi, Community-Experte für Excel, 32

Das sollte so klappen:

="A"&(ZEILE(A1)*15-14&":A"&ZEILE(A1)*15)

und nach unten kopieren soweit wie nötig.
Klappt es?

Kommentar von kaubakka ,

Gewitzt! Ja das  funktioniert mit der Anpassung auf Zeile 2 und unter hinzunahme der Summenformel. Der Vorteil hierbei ist, dass ich keine überflüssigen Zeilen habe wie bei der Array Lösung, danke!

Kommentar von Oubyi ,

Ja, klar, SUMME muss noch dazu.
Da hatte ich aus versehen meine Kontroll-Formel kopiert, statt der Ausgangsformel.
Aber Du hast es ja selber hinbekommen.

Antwort
von Jackie251, 24

Du fängt die gekürzte Tabelle einfach so an:

=SUMME(BEREICH.VERSCHIEBEN(Tabelle1!$A$1:$A$15;15*(ZEILE(A1)-1);0))

wobei sich Tabelle1!$A$1:$A$15 der erste 15 Zeilen Bereich ist. Formel nach unten ausfüllen für weitere 35k zeilen und fertig


Keine passende Antwort gefunden?

Fragen Sie die Community