Formel in Excel nur in jede vierte Spalte übernehmen?

... komplette Frage anzeigen

3 Antworten

meinst du so: das in blatt 1 spalte a1 eintragen =Tabelle2!A1 und für blatt1 spalte e1 das hier: =Tabelle2!B1  und immer so weiter. du kannst auch im blatt 1 die zelle auswählen und mit = beginnen dann einfach in das blatt 2 wechseln zelle auswählen und mit enter bestätigen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Sparfuchs86
20.06.2016, 19:52

Danke erstmal für die schnelle Antwort.
Allerdings will ich das für 92 Zeilen machen und quasi die Formel nach rechts in Arbeitsblatt 1 weiterkopieren können

0

Ich gehe mal davon aus, dass die Quelldaten in Tabelle1!A16:Z16 oder so stehen.
Dann diese Formel in z.B. A1 in Tabelle2:

=WENN(REST(SPALTE()+3;4)=0;INDEX(Tabelle1!16:16;;(SPALTE(Tabelle1!A16)/4)+1);"")

und nach rechst kopieren.

Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Sparfuchs86
20.06.2016, 20:17

Da bekomme ich leider eine Fehlermeldung, wenn ich die Formel einfach nur so in eine Zelle kopiere. Ich versteh aber auch nicht so ganz die Formel. Muss Ich da noch irgendwas ersetzen durch einen konkreten Bezug?

0

Wieso geht indirekt nur für den Umgekehrten Fall?
geht mit dieser Form von Indirekt wunderbar

=INDIREKT("'Arbeitsblatt 1'!Z3S"&(SPALTE()-1)*4+1;0)
Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
20.06.2016, 23:14

Mit INDIREKT ließe sich meine Formel (für Tabelle1!A16:Z16) so ersetzten:

=WENNFEHLER(INDIREKT("'Tabelle1'!Z16S"&(SPALTE()-1)/4+1;0);"")

Ist etwas einfacher zu handhaben und kompakter, weil für die leer zu lassenden Zellen #BEZUG! generiert wird.

Ich zieh INDEX meist vor, weil z.B. beim Ändern des Namens des Tabellenblattes die Formel automatisch angepasst wird, bei INDEX nicht. Dito beim Einfügen von Zellen.
Aber das ist sicherlich marginal.

1

Was möchtest Du wissen?