Frage von Labasan1701, 21

Excel - Verweis auf spezifische Spaltenüberschrift, wenn Suchwort in Spalte gefunden wurde?

Hallo zusammen, euer Rudelwissen ist gefragt. Ich murkse jetzt schon seit einigen Tagen immer wieder an dieser Formel herum und komme zu keinem Ergebnis. Ich möchte eine Auswertung machen und die Formel soll folgende Kriterien erfüllen:

  1. das Suchwort "x" soll je Zeile gesucht werden
  2. wenn es gefunden wurde, soll der Name der Spalte, in der das "x" steht ausgegeben werden
  3. bei mehreren "x"en immer den Spaltenname des 1. "x" nehmen
  4. wenn kein "x" gefunden wird, dann ausgeben: "siehe Kommentarfeld"

Ich habe einen Screenshot des Tabelleblatts gemacht und hoffe ihr könnt helfen.

Vielen Dank vorab für eure Hilfe!!!

Expertenantwort
von Oubyi, Community-Experte für Excel, 17

Teste mal diese Formel in L9 und runterkopieren:

=INDEX($C$8:$K$8;;VERGLEICH($L$7;C9:K9;0))

Kommentar von Oubyi ,

Sorry, hatte das vergessen:

wenn kein "x" gefunden wird, dann ausgeben: "siehe Kommentarfeld"

Teste mal:

=WENN(ZÄHLENWENN(C9:K9;$L$7)=0;"Siehe Kommtentarfeld";INDEX($C$8:$K$8;VERGLEICH($L$7;C9:K9;0)))

Kommentar von Labasan1701 ,

Sorry, dass ich mich jetzt erst melde. War viel Stress in den letzten beiden Wochen und ich musste die Auswertung verschieben.

Die Formel funktioniert!!! Vielen, vielen DANK!

Kommentar von Oubyi ,

Gern geschehen ☼

Antwort
von Funfroc, 16

Hallo,

schau mal hier: http://www.excelformeln.de/formeln.html?welcher=25

Das sollte der Ansatz für dein Problem sein. Um deinen Punkt 4 noch zu erfüllen, musst du das ganze in eine WENNFEHLER-Funktion einbetten.

Viel Erfolg.

LG, Chris

Kommentar von Labasan1701 ,

Hi Chris,
dank dir.

Aber irgendwie funktioniert es nicht so recht :(
Ich glaube ich stehe mit beiden Beinen fest auf dem Schlauch.

Viele Grüße

Kommentar von Funfroc ,

Hallo,

ok, dachte, du bekommst es damit schon hin.

Hier die Formel, soweit ich alles richtig verstehe:

=WENNFEHLER(INDEX($C$8:$J$8;VERGLEICH($L$7;$C9:J9;0));"siehe Kommentarfeld")


Schau dir auf jeden Fall mal die Syntax der einzelnen Funktionen an. Es ist immer besser, die Formel nicht nur anzuwenden, sondern auch reproduzieren zu können.

LG, Chris

Kommentar von Labasan1701 ,

Hi Chris,
Dir auch, Danke!
Formel funktioniert.
Bin nicht früher dazu gekommen sie auszuprobieren bzw. die Auswertung zu machen.
Hast mir auf jeden Fall sehr geholfen :)
LG, Larissa

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten