Frage von EnibasNamdre, 49

Die Aufgabe lautet: Ermitteln Sie in der Spalte J mit Hilfe einer dreifach verschachtelten WENN-Funktion, der Funktion UND sowie der Funktion HEUTE, ob:?

  1. die Rechnung bezahlt wurde, dann soll in der Zelle (J2) der Text "erledigt" erscheinen
  2. die Rechnung nur zum Teil bezahlt wurde; dann soll in der Zelle der Text "prüfen" stehen
  3. dem Kunden eine Zahlungserinnerung zugestellt werden sollte, da er das Zahlungsziel zumindest um drei Tage überschritten hat, dann soll in der Zelle der Text "ja" stehen ansonsten soll in der Zelle der Text "nein" erscheinen.

Aufgabe 1 und 2 bekomme ich gelöst. Eine dreifach Verschachtelung habe ich auch noch hinbekommen, aber ich komme jetzt bei den Funktionen UND, HEUTE nicht weiter. Ich weiss nicht wo ich diese in der Formel reinpacken muss um die 3. Aufgabe zulösen.

Meine Formel in Spalte J: WENN(M2=0;"erledigt";WENN(HEUTE()-H2>$J$13;"prüfen";WENN(UND(M7>0;(HEUTE()-H2)>$J$13);"ja";" nein")))

Kann mir bitte jemand helfen?

Expertenantwort
von Ninombre, Community-Experte für Excel, 27

Für 1. ist es aus meiner Sicht schon passend gelöst.
Für 2. ist nach meinem Verständnis nicht der zeitliche Verzug relevant, sondern dass es eine Zahlung gab (aber der Betrag in M nicht 0 ist). Also eigentlich eine UND-Bedingung: M2 > 0 UND I2 > 0. Da Excel nach der ersten passenden Bedingung in einer verschachtelten Wenn-Bedingung nicht mehr weitersucht, ist der Fall schon abgedeckt, dass eine vollständige Zahlung vorliegt. Die Bedingung I2 > 0 reicht somit für "prüfen".
Für 3. ist die Zeit relevant, da sehe ich aber eher Spalte G als richtig, weil nicht interessiert, wann eine Teilzahlung kam, sondern wann die Rechnung fällig war. Ansonsten ist Deine Formel richtig mit heute()-G2>=$J$13

Im Hinblick auf Deine Frage zu der anderen Antwort: Verschachteln musst Du wenn alle drei Aufgaben in einer Formel abgedeckt werden sollen. Denn nach dem wenn - dann - SONST kannst Du keine weiteren Abfragen mehr aufnehmen, die Wenn-Formel ist dann zu Ende.

=WENN(M2=0;"erledigt";WENN(I2>0;"prüfen";WENN(UND(M2>0;HEUTE()-H2>J$13);"ja";"nein")))

Kommentar von EnibasNamdre ,

Danke für die ausführliche Antwort.

Laut Aufgabenstellung soll ich ja alle drei Aufgaben verschachteln.

(Ermitteln Sie in der Spalte J mit Hilfe einer dreifach verschachtelten WENN-Funktion, der Funktion UND sowie der Funktion HEUTE, ob)

Deswegen komm ich nicht weiter. In der Spalte J soll als Text entweder "erledigt", "prüfen", "ja" oder "nein" erscheinen

Kommentar von Ninombre ,

Aus meiner Sicht wäre es doch mit der genannten Formel erfüllt. Das sind drei Wenn Bedingungen, UND sowie Heute. Es können die vier Ergebnisvarianten herauskommen.

Expertenantwort
von Oubyi, Community-Experte für Excel, 28

Wieso baust Du bei "prüfen" das Datum mit ein? Davon steht nichts in der Aufgabe.
Da musst Du nur prüfen, ob M2<D2 ist. Oder?
Bei "ja"/"nein" ist M7 wohl ein Tippfehler?! M2 ist sinnvoll!
Solltest Du HEUTE() nicht eher mit G2 vergleichen?
Die UND-Konstruktion für ja/nein kommt mir ok vor.

Hilft Dir das weiter?
Sonst lade mal eine Beispieltabelle bei einem Upload-Service hoch.

Kommentar von EnibasNamdre ,

Wenn ich die Aufgabe richtig verstande habe. Soll bei Aufgabe 1+2 "erledigt bzw. prüfen stehen, das wäre dann diese Formel (WENN(M3=0;"erledigt";"prüfen") das bekomme ich hin.

Aber um die 3. Aufgabe zu berücksichtigen muß ich dafür doch eine verschachtelte WENN Funktion benutzten, hier soll ja ausgeworfen werden ob ich eine Zahlungserinnerung schreiben muß (als Text "ja") oder nicht (als Text "nein")

Wie kann ich eine Beispieldatei  hochladen?

Kommentar von Oubyi ,

Dazu musst Du einen Upload-Service (z.B. http://www.file-upload.net) nutzen und dann hier den Link einstellen.

Antwort
von Spirit528, 23

Ohne das Dokument ist es schwierig.

3. soll wohl in 1. und 2. eingebaut werden? Also landet die ebenso in der J-Spalte.

Kommentar von EnibasNamdre ,

Ja genau. Und da liegt mein Problem.

Wenn ich die Aufgabe richtig verstande habe. Soll bei Aufgabe 1+2
"erledigt bzw. prüfen stehen, das wäre dann diese Formel
(WENN(M3=0;"erledigt";"prüfen") das bekomme ich hin.

Aber um die 3. Aufgabe zu berücksichtigen muß ich dafür doch eine
verschachtelte WENN Funktion benutzten, hier soll ja ausgeworfen werden ob ich eine Zahlungserinnerung schreiben muß (als Text "ja") oder nicht (als Text "nein")

Wie kann ich hier das Dokument bzw. die Datei einfügen?

Kommentar von Spirit528 ,

Andere Dateien als Bilder kann man hier nicht hochladen.

= WENN(UND($M$2>0;$I$2=0;HEUTE()-H2)>$J$13$);"ja";WENN($M$2=0;"erledigt";WENN($I$2>0;"prüfen";"nein")))
Kommentar von EnibasNamdre ,

Vielen lieben Dank spirit528. 

Genau das hab ich gebraucht, jetzt hab ich auch meinen Denkfehler gefunden.

😙💓

Kommentar von Spirit528 ,

Gerne.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten