Frage von Jackdri, 106

Zu viele argumente bei wenn funktion bei excel 2010?

=WENN(Tabelle3!A6=1;Tabelle3!B6;"";WENN(Tabelle3!A7=1;Tabelle3!B7;"";Wenn(Tabelle3!A10=1;Tabelle3!B10;"";Wenn(Tabelle3!A11=1;Tabelle3!B11;"";Wenn(Tabelle3!A12=1;Tabelle3!B12;"";Wenn(Tabelle3!A13=1;Tabelle3!B13;"";Wenn(Tabelle3!A14=1;Tabelle3!B14;"")))))))

Es sind nicht mehr als 7 Argumente

Könnt ihr mir sagen was daran falsch ist ich komme nicht drauf

ps. bei 2 argumenten sagt er schon "zu viel Argumente"

Danke im voraus

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 69

Ganz am Anfang hast du schon ein Fehler

=WENN(Tabelle3!A6=1;Tabelle3!B6;"";WENN...)
          Arg1         Arg2     Arg3 Arg4

Das sind 4 Argumente. Die WENN-Funktion erwartet maximal 3 Argumente. Salopp gesprochen das Wenn-, Dann- und Sonstargument. So würde man auch sprechen. Wenn das Feld A6 der Tabelle 3 gleich 1 ist, dann nimm das Feld B6 aus Tabelle 3, sonst lass die Zelle leer.
Wofür sollte denn der letzte Parameter bei dir stehen?

Antwort
von PWolff, 63

Die WENN-Funktion erwartet 1 bis 3 Argumente.

7 sind zu viel. Aber die WENN-Funktion lässt sich auch schachteln, wie du auch angefangen hast.

Vermutlich sind die ersten Leerstrings zu viel.

Antwort
von Minilexikon, 67

Du schreibst in deiner Formel

=WENN(Tabelle3!A6=1;Tabelle3!B6;"";WENN(...

Die beiden Anführungszeichen nach dem B6 sind aber bereits das DANN-Argument. Somit hast du vier statt drei Argumenten.

=WENN(Tabelle3!A6=1;Tabelle3!B6;WENN(...

So müsste es gehen. Du verschachtelst weitere Funktionen immer im DANN-Parameter; tust du es im vierten, kommt ein Fehler, weil die Funktion nur maximal drei akzeptiert.

Kommentar von Minilexikon ,

Ich muss mich korrigieren: Immer wenn ich explizit vom DANN-Argument gesprochen habe, meinte ich eigentlich das SONST-Argument. Keine Ahnung, was mich da geritten hat^^

Antwort
von Jackie251, 41

Die Lösung ist ja schon vorhanden, daher nur der Hinweis, das diese Wenn Verschachtelung recht fragwürdig ist. Je nachdem was in den 2 Leerzeilen (A8/A9) steht könnte man auch mit einem ganz normalen Sverweis/Index+Vergleich arbeiten.

Expertenantwort
von Oubyi, Community-Experte für Excel, 37

Falls Du es noch nicht hinbekommen hast:

=WENN(Tabelle3!A6=1;Tabelle3!B6;WENN(Tabelle3!A7=1;Tabelle3!B7;WENN(Tabelle3!A10=1;Tabelle3!B10;WENN(Tabelle3!A11=1;Tabelle3!B11;WENN(Tabelle3!A12=1;Tabelle3!B12;WENN(Tabelle3!A13=1;Tabelle3!B13;WENN(Tabelle3!A14=1;Tabelle3!B14;"")))))))

Das ließ sich ganz schnell mit dem Ersetzen-Tool aus Deiner Formel kreieren.

Antwort
von DustFireSky, 44

Du hast die Wenn Formel nicht verstanden :D

WENN => DANN => SONST!

Du hast aber in jedem WENN ein viertes Argument!

Lösche überall "";

Kommentar von Jackdri ,

danke das hatte mir "minilexikon" eben schon gesagt

Kommentar von DustFireSky ,

Haben zeitgleich die Antwort geschrieben. Dann passiert das schon mal....

Keine passende Antwort gefunden?

Fragen Sie die Community