Frage von DaveAlmeida, 77

Mit Excel ein Datum eintragen und 14 tage vor dem Datum eine Erinnerung erhalten.. Ist das möglich?

Hey hey..

gibt es die Möglichkeit mit Excel eine Tabelle zu erstellen, wo ich ein Datum eintrage und Excel mir dann 14 tage vor dem Eintreten des Datums eine Meldung zeigt??

Ich gebe Euch mal ein Beispiel:


Name...........................von.....................................bis...............................Status

Hans Müller.................20/11/2016.........................30/12/2016...................OK


Nun möchte ich das Excel mir 14 tage vor dem 30/12/2016 die Zelle wo "OK" steht mit "FEHLT" ändern

Wenn es möglich währe, sollte die Zelle komplett Rot werden

MFG Dave Almeida

Expertenantwort
von schmiddi1967, Community-Experte für Excel, 70

Ok, da du leider keine Zeilen oder Spalten Bezeichungen mit angegeben hast gehe ich mal davon aus das deine Datümer jetzt in Spalte C ab C3 stehen.

Dann in D3 folgende Formel:

=WENN(HEUTE()>C3-15;"FEHLT";"OK")

Dann noch oben über den Reiter Start auf bedingte Formatierung und dann auf Neue Regel "Nur Zellen formatieren, die enthalten", da weiter auf (siehe Bild unten) HIER NATÜRLICH DEN BEREICH ANPASSEN


Kommentar von DaveAlmeida ,

Danke für die schnelle Antwort..
Ich werde es morgen im Büro direkt ausprobieren.

Kommentar von schmiddi1967 ,

Gerne, wenn noch Fragen sind immer raus damit ;))

Kommentar von DaveAlmeida ,

Vielen dank.. ich hab auf ihren Profil gesehen das sie ihre Email hinterlassen haben.
Sollte ich weitere fragen haben werde ich mich bei ihrer hinterlegten Email melden :)

Kommentar von DaveAlmeida ,

Ps.. ich hab versehentlich auf dem pfeil nach unten geklickt (antwort nicht hilfreich) :(

Kommentar von schmiddi1967 ,

Alles gut, ist mir auch schon mal passiert. Dadurch geht für mich die Welt nicht unter :)) Klar, du kannst die Email Adresse gerne nutzen. Nur wenn das Thema für dich erledigt ist, bitte ich dich darum es hier auch als Antwort zu schreiben, damit das auch alle anderen wissen. OK?

Ps. Du brauchst mich nicht mit sie ansprechen, ich komme mir sonst so alt vor :))

Kommentar von DaveAlmeida ,

Ok :)
Eine Frage hätte ich noch..
Kann ich den Code den du für mich geschrieben hast auf eine komplette Zeile einrichten

=WENN(HEUTE()>C3-15;"FEHLT";"OK")
=WENN(HEUTE()>C4-15;"FEHLT";"OK")
=WENN(HEUTE()>C5-15;"FEHLT";"OK")

Und so weiter...

Kommentar von schmiddi1967 ,

Du meinst Spalte und nicht Zeile?

Dann nimm mal den:

=WENN(C3="";"";WENN(HEUTE()>C3-15;"FEHLT";"OK"))

Den kannst du einfach so weit runter ziehen wie du ihn brauchst, sobald in Spalte C kein (bis) Datum steht wird auch in D nichts angezeigt. Sonst würde da überall Fehlt stehen.


Kommentar von schmiddi1967 ,

Ich habe noch was für dich, das musst du dann in deinem Tabellenblatt in den VBA Modus einbauen. Das überwacht die ganze Spalte C, sobald du da ein Datum einträgst, schreibt er automatisch die Formel in die Spalte D. Sprich du brauchst die da gar nicht eintragen und auch nicht lange runterziehen. Falls das für dich in Frage hier die Beschreibung dafür:

In deinem Tabellenblatt unten auf den Reiter (eventuell Tabelle1) und dann mit der rechten Maustaste auf Code anzeigen.

Dort kommt dann folgender Code im rechten Bereich rein:

Sub worksheet_change(ByVal target As Range)
Dim rngBereich As Range
Set rngBereich = Intersect(target, Range("C:C"))

If Not rngBereich Is Nothing Then
Dim rngZelle As Range
For Each rngZelle In rngBereich.Cells
If Not IsEmpty(rngZelle) Then rngZelle.Offset(0, 1).FormulaR1C1 = "=IF(RC[-1]="""","""",IF(TODAY()>RC[-1]-15,""FEHLT"",""OK""))"
Next rngZelle
End If
End Sub

Jetzt musst du deine Datei noch speichern, das machst du oben auf der Diskette. Da solltest du jetzt eine Fehlermeldung bekommen, welche du mit Nein beantworten musst und im folgenden Fenster deine Datei als xlsm Datei (Excel Arbeitsmappe mit Makros) abspeichern. Dann kannst du das Fenster einfach wieder schliessen.

Die bedingte Formatierung musst du dann noch auf den Bereich

=$D:$D

erweitern.

Falls du damit nicht klar kommst, immer raus damit.

Kommentar von DaveAlmeida ,

Hey schmiddi ich hab das was du mir gestern erklärt hast heute im Büro ausprobiert und es hat super geklappt.. Ich werde jetzt ein Kommentar schreiben das alle wissen das ich schon geholfen wurde..

Ich schreibe dir heute eine email mit weiteren Fragen wenn es ok ist :)

Kommentar von schmiddi1967 ,

Schön das es geklappt hat, was hast du genau genommen. Die Formel oder die VBA Lösung? Email geht natürlich in Ordnung.

Kommentar von DaveAlmeida ,

Ich hab erstmal die Formel benutzt =WENN(HEUTE()>C3-15;"FEHLT";"OK")

Ich hatte heute nicht genügt Zeit gehabt und die anderen auch noch zu testen.. Bevor ich aber alle durchteste werde ich dir per Email schreiben was ich alles noch machen will.. Nicht das ich dir 100 Fragen stelle und am Ende wir dann Feststellen das viele Fragen mit einer einzigen Formel lösbar sind XD

Kommentar von schmiddi1967 ,

Wie bereits geschrieben ist das beste die letzte Variante, da brauchst du keine Formeln in die Zellen schreiben. Das passiert da alles automatisch sobald du da ein Datum eingetragen hast.

Expertenantwort
von Iamiam, Community-Experte für Excel, 39

formal für eine Hilfreichste, auch wenn Du pessimistisch bist...

Kommentar von schmiddi1967 ,

:))))))

Keine passende Antwort gefunden?

Fragen Sie die Community