Frage von kaliesch, 67

Excel: Zählenwenn Zelle mit der Zahl "x" beginnt?

Ich benötige einmal Hilfe bei Excel? Ich habe eine Excel-Tabelle in der 141 Zeilen mit verschiedenen Postleitzahlen.

Jetzt will ich mit mit Excel eine Auswertung machen wie viele PLZ mit der Zahl z.B. 9 beginnen.

kann mir jemand helfen?

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 58

Wenn die PLZ numerisch sind, kannst du mit ZÄHLENWENN auf ">=90000" abfragen. Ansonsten kannst du Platzhalter verwenden. Ohne es testen zu können, versuch mal "9????".

Kommentar von Funfroc ,

Als Platzhalter funktioniert alternativ auch "9****"

In beiden Fällen müsste aber als Text formatiert sein.

Kommentar von Suboptimierer ,

Ein Stern repräsentiert eine beliebige Anzahl an Zeichen. Deswegen reicht hier ein Stern.

Kommentar von Funfroc ,

ach ja, stimmt

Antwort
von Funfroc, 51

Hallo,

entweder Zählenwenn, wie von Suboptimierer vorgeschlagen, oder du machst das einfach über den normalen Autofilter und filterst nach "beginnt mit".

LG, Chris

Antwort
von BilenKisi, 34

Versuch es mal mit makro programmierung. Du machst eine "for" schleife und in diese Schleife bestimmst du mit "if" anweisung was er durchsuchen und ausgeben soll. Bei dir wäre "9????" der Fall. Vergiss nicht die ausgabezeile immer mit +1 zu erhöhen. Wenn du es denn nicht mit Makro willst dann würde ich es mit "sverweis" probieren.

Expertenantwort
von Ninombre, Community-Experte für Excel, 41

=SUMMENPRODUKT((LINKS(A1:A141;1)="9")*1)

wäre noch eine Variante

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten