Frage von bilominati, 57

Excel: Zählenwenn ansonsten leer?

Hi!

Excel Problem:

In der Zelle AJ21 soll mir angezeigt werden, wie oft der Buchstabe "U" in dem Bereich E21 bis AI21 eingetragen wurde. Wenn er kein mal eingetragen wurde, soll die Zelle AJ21 leer bleiben..

also irgendwie eine zählenwenn gekoppelt mit wenn-dann wahrscheinlich.. danke für eure hilfe!!

Expertenantwort
von Iamiam, Community-Experte für Excel, 34

wenn es Dir nur um das wie oft geht, dann

=Zählenwenn(auszuwertender Bereich;"*u*")

Allerdings werden Zellen mit 2U nur einmal gezählt und U=u angenommen.

Willst Du Doppelnennungen auch doppelt erfassen, musst Du für jede infragekommende Anzahl das dazuaddieren:

+Zählenwenn(Bereich;"*u*u*") und
+Zählenwenn(Bereich;"*u*u*u*") etc.

Der Stern ist die "Wildcard" für beliebig viele Zeichen davor, danach  und dazwischen, auch für gar keins. Lin OO/LO musst Du anstatt nur * ein .* angeben

Für genau 1 Zeichen steht ? bzw .?

Kommentar von Iamiam ,

"...ansonsten leer?":

=wenn(Zählenwenn(auszuwertender Bereich;"*u*")<1;"";hier alle obigen Formeln soweit gewünscht)

zum Testen als Wenn-Bedingung reicht die eine Formel, als sonst so viele mit + aneinanderhängen, wie absehbar nötig.

Wenn Du übrigens wissen willst, wie viele u's aus Zellen mit 2 zwei oder drei u's stammen, einfach die zugehörige zählenwenn-Formel in der Bearbeitungszeile überstreichen (markieren) und F9 drücken, ablesen, im Kopf mit Zahl der u's/Zelle multiplizieren und dann die Zelle mit Esc wieder verlassen.

Antwort
von Schwimmakademie, 30

ist "U" der vollständge Zellinhalt oder nur ein Teil davon.


Es sollte im FaLL A EIGENTLICH MIT



Wenn(ZÄHLENWENN("E21:AJ21;"U") = 0;0;ZÄHLENWENN("E21:AJ21;"U"))



klappen.

Kommentar von Iamiam ,

mit "*U*" klappt beides.

Kommentar von Schwimmakademie ,

Es muss natürlich AI heissen. nicht AJ in der Formel. Ferner ist das "0" falsch, Es Muss "" heissen, wenn die Zelle leer bleiben soll:


Wenn(ZÄHLENWENN("E21:AI21;"U") = 0;"";ZÄHLENWENN("E21:AI21;"U"))


Kommentar von bilominati ,

ich danke dir!

Antwort
von bilominati, 19

erstmal danke an alle! ich glaube, ich habe mich eingangs schlecht ausgedrückt oder ich check es selber nicht..

eigentlich bin ich mit der formel =ZÄHLENWENN(E21:AI21;"U") schon am ziel meiner wünsche.. das einzige, was mir nicht gefällt ist, dass wenn es in dem
o.g. bereich kein einziges "U" gibt, mir logischerweise eine "0"
angezeigt wird. Hier möchte ich aber, dass dort dann nichts steht, also
eine leere zelle :)

possible? danke euch!

Kommentar von Oubyi ,

Das leistet die Kommentarformel von Schwimmakademie:
[mit kleiner Korrektur:]

=WENN(ZÄHLENWENN(E21:AI21;"U")=0;"";ZÄHLENWENN(E21:AI21;"U"))

Kommentar von bilominati ,

perfekt, danke!!

Antwort
von Wooria, 30

Hallo,

ich habe es gerade mal ausprobiert.

Mit einer Wenn-Dann-Funktion kommst du nicht weiter.

Du brauchst eine "Zählenwenn-Funktion". Du benötigst einen Bereich in dem Excel deine Us zählt.

=ZÄHLENWENN(A2:A29;"U")

Du musst nur deine benötigten Zellen einfügen, dann sollte es hin hauen. ;-)


Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten