Excel Wenn Funktion mit beliebigen Zahlen?

... komplette Frage anzeigen

3 Antworten

Über SVERWEIS oder so (die in Spalte E)
=VERWEIS(B1;{"April";"August";"Dezember";"Februar";"Januar";"Juli";"Juni";"Mai";"März";"November";"Oktober";"September"};{1;2;3;4;5;6;7;8;9;10;11;12})

Wichtig: Die Monate müssen alphabetisch aufsteigend sein, egal wie Du sie abkürzt! Wenn Du sie als Zahlen hast, auch aufsteigend, aber ohne die "".

An die Stelle von 1;2;3 trägst Du die Zahlen ein, die tatsächlich verwendet werden sollen.

Die geschwungenen Klammer müssen um die Auswahl der Monate und der Ergebnisse stehen.

SVERWEIS solltest Du auch kennen lernen (da Du ja einiges zu tun scheinst in Excel):
Dafür legst Du eine kleine Tabelle an, eine Spalte die Monate und daneben der jeweilige Wert. Wenn die Tabelle bspw. in G1:H12 steht gehört in E1

=SVERWEIS(B1;G$1:H$12;2;FALSCH)

Damit wird der Wert aus B1 in der Tabelle gesucht (in der 1. Spalte) und der Wert auf der zweiten Spalte (H) zurückgeliefert. Die $ verhindern, dass beim Runterkopieren der Formel in die anderen Zeilen von E die Position der Tabelle, in der Gesucht werden soll, mitverändert wird.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von ROHMNI1
07.12.2015, 13:25

Hab die erste Formel genommen und mit Pivottabelle kenne ich mihc mittlerweile schon aus nur die muss man ja mit Daten füttern deshalb danke für deine Formel

0

Soll für August immer die gleiche Zahl in Spalte E ausgegeben werden oder kann diese unterschiedlich sein?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von ROHMNI1
07.12.2015, 11:48

immer die gleiche. Am besten wäre wenn Excel schaut ob Februar da steht wenn ja dann 5 hinschreibt wenn nicht soll es schaun ob es März ist wenn ja dann 166 schreiben wenn nicht soll es schaun ob es April ist und so weiter

0

Was möchtest Du wissen?