Excel Tabelle in eine lange Zeile verwandeln?

... komplette Frage anzeigen

4 Antworten

Ich habe gerade auf diese Frage hier geantwortet:
https://www.gutefrage.net/frage/wie-kann-ich-in-excel-viele-zellen-einer-spalte-miteinander-verketten-gibt-es-die-moeglichkeit-bestimmte-bereiche-automatisch-zu-einer-zelle-zusammenzufuegen?foundIn=list-answers-by-user#answer-223973196
Das ist ein ähnliches Problem.
Hilft Dir das vlt. schon weiter?
Sonst beschreibe mal den Aufbau Deine Tabelle genauer oder - noch besser - lade ein Beispiel hoch.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Aliasat
05.10.2016, 14:40

Danke ich versuchs erst Mal mit deiner Antwort. Wie kann ich hier denn Bilder hochladen? Bin neu hier :)

0

Wie ist definiert, was zu einem Namen gehört?

Wenn es feste Abstände sind, ginge es wie im Bild gezeigt.

A1 bis A... stehen die Informationen unter einander.

Ab B1
=WENN(REST(ZEILE(B1);4)=1;INDEX($A$1:$A$1000;ZEILE(B1)+SPALTE(B1)-2;1);"")

Anschließend kopieren, als Werte einfügen und die leeren Zeilen über den Filter sortieren / löschen

Die Abfrage von rest(zeile(b1);4)=1 sorgt dafür, dass nur jede 5 Zeile Einträge erhält. Mit Spalte (B2)-2 kannst Du die Formel einfach in die anderen Spalten ziehen und musst manuell nichts in der Formel anpassen

Wenn es kein fester Aufbau ist, dann hilft diese Lösung nix. Wenn es mehr oder weniger als meine verwendeten 4 Angaben sind (Name, Str, PLZ, Ort) muss man die fettgedruckte 4 ändern.


Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Aliasat
05.10.2016, 16:43

Also ich glaube das ist schon der richtige Ansatz, in meiner Tabelle gibt es 3 Spalten nebeneinander und ca. 15 Zeilen darunter die ich dann in eine lange Zeile verwandeln will wo abwechselnd die jeweiligen Spalten kommen.

Vorher

[URL=http://www.directupload.net/file/d/4499/w8izzdpx\_png.htm][IMG]http://fs5.directupload.net/images/161005/temp/w8izzdpx.png[/IMG][/URL]

Nachher

[URL=http://www.directupload.net/file/d/4499/xazhnd4b\_png.htm][IMG]http://fs5.directupload.net/images/161005/temp/xazhnd4b.png[/IMG][/URL]

0

Damit es keinbe Missverständnisse gibt: Willst Du den Namen und alle Daten aneinandergehängt in EINER ZELLE stehen haben oder in verschiedenen Zellen in einer ZEILE?

Geht beides, sind aber unterschiedliche Lösungsansätze, und weil beides recht aufwändig ist, frag ich vorher!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Aliasat
06.10.2016, 09:40

Das zweite: Daten in verschiedenen Zellen aber in einer Zeile

0
Kommentar von Iamiam
07.10.2016, 00:00

Da Du ausser der Namensspalte nur 2 Spalten auszulesen hast, schlage ich eine ganz konventionelle Lösung vor:

Erst mal Bestimmst Du die maximale Häufigkeit eines Namens mit der Formel: {=MAX(ZÄHLENWENN(A:A;A:A))}

Achtung, Matrixformel! Nicht mit Enter eingeben, sondern mit Strg+Shift+Enter (ohne geschweifte {Klammern} und bei jeder Korrektur wieder! Nimm die rechten Tasten, dann gehts mit 1 Hand und lässt sich leichter merken))

Die Formel findet das maximale Auftreten eines Namens. Du schreibst was von 15x, dann musst Du 30 Formeln schreiben. Ist zwar Arbeit, aber die automatische Erstellung ist auch viel Arbeit und bleibt lange Zeit undurchsichtig.)

Nun schreibst Du in D2 diese Formel

=WENN(UND($A2<>$A1;A3=A2);$B3;".")

und in E2: =WENN(UND($A2<>$A1;A3=A2);$C3;".")

In F2 dann: =WENN(UND($A2<>$A1;A4=A2);$B4;".")

und in G2: =WENN(UND($A2<>$A1;A4=A2);$C4;".")

erkennst Du schon die Systematik? wenn noch nicht,

dann in H2: =WENN(UND($A2<>$A1;$A5=$A2);$B5;".")

und in i2: =WENN(UND($A2<>$A1;$A5=$A2);$C5;".")

in Worten: Nach einem Namenswechsel ist zu prüfen, ob der Name 1, 2, 3,... Zeilen darunter noch derselbe ist. Wenn ja, dann hole die Daten aus 1. 2, 3., ... Zeilen darunter. Das Ganze für 15 Zeilen => 30 Spalten.

Nun markierst Du D2:Enderechts und "ziehst"(kopierst) die Formel nach unten, über die gesamte Tabellenlänge. Es sind jetzt immer nur die Zeilen des ersten Auftretens des Namens gefüllt, sonst stehen überall Punkte.

Nun markierst Du den gesamten Formelbereich, kopierst ihn und fügst ihn an selber Stelle ALS WERTE wieder ein.

Nun musst Du noch die überflüssigen Zeilen loswerden:

dazu fügst Du vor Spalte A eine neue ein und schreibst ins neue A2:

=B1<>B2

das ergibt bei jedem Wechsel ein WAHR, sonst lauter FALSCH.

Spalte wieder kopieren und ALS WERTE wieder an selber stelle einfügen, dann die gesamte Tabelle nach dieser Spalte sortieren.

Die gesammelten FALSCH-Zeilen kannst Du nun löschen, übrig bleiben die relevanten WAHR-Zeilen. Danach kannst Du Spalte A wieder löschen.

Sollte Deine Tabelle doch komplizierter sein, v. allem mehr DatenSpalten enthalten, dann melde Dich und schreib aber, wieviele Spalten ausgewertet werden müssen (mit Spaltenbuchstaben-Angabe der Datenspalten, der Name in A bleibt ja einmalig je Zeile)

Dann lohnt sich nämlich doch die automatisierte Formelerstellung.

0

Was möchtest Du wissen?