Excel 2007 --> Das häufigste Wort in einer Liste ausgeben lassen?

... komplette Frage anzeigen

6 Antworten

Für dein Beispiel:

In Zelle B1:
=ZÄHLENWENN($A$1:$A$7;A1)
Diese Formel ziehst du nach unten bis B7

In der Zelle, in der du das Ergebnis ausgeben möchtest:
=INDEX(A1:A7;VERGLEICH(MAX(B1:B7);B1:B7;0))

Antwort bewerten Vielen Dank für Deine Bewertung

Das geht ohne VBA nur über INDEX-Funktion. Verschachtelt mit WENN, HÄUFIGKEIT, MAX.

Schau mal hier: http://www.office-loesung.de/ftopic27843_0_0_asc.php

Nicht genau dein Problem, aber auf die Schnelle mal ein Ansatz, wie man sowas lösen kann.

INDEX ist jetzt nicht ganz trivial, vor allem mit den Klammern,

Antwort bewerten Vielen Dank für Deine Bewertung

Lösungsvorschlag:

{=INDEX(A1:A7;VERGLEICH(MAX(ZÄHLENWENN(A1:A7;A1:A7));(ZÄHLENWENN(A1:A7;A1:A7));0))}

Achtung:

die geschwungenen Klammern am Anfang und Ende müssen dort stehen aber nicht manuell in die Formel eingeben...

Daher die Formel mit "STRG"+"SHIFT"+"ENTER" abschließen, dann werden die geschwungenen Klammern gesetzt - sonst erhälst Du eine Fehlermeldung!!

Antwort bewerten Vielen Dank für Deine Bewertung

=INDEX(A:A;MODALWERT(WENN(A1:A99<>"";VERGLEICH(A1:A99;A1:A99;0))))

Achtung! Formel mit Strg + Shift + Enter abschließen!

Antwort bewerten Vielen Dank für Deine Bewertung